View Issue Details

IDProjectCategoryView StatusLast Update
0014132LazarusLazReportpublic2011-12-01 11:25
ReporterBoguslaw BrandysAssigned ToJesus Reyes 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformwindowsOSwindows xp homeOS Version32-bit
Product VersionProduct BuildLazarus 0.9.27 r20829 FPC 2.3.1  
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0014132: PNG picture transparency is not used when printing report
DescriptionWhen I use PNG picture with transparent color somehow I can set it to be transparent in lazreport preview (more or less) but in designer and in printout it turn out to have white background again.

Also fill and frame color if transparent is not saved into report file for tfrPictureView.
Tagslazreport
Fixed in Revision28585
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Activities

2009-07-11 15:06

 

test.jpg (69,100 bytes)
test.jpg (69,100 bytes)

2009-07-11 15:06

 

test.lrf (28,071 bytes)

2009-07-11 15:06

 

test.pdf (24,989 bytes)

2009-07-11 15:06

 

test.png (11,845 bytes)
test.png (11,845 bytes)

Boguslaw Brandys

2009-07-11 15:13

developer   ~0029051

When I try to print from preview of report on Xerox printer Phaser 3117 PNG picture doesn't appear at all on printed page.It could be because fillcolor is set to transparent ?

Jesus Reyes

2010-12-01 23:14

developer   ~0043866

requires powerpdf 0.9.6

Issue History

Date Modified Username Field Change
2009-07-11 15:05 Boguslaw Brandys New Issue
2009-07-11 15:05 Boguslaw Brandys Status new => assigned
2009-07-11 15:05 Boguslaw Brandys Assigned To => Jesus Reyes
2009-07-11 15:05 Boguslaw Brandys LazTarget => -
2009-07-11 15:05 Boguslaw Brandys Widgetset => Win32/Win64
2009-07-11 15:06 Boguslaw Brandys File Added: test.jpg
2009-07-11 15:06 Boguslaw Brandys File Added: test.lrf
2009-07-11 15:06 Boguslaw Brandys File Added: test.pdf
2009-07-11 15:06 Boguslaw Brandys File Added: test.png
2009-07-11 15:13 Boguslaw Brandys Note Added: 0029051
2009-07-11 18:41 Boguslaw Brandys Priority high => normal
2009-08-21 11:39 Paul Ishenin LazTarget - => 0.9.30
2009-08-21 11:39 Paul Ishenin Target Version 0.9.29 (SVN) => 0.9.30
2010-03-15 03:57 Jesus Reyes Tag Attached: lazreport
2010-12-01 23:14 Jesus Reyes Fixed in Revision => 28585
2010-12-01 23:14 Jesus Reyes Status assigned => resolved
2010-12-01 23:14 Jesus Reyes Fixed in Version => 0.9.29 (SVN)
2010-12-01 23:14 Jesus Reyes Resolution open => fixed
2010-12-01 23:14 Jesus Reyes Note Added: 0043866
2011-12-01 11:25 Marc Weustink Status resolved => closed