View Issue Details

IDProjectCategoryView StatusLast Update
0014137PackagesLazReportpublic2013-09-28 04:24
ReporterBoguslaw Brandys Assigned ToJesus Reyes  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformwindowsOSwindows xp home 
Target Version1.2.0Fixed in Version1.3 (SVN) 
Summary0014137: Saving as FastReport template is incorrect. When creating new report based on template application crash
DescriptionFirst crash is when template has assigned bitmap:

               FPImageException - Wrong image format
                 $00478603 TFPCUSTOMIMAGEREADER__IMAGEREAD, line 233 of src/fphandler.inc
                 $00474535 TFPIMAGEBITMAP__READSTREAM, line 131 of ./include/fpimagebitmap.inc
                 $00466E76 TRASTERIMAGE__LOADFROMSTREAM, line 435 of ./include/rasterimage.inc
                 $00474AF2 TBITMAP__LOADFROMSTREAM, line 148 of ./include/bitmap.inc
                 $00466D93 TRASTERIMAGE__LOADFROMSTREAM, line 414 of ./include/rasterimage.inc
                 $00596BD3 TFRREPORT__LOADTEMPLATE, line 7906 of lr_class.pas
                 $00686FCC TFRTEMPLFORM__LISTBOX1CLICK, line 83 of lr_newrp.pas
                 $004C70D4 TCONTROL__CLICK, line 2227 of ./include/control.inc
                 $00518121 TCUSTOMLISTBOX__CLICK, line 624 of ./include/customlistbox.inc
                 $004C6E2D TCONTROL__WMLBUTTONUP, line 2116 of ./include/control.inc
                 $0051759D TCUSTOMLISTBOX__WMLBUTTONUP, line 306 of ./include/customlistbox.inc
                 $0040B3FE TOBJECT__DISPATCH, line 465 of E:/projekty/fpc/rtl/inc/objpas.inc
                 $004BDCE2 TWINCONTROL__WNDPROC, line 4914 of ./include/wincontrol.inc
                 $005440B7 DELIVERMESSAGE, line 111 of lclmessageglue.pas
                 $004E36FE WINDOWPROC, line 2571 of win32callback.inc
                 $7E368734
                 $7E368816

Second crash is when template has no bitmap and occur when new report is created based on template.Application starts to consume huge amount of memory and need to be killed or consume all available memory after a long time.No exception this time looks like infinite loop.
Tagslazreport
Fixed in Revision42996
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Activities

Renato Ricci

2011-12-30 17:08

reporter   ~0055379

I am having the same problem..

Issue History

Date Modified Username Field Change
2009-07-12 16:05 Boguslaw Brandys New Issue
2009-07-12 16:05 Boguslaw Brandys Status new => assigned
2009-07-12 16:05 Boguslaw Brandys Assigned To => Jesus Reyes
2009-07-12 16:05 Boguslaw Brandys LazTarget => -
2009-07-12 16:05 Boguslaw Brandys Widgetset => Win32/Win64
2010-03-15 04:07 Jesus Reyes Tag Attached: lazreport
2011-12-30 17:08 Renato Ricci Note Added: 0055379
2012-02-04 11:29 Zeljan Rikalo LazTarget - => 1.2
2013-09-14 00:42 Martin Friebe Target Version 0.9.27 (SVN) => 1.2.0
2013-09-28 04:24 Jesus Reyes Fixed in Revision => 42996
2013-09-28 04:24 Jesus Reyes Status assigned => resolved
2013-09-28 04:24 Jesus Reyes Fixed in Version => 1.3 (SVN)
2013-09-28 04:24 Jesus Reyes Resolution open => fixed