View Issue Details

IDProjectCategoryView StatusLast Update
0014188FPCDatabasepublic2011-10-01 13:41
ReporterJohn Campbell Assigned ToJoost van der Sluis  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Summary0014188: TSqlquery.locate raises SIGSEGV when record not found
DescriptionAttempting a locate with TSqlquery connected to TPQConnections component. If the record is found all is well. If record is not found an error "External SIGSEGV" is raised.
Additional InformationI upgraded to 0.9.26.2 to see if this would solve the problem - it hasn't :(

I'm having some trouble working out why nobody else has raised this - locate is surely a very commonly used procedure. Maybe it only occurs with a postgresql database. The version of the database is 8.0.13. OS is Mandriva 2009.1

Using KDE4 so I think the widget set will be QT.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId0
FPCTarget
Attached Files

Activities

Felipe Monteiro de Carvalho

2010-07-21 09:20

developer   ~0039535

Please provide a full compilable example with database files if necessary

John Campbell

2010-10-23 01:45

reporter   ~0042013

Apologies for the delay - gave up waiting and reverted to Kylix! I shall try to produce a suitable example soon.

Marco van de Voort

2011-06-16 20:09

manager   ~0049158

Last edited: 2011-06-16 20:09

Last call for closing with "no feedback".

Btw, meanwhile Lazarus 0.9.30 came out

Marco van de Voort

2011-10-01 13:41

manager   ~0052322

No reaction on (repeated) request for program after 3 months -> Close for administrative reasons.

If you have new information please reopen, or file a new ticket.

Issue History

Date Modified Username Field Change
2009-07-24 14:43 John Campbell New Issue
2009-07-24 14:43 John Campbell Widgetset => QT
2009-07-28 04:03 Paul Ishenin Project Lazarus => FPC
2009-07-28 10:03 Jonas Maebe FPCOldBugId => 0
2009-07-28 10:03 Jonas Maebe Category Database => Database Components
2009-07-28 10:03 Jonas Maebe Product Version 0.9.26.2 =>
2009-07-28 10:03 Jonas Maebe Status new => assigned
2009-07-28 10:03 Jonas Maebe Assigned To => Joost van der Sluis
2010-07-21 09:20 Felipe Monteiro de Carvalho Note Added: 0039535
2010-07-21 09:20 Felipe Monteiro de Carvalho Status assigned => feedback
2010-10-23 01:45 John Campbell Note Added: 0042013
2011-06-16 20:09 Marco van de Voort Note Added: 0049158
2011-06-16 20:09 Marco van de Voort Note Edited: 0049158
2011-10-01 13:41 Marco van de Voort Status feedback => resolved
2011-10-01 13:41 Marco van de Voort Resolution open => unable to reproduce
2011-10-01 13:41 Marco van de Voort Note Added: 0052322