View Issue Details

IDProjectCategoryView StatusLast Update
0014326LazarusIDEpublic2010-05-12 09:45
ReporterGennadiy Assigned ToMartin Friebe  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN) 
Target Version0.9.28Fixed in Version0.9.27 (SVN) 
Summary0014326: Lazarus doesn't build
Descriptionmake all results in this

make[2]: Entering directory `C:/Dev/CygWin/root/home/Barvinok/lazarus/ide'
C:/Dev/FPC/2.3.1/bin/x86_64-win64/ppcx64.exe -gl -dlclwin32 -Fu../lcl/units/x86_64-win64 -Fu../lcl/units/x86_64-win64/win32 -Fu../components/codetools/units/x86_64-win64 -Fu../components/synedit/units/x86_64-win64 -Fu../components/custom -Fu../components/mpaslex -Fu../ideintf/units/x86_64-win64 -Fu../designer -Fu../debugger -Fu../debugger/frames -Fu../converter -Fu../packager -Fu../packager/frames -Fu../packager/units/x86_64-win64 -Fu../units/x86_64-win64 -Fuframes -Fu. -Fiinclude -Fiinclude/win64 -Fi../images -FE.. -FU../units/x86_64-win64 -WG -dx86_64 lazarus.pp
editoroptions.pp(3615,69) Error: Wrong number of parameters specified for call to "AddSpecialAttribute"
editoroptions.pp(3724) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
make[2]: *** [lazarus.exe] Error 1
make[2]: Leaving directory `C:/Dev/CygWin/root/home/Barvinok/lazarus/ide'
make[1]: *** [ide] Error 2
make[1]: Leaving directory `C:/Dev/CygWin/root/home/Barvinok/lazarus/ide'
make: *** [ide] Error 2
TagsNo tags attached.
Fixed in Revision21186
LazTarget0.9.28
Widgetset
Attached Files

Activities

Gennadiy

2009-08-12 12:14

reporter   ~0029773

This is latest (as of now) SVNed revision 21185

Vincent Snijders

2009-08-12 12:24

manager   ~0029774

Caused by r21184.

Martin Friebe

2009-08-12 13:48

manager   ~0029776

Sorry, missed a file
Fixed by Mattias in the meantime

Issue History

Date Modified Username Field Change
2009-08-12 12:13 Gennadiy New Issue
2009-08-12 12:13 Gennadiy Widgetset => Win32/Win64
2009-08-12 12:14 Gennadiy Note Added: 0029773
2009-08-12 12:23 Vincent Snijders Status new => assigned
2009-08-12 12:23 Vincent Snijders Assigned To => Martin Friebe
2009-08-12 12:24 Vincent Snijders LazTarget => -
2009-08-12 12:24 Vincent Snijders Severity major => block
2009-08-12 12:24 Vincent Snijders Summary Lazarus doesn't build for Win64 => Lazarus doesn't build
2009-08-12 12:24 Vincent Snijders Note Added: 0029774
2009-08-12 12:29 Vincent Snijders LazTarget - => 0.9.28
2009-08-12 12:29 Vincent Snijders Target Version => 0.9.28
2009-08-12 13:48 Martin Friebe Fixed in Revision => 21186
2009-08-12 13:48 Martin Friebe Widgetset Win32/Win64 =>
2009-08-12 13:48 Martin Friebe Status assigned => resolved
2009-08-12 13:48 Martin Friebe Fixed in Version => 0.9.27 (SVN)
2009-08-12 13:48 Martin Friebe Resolution open => fixed
2009-08-12 13:48 Martin Friebe Note Added: 0029776
2010-05-12 09:45 Gennadiy Status resolved => closed