View Issue Details

IDProjectCategoryView StatusLast Update
0014328LazarusLCLpublic2011-12-01 11:24
Reporterdelete meAssigned ToLuiz Americo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.26.3 (SVN)Product Build 
Target Version0.9.30Fixed in Version 
Summary0014328: TextAlignment of TDBEdit
DescriptionThe TextAlignment of TDBEdit is always set to left and is not changed by the alignment of the corresponding TField, i.e. the TextAlignment should be alRight if the TField is numeric.
Tagsdbcontrols
Fixed in Revision26786
LazTarget0.9.30
Widgetset
Attached Files

Relationships

duplicate of 0001179 closedLuiz Americo TDBEdit alignment 

Activities

delete me

2009-10-07 12:22

reporter   ~0031171

I have a solution for this bug. Add in the method TDBEdit.ActiveChange in dbedit.inc the '//*****' marked lines.
------------------------------------------------------------------------
procedure TDBEdit.ActiveChange(Sender: TObject);
begin
  if FDatalink.Active then begin
    if not (FDataLink.Field.DataType in [ftTime, ftTimeStamp, ftDate, ftDateTime, ftString]) then //*****
      Alignment := taRightJustify; //*****
    DataChange(Sender)
  end else begin
    Text := '';
    Alignment := taLeftJustify; //*****
    FDataLink.Reset;
  end;
end;

Paul Ishenin

2010-05-08 16:09

manager   ~0037361

It must get Alignment of TField and it needs to be set in DataChange.

Issue History

Date Modified Username Field Change
2009-08-12 15:02 delete me New Issue
2009-08-12 15:13 Vincent Snijders LazTarget => post 1.2
2009-08-12 15:13 Vincent Snijders Status new => acknowledged
2009-08-12 15:13 Vincent Snijders Relationship added has duplicate 0001179
2009-08-12 15:14 Vincent Snijders Relationship replaced duplicate of 0001179
2009-10-07 12:22 delete me Note Added: 0031171
2009-10-07 12:38 Vincent Snijders LazTarget post 1.2 => 0.9.30
2009-10-07 12:38 Vincent Snijders Assigned To => Jesus Reyes
2009-10-07 12:38 Vincent Snijders Status acknowledged => assigned
2009-10-07 12:38 Vincent Snijders Target Version => 0.9.30
2010-03-15 03:05 Jesus Reyes Tag Attached: dbcontrols
2010-05-08 16:09 Paul Ishenin Note Added: 0037361
2010-07-22 22:35 Luiz Americo Assigned To Jesus Reyes => Luiz Americo
2010-07-22 22:36 Luiz Americo Fixed in Revision => 26786
2010-07-22 22:36 Luiz Americo Status assigned => resolved
2010-07-22 22:36 Luiz Americo Resolution open => fixed
2011-12-01 11:24 Marc Weustink Status resolved => closed