View Issue Details

IDProjectCategoryView StatusLast Update
0014355LazarusDatabasepublic2011-12-01 10:25
Reporterindianajones Assigned ToJesus Reyes  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN) 
Target Version0.9.30 
Summary0014355: DBGrid Problem
Description
The example program is attached.
Database has 4 datas, the result of the sqlquery returns 4 datas, but datas are not displayed in the DBGrid.
Additional Information
Windows XP
FPC 2.2.5
Lazarus SVN 21182
Tagsdbgrids
Fixed in Revision
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Activities

2009-08-15 19:02

 

ProjectS.rar (487,670 bytes)

2009-08-15 19:04

 

data_screen.JPG (139,642 bytes)   
data_screen.JPG (139,642 bytes)   

indianajones

2009-08-15 19:04

reporter   ~0029877

MySQL Server 5.0.84

Jesus Reyes

2010-10-27 20:20

developer   ~0042220

Is this still an issue?

Checking the project files I noted that persistent fields were used, but it seems they are wrongly setup, FieldKind must be fkData instead they are fkCalculated, Datasets with calculated fields need an event OnCalcFields where calculated fields get its values. As in this example there is no OnCalcFields event, calculated fields are empty and so the grid is empty.

This is just theory, because as there is no script to recreate the database I have not tested.

indianajones

2010-10-28 12:58

reporter   ~0042249

can be closed, thanks.

Issue History

Date Modified Username Field Change
2009-08-15 19:02 indianajones New Issue
2009-08-15 19:02 indianajones File Added: ProjectS.rar
2009-08-15 19:02 indianajones Widgetset => Win32/Win64
2009-08-15 19:04 indianajones File Added: data_screen.JPG
2009-08-15 19:04 indianajones Note Added: 0029877
2009-08-17 14:24 Vincent Snijders LazTarget => 1.0
2009-08-17 14:24 Vincent Snijders Assigned To => Jesus Reyes
2009-08-17 14:24 Vincent Snijders Status new => assigned
2009-08-17 14:24 Vincent Snijders Target Version => 1.0.0
2010-03-15 02:59 Jesus Reyes Tag Attached: dbgrids
2010-10-27 20:20 Jesus Reyes LazTarget 1.0 => 0.9.30
2010-10-27 20:20 Jesus Reyes Note Added: 0042220
2010-10-27 20:20 Jesus Reyes Status assigned => feedback
2010-10-27 20:20 Jesus Reyes Target Version 1.0.0 => 0.9.30
2010-10-28 12:58 indianajones Note Added: 0042249
2010-11-19 09:51 Vincent Snijders Status feedback => resolved
2010-11-19 09:51 Vincent Snijders Resolution open => fixed
2011-12-01 10:25 Marc Weustink Status resolved => closed