View Issue Details

IDProjectCategoryView StatusLast Update
0014361LazarusIDEpublic2009-09-23 00:00
ReporterMartin Friebe Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionfixed 
Product Version0.9.27 (SVN) 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0014361: Form top/left reset to 0/0 when moved accross screens and resized
DescriptionUnfortunately this is not 100 % reproducible.

Having 2 screens: left to right. The left screen is the main screen, and start at coordinate 0,0, the right screen continues at 1600,0
(on vista)

- Create a new application (in my case this places the window on the left screen.
- Move the window to the right screen
- Resize the window

When you start resizing the upper left corner is set to 0,0 the right bottom si resized normally => result in an utlra big window across 2 screens.

Top and left are both updated in the OI while moving the form, so I suspect that either designer top/left are not updated, or they are checked against the bounds of a single screen without taking in account that the coordinates of the 2nd screen do not start at 0,0.
TagsNo tags attached.
Fixed in Revision21777
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

has duplicate 0014636 closedPaul Ishenin Problem while resizing forms 

Activities

Swen Heinig

2009-08-16 14:55

developer   ~0029907

I can confirm this with several Lazarus versions under Windows XP. As Martin said, this happens only sometimes.

Paul Ishenin

2009-08-16 18:05

manager   ~0029913

I also noticed but never had an ability to reproduce it.

Zeljan Rikalo

2009-09-19 19:27

developer   ~0030840

Sometimes it happens under linux too (qt)

Paul Ishenin

2009-09-20 06:47

manager   ~0030844

Please test and close if ok.

Tomasz Wieckowski

2009-09-20 19:02

reporter   ~0030863

It seems to be fixed, at least for me.

Martin Friebe

2009-09-23 00:00

manager   ~0030921

seems good, no longer reproducible. Strange though, because I couldn't reproduce with afew days before fix revision neither...

Issue History

Date Modified Username Field Change
2009-08-16 14:47 Martin Friebe New Issue
2009-08-16 14:47 Martin Friebe LazTarget => -
2009-08-16 14:47 Martin Friebe Widgetset => Win32/Win64
2009-08-16 14:55 Swen Heinig Note Added: 0029907
2009-08-16 18:05 Paul Ishenin Note Added: 0029913
2009-08-17 16:49 Vincent Snijders LazTarget - => 1.0
2009-08-17 16:49 Vincent Snijders Status new => acknowledged
2009-08-17 16:49 Vincent Snijders Target Version => 1.0.0
2009-09-19 18:30 Paul Ishenin Relationship added has duplicate 0014636
2009-09-19 19:27 Zeljan Rikalo Note Added: 0030840
2009-09-20 06:47 Paul Ishenin Fixed in Revision => 21777
2009-09-20 06:47 Paul Ishenin Status acknowledged => resolved
2009-09-20 06:47 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2009-09-20 06:47 Paul Ishenin Resolution open => fixed
2009-09-20 06:47 Paul Ishenin Assigned To => Paul Ishenin
2009-09-20 06:47 Paul Ishenin Note Added: 0030844
2009-09-20 19:02 Tomasz Wieckowski Note Added: 0030863
2009-09-23 00:00 Martin Friebe Status resolved => closed
2009-09-23 00:00 Martin Friebe Note Added: 0030921