View Issue Details

IDProjectCategoryView StatusLast Update
0014379LazarusFCLpublic2009-08-20 16:00
ReporterJorge Turiel Assigned ToVincent Snijders  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Summary0014379: TFloatSpinEdit and TSpinEdit lost value when lost focus
DescriptionIn a application, when you enter a number using the keyboard, they lost the number that you typed.
Steps To ReproducePut a TFloatSpinEdit or TFloatEdit, in a form, compile por WinCe. Click on it, use keyboard to enter a number. Then click in other control or in the form. You will see that the control lost the value that you entered and restore the original value.
Of course the value are into the maximun and minimun values.
Additional InformationIf you the same test in application for win32 the controls doesn't lost the value, it keeps the value that you typed.

I upload a small test.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0014378 closedFelipe Monteiro de Carvalho TFloatSpinEdit and TSpinEdit lost value when lost focus 

Activities

Jorge Turiel

2009-08-20 16:00

reporter   ~0030029

This issue is duplicate of 0014378, so I close this issue.

Issue History

Date Modified Username Field Change
2009-08-18 19:32 Jorge Turiel New Issue
2009-08-18 19:39 Marco van de Voort Project FPC => Lazarus
2009-08-19 11:32 Vincent Snijders LazTarget => -
2009-08-19 11:32 Vincent Snijders Relationship added duplicate of 0014378
2009-08-19 11:32 Vincent Snijders Duplicate ID 0 => 14378
2009-08-19 11:32 Vincent Snijders Status new => resolved
2009-08-19 11:32 Vincent Snijders Resolution open => duplicate
2009-08-19 11:32 Vincent Snijders Assigned To => Vincent Snijders
2009-08-20 16:00 Jorge Turiel Status resolved => closed
2009-08-20 16:00 Jorge Turiel Note Added: 0030029