View Issue Details

IDProjectCategoryView StatusLast Update
0014405LazarusIDEpublic2011-12-01 11:22
Reporterciuly Assigned ToMattias Gaertner  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.26.2 
Fixed in Version0.9.27 (SVN) 
Summary0014405: Cannot find an existing directory while compiling indy package
DescriptionI am trying to build latest indy with lazarus (made some adjustments, still in testing) on winxp sp2.
I compiled system fine. Then I went to Core and that's where it hit me hard. Core depends on system so there is a dependency which is set up correctly. However, it cannot find files from system.
So I went to package options and made sure the system directory is there and when saving those directories (that is package options (general options), usage 3 dots from unit box, modify paths then click ok) I get this error message: "Directory blabla not found."

I reduced the test scenario even more:
- I moved the indy to a close-to-root path: e:\indy
- I opened up system package which compiles and went to options and removed the trailing slash from the usage unit path so it picks up the change and tries to validate it
- clicking ok will raise the error.

So, as you can see from the screenshot, not only does the System directory exist, but lazarus has the system package open from it. So it's kind of stupid that it doesn't find it.
This happens with all the packlages I have, no matter in what directroy I place them.
Additional InformationThis is not necessarely the reason why I cannot compile the core package but it might be. In any case this is a bug and should be fixed.
I'll try to debug the core package compilation issue to see if it's another problem or not and if so I'll log another bug.
TagsNo tags attached.
Fixed in Revision21390
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

2009-08-21 19:13

 

existing-dir-not-found-3.JPG (108,910 bytes)   
existing-dir-not-found-3.JPG (108,910 bytes)   

Issue History

Date Modified Username Field Change
2009-08-21 19:13 ciuly New Issue
2009-08-21 19:13 ciuly File Added: existing-dir-not-found-3.JPG
2009-08-21 19:13 ciuly Widgetset => Win32/Win64
2009-08-22 16:54 Mattias Gaertner Fixed in Revision => 21390
2009-08-22 16:54 Mattias Gaertner LazTarget => -
2009-08-22 16:54 Mattias Gaertner Assigned To => Mattias Gaertner
2009-08-22 16:54 Mattias Gaertner Status new => resolved
2009-08-22 16:54 Mattias Gaertner Resolution open => fixed
2009-09-07 12:29 Vincent Snijders Fixed in Version => 0.9.27 (SVN)
2011-12-01 11:22 Marc Weustink Status resolved => closed