View Issue Details

IDProjectCategoryView StatusLast Update
0014423LazarusIDEpublic2011-01-04 15:27
ReporterStefan Müller Assigned ToMattias Gaertner  
PrioritynormalSeverityfeatureReproducibilityN/A
Status assignedResolutionreopened 
Summary0014423: Feature request for IDE FPDoc Editor: document overloaded operators
DescriptionCurrently there seems to be no possibility to enter or edit documentation of overloaded operators in FPDoc Editor, although fpdoc can handle this.
Additional InformationI'll provide an example. My operator is declared as

    operator + (dp1: TPoint; dp2: TPoint) dps: TPoint;

The corresponding part of the description file would look like

      <element name="operator +(TPoint, TPoint): TPoint">
        <short>Componentwise sum of two vectors</short>
        <descr>And a descrption of course...</descr>
      </element>
      <element name="operator +(TPoint, TPoint): TPoint.dp1">
        <short>Left argument, vector</short>
      </element>
      <element name="operator +(TPoint, TPoint): TPoint.dp2">
        <short>Right argument, vector</short>
      </element>
      <element name="operator +(TPoint, TPoint): TPoint.Identifier dps">
        <short>Operator result</short>
      </element>
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0015120 resolvedMattias Gaertner FPDoc-Editor: when saving changes, XML validity must be checked, otherwise error in fpdoc 

Activities

Stefan Müller

2011-01-04 15:27

reporter   ~0044866

Thank you very much for the effort that has been put into this.

I tested this feature with SVN revision 28865, fpdoc from FPC 2.4.2. There are still the following issues. Consider the above example.

(1) It is now possible to enter documentation with FPDocEditor for "dp1", "dp2" and "dps" by placing the cursor on them, but it is not possible to enter general information about the operator:

  <element name="operator +(TPoint, TPoint): TPoint">
    <short>Componentwise sum of two vectors</short>
    <descr>And a descrption of course...</descr>
  </element>

from the above example can not be entered via FPDocEditor, as far as I can see.

(2) It is possible to enter documentation for "Result" in the FPDocEditor when placing the cursor over the third "TPoint". This should be removed, as the node

  <element name="operator +(TDoublePoint, TDoublePoint): TDoublePoint.Result"/>

is not considered by fpdoc. Instead, the node for "dps" could be presented for editing here, too.

(3) The generated XML-nodes are not correct. Spaces cannot be dropped and the separator between parameters has to be a comma instead of a semicolon. E.g. FPDocEditor would now generate the node

  <element name="operator+(TPoint;TPoint):TPoint.Identifier dps"/>
    <short>Operator result</short>
  </element>

which is wrong. I.e. fpdoc does not generate documentation for the operator because it looks for a node like this:

  <element name="operator +(TPoint, TPoint): TPoint.Identifier dps">
    <short>Operator result</short>
  </element>

Issue History

Date Modified Username Field Change
2009-08-24 12:30 Stefan Müller New Issue
2009-08-24 20:16 Vincent Snijders LazTarget => -
2009-08-24 20:16 Vincent Snijders Assigned To => Mattias Gaertner
2009-08-24 20:16 Vincent Snijders Status new => assigned
2009-11-17 18:49 Vincent Snijders Relationship added child of 0015120
2009-11-17 18:49 Vincent Snijders Relationship replaced related to 0015120
2010-11-28 14:29 Mattias Gaertner Status assigned => resolved
2010-11-28 14:29 Mattias Gaertner Resolution open => fixed
2010-11-28 14:29 Mattias Gaertner Additional Information Updated
2011-01-04 15:27 Stefan Müller Status resolved => assigned
2011-01-04 15:27 Stefan Müller Resolution fixed => reopened
2011-01-04 15:27 Stefan Müller Note Added: 0044866