View Issue Details

IDProjectCategoryView StatusLast Update
0014437LazarusDatabasepublic2009-09-10 22:41
ReporterJosé Mejuto Assigned ToJesus Reyes  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
Platformi386OSWindows 
Product Version0.9.27 (SVN) 
Summary0014437: SQLdb params bring down the IDE
DescriptionTrying to modify the "Params" of any SQL connection (Firebird, MySQL, Postgres,..) brings down the IDE in different ways.
Steps To ReproduceDrop a SQL connection control in a form, edit the "params" field and add any text, press "OK". If you do not get an Access Violation, you can try to "edit" the params again and the text list is empty.
Now try to exit the IDE, if you save you will get different streaming errors when trying to save with a final complete hangup which require a terminate process.
Additional InformationI was trying to trackdown the problem without success as my knows about the Object Inspector are limited.

Tested with 0.9.27 and 0.9.29 (today) and fcp 2.2.2, 2.4.0, 2.3.1 (about 2 weeks ago).

Setting params via code in the "BeforeConnection" event seems to work, so it looks more like a problem with the OI modifiying that particular TStrings.

Also "Params" in TSQLTransaction fails in the same way.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2, Win32/Win64
Attached Files

Relationships

related to 0014438 closedJoost van der Sluis FPC SQLDb Patch: Fix assignment to connection's params property when editing using lazarus strings editor. 

Activities

Jesus Reyes

2009-08-25 18:32

developer   ~0030146

I didn't get Access Violation, but I can confirm params was empty after second edit.

Jesus Reyes

2009-08-25 20:26

developer   ~0030149

Last edited: 2009-08-25 20:34

This is a fpc problem, already reported and a patch was proposed. I couldn't reproduce the problem in TSQLTransaction on fpc 2.5.1

José Mejuto

2009-08-25 23:06

reporter   ~0030152

I can confirm that your patch solves the problem for all SQLConnections and Transaction. I had also tested almost the same patch but it had a "beginner" error assigning directly instead intead using Assign and replacing the FParams TStrings instead changing its content :(
Thank you.

Vincent Snijders

2009-09-09 10:09

manager   ~0030561

Can this issue be closed?

José Mejuto

2009-09-09 22:14

reporter   ~0030575

No sorry, the patch has not been applied, so the current code state is the same as before the bug report.

Vincent Snijders

2009-09-10 06:33

manager   ~0030583

José, I may consider this issue as not-fixable in Lazarus, so this issue might as well be closed, nothing we can do about it. You can monitor the related fpc issue.

José Mejuto

2009-09-10 12:11

reporter   ~0030593

OOops, you are right. I had posted it in Lazarus as at my first look I think it was an Object Inspector problem, which finally it is fpc's db.pas problem.

Fron Lazarus point of view it can be considered to not-fixable unless something can be added to the OI to detect that kind of problems, I think there are a bunch of similar properties published without getter/setter which can not be modified in OI without corrupting memory (most times not error or crash displayed).

If you think that something can be added to the OI let me know in the mailing list (or private mail) and I'll put a new bug report about that "problem".

Please resolve to not-fixable and directly close it. Thank you.

Issue History

Date Modified Username Field Change
2009-08-25 18:08 José Mejuto New Issue
2009-08-25 18:08 José Mejuto Widgetset => GTK 2, Win32/Win64
2009-08-25 18:32 Jesus Reyes LazTarget => -
2009-08-25 18:32 Jesus Reyes Note Added: 0030146
2009-08-25 18:32 Jesus Reyes Status new => confirmed
2009-08-25 20:23 Jesus Reyes Status confirmed => assigned
2009-08-25 20:23 Jesus Reyes Assigned To => Jesus Reyes
2009-08-25 20:25 Jesus Reyes Relationship added related to 0014438
2009-08-25 20:26 Jesus Reyes Note Added: 0030149
2009-08-25 20:34 Jesus Reyes Note Edited: 0030149
2009-08-25 23:06 José Mejuto Note Added: 0030152
2009-09-09 10:09 Vincent Snijders Note Added: 0030561
2009-09-09 20:32 Jesus Reyes Status assigned => resolved
2009-09-09 20:32 Jesus Reyes Resolution open => no change required
2009-09-09 22:14 José Mejuto Status resolved => assigned
2009-09-09 22:14 José Mejuto Resolution no change required => reopened
2009-09-09 22:14 José Mejuto Note Added: 0030575
2009-09-10 06:33 Vincent Snijders Note Added: 0030583
2009-09-10 12:11 José Mejuto Note Added: 0030593
2009-09-10 17:53 Jesus Reyes Status assigned => resolved
2009-09-10 17:53 Jesus Reyes Resolution reopened => not fixable
2009-09-10 22:41 José Mejuto Status resolved => closed