View Issue Details

IDProjectCategoryView StatusLast Update
0014452LazarusLCLpublic2009-09-03 10:16
ReporterTsvetoslav Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSwindows 
Product Version0.9.27 (SVN) 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0014452: Labels in GroupBox in TabSheet disappear if Tab key used
DescriptionIf you have labels placed in a GroupBox, which is on a TabSheet of a PageControl, and use "Tab" key to move around, the labels disappear. If you switch to another TabSheet and back to the first TabSheet, the labels appear again and do not vanish anymore.
Steps To ReproduceCompile and run the attached project. Now use "Tab" key to move to Edit2 edit control - the labels "Label3" and "Label4" disappear! After a while, if you move the mouse over the edit controls or switch to TabSheet2 and back to TabSheet1, the labels appear again and do not vanish anymore.
TagsNo tags attached.
Fixed in Revision21550
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Activities

2009-08-28 15:25

 

LabelsTestProj.zip (221,327 bytes)

Paul Ishenin

2009-09-03 09:33

manager   ~0030355

Please test and close if ok.

Tsvetoslav

2009-09-03 10:16

reporter   ~0030358

I can't reproduce it anymore, so it must be fixed. Thanks!

Issue History

Date Modified Username Field Change
2009-08-28 15:25 Tsvetoslav New Issue
2009-08-28 15:25 Tsvetoslav File Added: LabelsTestProj.zip
2009-08-28 15:25 Tsvetoslav Widgetset => Win32/Win64
2009-08-31 12:04 Vincent Snijders LazTarget => 1.0
2009-08-31 12:04 Vincent Snijders Status new => acknowledged
2009-08-31 12:04 Vincent Snijders Target Version => 1.0.0
2009-09-03 09:33 Paul Ishenin Fixed in Revision => 21550
2009-09-03 09:33 Paul Ishenin Status acknowledged => resolved
2009-09-03 09:33 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2009-09-03 09:33 Paul Ishenin Resolution open => fixed
2009-09-03 09:33 Paul Ishenin Assigned To => Paul Ishenin
2009-09-03 09:33 Paul Ishenin Note Added: 0030355
2009-09-03 10:16 Tsvetoslav Status resolved => closed
2009-09-03 10:16 Tsvetoslav Note Added: 0030358