View Issue Details

IDProjectCategoryView StatusLast Update
0014486LazarusIDEpublic2011-12-01 11:22
ReporterAndreas SchneiderAssigned ToVincent Snijders 
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0014486: Wrong translated item "Build" in the german lazarus menu.
DescriptionThe menu item "Build" in the lazarus menu has been translated to "Lazarus kompilieren" in the german language file, instead of just "Kompilieren".

The attached patch should fix that.
TagsNo tags attached.
Fixed in Revision21563
LazTarget-
Widgetset
Attached Files
  • lang_de.diff (432 bytes)
    Index: languages/lazaruside.de.po
    ===================================================================
    --- languages/lazaruside.de.po	(Revision 21540)
    +++ languages/lazaruside.de.po	(Arbeitskopie)
    @@ -7985,7 +7985,7 @@
     #: lazarusidestrconsts.lismenubuild
     msgctxt "lazarusidestrconsts.lismenubuild"
     msgid "Build"
    -msgstr "Lazarus kompilieren"
    +msgstr "Kompilieren"
     
     #: lazarusidestrconsts.lismenubuildall
     msgid "Build all"
    
    lang_de.diff (432 bytes)
  • lang_de2.diff (552 bytes)
    Index: languages/lazaruside.de.po
    ===================================================================
    --- languages/lazaruside.de.po	(Revision 21540)
    +++ languages/lazaruside.de.po	(Arbeitskopie)
    @@ -7985,11 +7985,11 @@
     #: lazarusidestrconsts.lismenubuild
     msgctxt "lazarusidestrconsts.lismenubuild"
     msgid "Build"
    -msgstr "Lazarus kompilieren"
    +msgstr "Kompilieren"
     
     #: lazarusidestrconsts.lismenubuildall
     msgid "Build all"
    -msgstr "Alles komplieren"
    +msgstr "Alles kompilieren"
     
     #: lazarusidestrconsts.lismenubuildfile
     msgid "Build File"
    
    lang_de2.diff (552 bytes)

Activities

2009-09-02 21:57

 

lang_de.diff (432 bytes)
Index: languages/lazaruside.de.po
===================================================================
--- languages/lazaruside.de.po	(Revision 21540)
+++ languages/lazaruside.de.po	(Arbeitskopie)
@@ -7985,7 +7985,7 @@
 #: lazarusidestrconsts.lismenubuild
 msgctxt "lazarusidestrconsts.lismenubuild"
 msgid "Build"
-msgstr "Lazarus kompilieren"
+msgstr "Kompilieren"
 
 #: lazarusidestrconsts.lismenubuildall
 msgid "Build all"
lang_de.diff (432 bytes)

2009-09-02 21:59

 

lang_de2.diff (552 bytes)
Index: languages/lazaruside.de.po
===================================================================
--- languages/lazaruside.de.po	(Revision 21540)
+++ languages/lazaruside.de.po	(Arbeitskopie)
@@ -7985,11 +7985,11 @@
 #: lazarusidestrconsts.lismenubuild
 msgctxt "lazarusidestrconsts.lismenubuild"
 msgid "Build"
-msgstr "Lazarus kompilieren"
+msgstr "Kompilieren"
 
 #: lazarusidestrconsts.lismenubuildall
 msgid "Build all"
-msgstr "Alles komplieren"
+msgstr "Alles kompilieren"
 
 #: lazarusidestrconsts.lismenubuildfile
 msgid "Build File"
lang_de2.diff (552 bytes)

Andreas Schneider

2009-09-02 22:00

reporter   ~0030338

I just noticed, that also the menu item right below that one contains a small typo (a missing 'i'). Fixed that too (lang_de2.diff).

Swen Heinig

2009-09-02 23:23

developer   ~0030342

The current translation is an intent (and should not be changed without contacting Jörg).

Andreas Schneider

2009-09-03 11:56

reporter   ~0030362

I don't think it's intended to spell "kompilieren" as "komplieren". I also don't think that it makes sense to name the menu item that compiles the current project "Lazarus kompilieren" (which would translate to "Build lazarus") ... and I speak about the build process started with the F9 key, not the actual "Build lazarus" menu item.

Vincent Snijders

2009-09-03 12:02

manager   ~0030363

Swen, did you contact Jörg?

Swen Heinig

2009-09-04 11:14

developer   ~0030396

There was a misunderstanding from my side, because exact the same german translation is used on a second place (and there it should not be changend). Sorry for the inconvenience. I sent an updated po file to Vincent, which includes the suggested changes.

Vincent Snijders

2009-09-04 11:31

manager   ~0030398

Thanks for the patches.

Issue History

Date Modified Username Field Change
2009-09-02 21:57 Andreas Schneider New Issue
2009-09-02 21:57 Andreas Schneider File Added: lang_de.diff
2009-09-02 21:59 Andreas Schneider File Added: lang_de2.diff
2009-09-02 22:00 Andreas Schneider Note Added: 0030338
2009-09-02 23:23 Swen Heinig Note Added: 0030342
2009-09-03 11:56 Andreas Schneider Note Added: 0030362
2009-09-03 12:02 Vincent Snijders Note Added: 0030363
2009-09-04 10:40 Vincent Snijders Status new => assigned
2009-09-04 10:40 Vincent Snijders Assigned To => Vincent Snijders
2009-09-04 11:14 Swen Heinig Note Added: 0030396
2009-09-04 11:31 Vincent Snijders Fixed in Revision => 21563
2009-09-04 11:31 Vincent Snijders LazTarget => -
2009-09-04 11:31 Vincent Snijders Status assigned => resolved
2009-09-04 11:31 Vincent Snijders Fixed in Version => 0.9.29 (SVN)
2009-09-04 11:31 Vincent Snijders Resolution open => fixed
2009-09-04 11:31 Vincent Snijders Note Added: 0030398
2011-12-01 11:22 Marc Weustink Status resolved => closed