View Issue Details

IDProjectCategoryView StatusLast Update
0014502LazarusIDEpublic2009-09-08 14:37
ReporterBurkhard CarstensAssigned ToPaul Ishenin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSlinuxOS Versionsuse 10.0
Product Version0.9.27 (SVN)Product Build21559 
Target Version0.9.28Fixed in Version0.9.29 (SVN) 
Summary0014502: Form Designer: Icons and Captions of non-visual components are not painted when the are placed above other components
DescriptionIf you place any non-visual component (e.g. TTimer, TOpenDialog) above some other component, the icon is not drawn (tested with TPanel, TGroupBox, TMemo).
If there are multiple non-visual components, the caption is only drawn for the first component, i.e. the second timer is completely invisible.
Steps To Reproduce- add TPanel to form, align=alClient
- add TTimer to form
- add TOpenDialog to form
--> caption of Timer1 is visible, but no icon
--> OpenDialog1 is completely invisible.
TagsNo tags attached.
Fixed in Revision21611
LazTarget0.9.28
WidgetsetGTK
Attached Files

Relationships

duplicate of 0014341 closedPaul Ishenin Components icons not showing correctly on GTK2 
related to 0014501 closedPaul Ishenin Grabber are sometimes shown only partly (bad-1) or not at all (bad-2) 

Activities

Burkhard Carstens

2009-09-04 22:15

reporter   ~0030421

Forgott to add: This is a regression!

Burkhard Carstens

2009-09-04 22:30

reporter   ~0030424

Unchecking "Reduce designer painting" in the form editor options allmost fixes this problem. Now only the first non-visual component has no icon, but at least a grey rectangle and all captions are drawn.

Paul Ishenin

2009-09-05 04:25

manager   ~0030432

This is duplicate of another issue. I don't remember it id.

Graeme Geldenhuys

2009-09-07 08:40

reporter   ~0030500

I can confirm this regression bug. It appears here under Lazarus+GTK2+Linux as well.

Paul Ishenin

2009-09-07 10:36

manager   ~0030505

Ok. If this is a regression then please help us to find which revision breaks correct drawing. Please also test with "Show component captions" unchecked in the ide options -> form editor

Burkhard Carstens

2009-09-07 22:02

reporter   ~0030522

Last edited: 2009-09-07 22:16

Tested using fpc-2.2.5 (fixes_2_2-r13173):
* lazarus r18804
  -> works fine
* lazarus r18805
  * TTimer does not have Frame3D when placed above a panel.
  * Icon is ok.
  * having one or more TTimers does not make any difference
 -> disable "Show component captions" does nothing (no captions
    for non-visual components yet)
 -> disable "Reduce designer painting" fixes the problem.

* lazarus r18806
  * TTimer does not have Frame3D when placed above a panel.
  * Icon is *not* visible but there is a grey area (no grid dots) where
    the icon should be.
  * TTimer caption is shown
  * second TTimer is not visible at all. No frame, no icon,
    no grey area, no caption.
 -> disable "Show component captions" changes nothing:
    * caption for timer1 is still visible
    * timer2 is still completely invisible
 -> disable "Reduce designer painting"
    * both timers have frame3D
    * both timers have caption (even though "Show component
      captions" is still disabled)
    * only the second timer has an icon, the first one still
      just has a grey area with frame.

Note: it seems, r18806 is also responsible for "grabber" problem described in 0014501 .. I'll retest and report there tomorrow.

Burkhard Carstens

2009-09-08 12:37

reporter   ~0030533

Tested with fpc-fixes_2_4-r13649 and lazarus-0_9_29-r21612-gtk1.

All seems fixed except TTimer on Panel has no Frame3D.
Disabling "Reduce designer painting" fixes the Frame3D.

However, this remaining issue is a minor problem. As far as I'm concerned, this report can be closed.

Burkhard Carstens

2009-09-08 14:37

reporter   ~0030542

Thank you very much! Please be sure to merge this into fixes_0_9_28.

Issue History

Date Modified Username Field Change
2009-09-04 22:13 Burkhard Carstens New Issue
2009-09-04 22:13 Burkhard Carstens Widgetset => GTK
2009-09-04 22:15 Burkhard Carstens Note Added: 0030421
2009-09-04 22:30 Burkhard Carstens Note Added: 0030424
2009-09-05 04:25 Paul Ishenin Note Added: 0030432
2009-09-07 08:40 Graeme Geldenhuys Note Added: 0030500
2009-09-07 10:08 Paul Ishenin Relationship added duplicate of 0014341
2009-09-07 10:36 Paul Ishenin Note Added: 0030505
2009-09-07 16:01 Vincent Snijders LazTarget => 0.9.28
2009-09-07 16:01 Vincent Snijders Status new => acknowledged
2009-09-07 16:01 Vincent Snijders Target Version => 0.9.28
2009-09-07 22:02 Burkhard Carstens Note Added: 0030522
2009-09-07 22:11 Burkhard Carstens Note Edited: 0030522
2009-09-07 22:16 Burkhard Carstens Note Edited: 0030522
2009-09-08 00:53 Paul Ishenin Relationship added related to 0014501
2009-09-08 12:37 Burkhard Carstens Note Added: 0030533
2009-09-08 14:34 Paul Ishenin Fixed in Revision => 21611
2009-09-08 14:34 Paul Ishenin Status acknowledged => resolved
2009-09-08 14:34 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2009-09-08 14:34 Paul Ishenin Resolution open => fixed
2009-09-08 14:34 Paul Ishenin Assigned To => Paul Ishenin
2009-09-08 14:37 Burkhard Carstens Status resolved => closed
2009-09-08 14:37 Burkhard Carstens Note Added: 0030542