View Issue Details

IDProjectCategoryView StatusLast Update
0014512LazarusIDEpublic2009-09-08 13:11
ReporterBurkhard Carstens Assigned ToPaul Ishenin  
PrioritynormalSeveritymajorReproducibilityrandom
Status closedResolutionfixed 
Platformi386OSlinux 
Product Version0.9.27 (SVN) 
Target Version0.9.28Fixed in Version0.9.29 (SVN) 
Summary0014512: lazarus sometimes crashes when deleting a memo while mouse is over this memo
Descriptionlazarus sometimes crashes when deleting a memo while mouse is over this memo.

TLazarusManager.Run starting /home/bork/FreePascal/lazarus/lazarus ...
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/home/bork/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
TMainIDE.DoNewProject A
TCustomFormEditor.CreateComponent Form1:TForm1 True
TMainIDE.DoNewEditorFile END unit1.pas
TFPDocEditForm.UpdateChain failed loading /home/bork/FreePascal/lazarus/unit1.pas
Parent is 'Form1:TForm1'
TCustomFormEditor.CreateComponent Memo1:TMemo True
TMainIDE.OnPropHookPersistentAdded A Memo1:TMemo
TPkgManager.AddUnitDependenciesForComponentClasses Extending Uses unit1.pas StdCtrls
[TEventsCodeTool.CompleteComponent] CurComponent=Memo1:TMemo
TFPDocEditForm.UpdateChain failed loading /home/bork/FreePascal/lazarus/unit1.pas
TApplication.HandleException Access violation
  Stack trace:
  $40248BF7
  $08157EBA
  $080C2BC8
  $080FEA7F
  $080FEAA4
  $080FEBCC
  $080FEC1E
  $0805EA3B
  $0805E687
  $080602EF
  $0806072F
  $080A8BF3
  $080606EA
  $080534E2

Gtk-CRITICAL **: file gtkwidget.c: line 3722 (gtk_widget_get_parent_window): assertion `widget->parent != NULL' failed.
lazarus.pp - unhandled exception
[TMainIDE.Destroy] A
[TMainIDE.Destroy] B -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END
Steps To Reproduce* add memo to form
* move mouse into memo
* press "DEL" key
-> crash (sometimes)
Additional Informationfpc: fpc-fixes_2_4-r13601
 
happens with
 * lazarus-fixes_0_9_28-r21559
 * lazarus-fixes_0_9_28-r21559 + fix in trunk r21569
TagsNo tags attached.
Fixed in Revision21608
LazTarget0.9.28
WidgetsetGTK
Attached Files

Activities

Burkhard Carstens

2009-09-07 10:48

reporter   ~0030507

Here is another output which contains lineinfo (for some unknown reason, this is sometimes missing)

TMainIDE.DoNewProject A
TCustomFormEditor.CreateComponent Form1:TForm1 True
TMainIDE.DoNewEditorFile END unit1.pas
TFPDocEditForm.UpdateChain failed loading /home/bork/FreePascal/lazarus/unit1.pas
Parent is 'Form1:TForm1'
TCustomFormEditor.CreateComponent Memo1:TMemo True
TMainIDE.OnPropHookPersistentAdded A Memo1:TMemo
TPkgManager.AddUnitDependenciesForComponentClasses Extending Uses unit1.pas StdCtrls
[TEventsCodeTool.CompleteComponent] CurComponent=Memo1:TMemo
TFPDocEditForm.UpdateChain failed loading /home/bork/FreePascal/lazarus/unit1.pas
TApplication.HandleException Access violation
  Stack trace:
  $086F4B24 GTK_IS_OBJECT_CLASS, line 254 of src/gtk/gtkobjects.pp
  $080C415D WINDOWFROMPOINT, line 900 of ./include/winapi.inc
  $080FEBC1 FINDLCLWINDOW, line 2590 of controls.pp
  $080FEC1E FINDCONTROLATPOSITION, line 2613 of controls.pp
  $0805EA3B TAPPLICATION__GETCONTROLATMOUSE, line 448 of ./include/application.inc
  $0805E687 TAPPLICATION__IDLE, line 322 of ./include/application.inc
  $080602EF TAPPLICATION__HANDLEMESSAGE, line 1136 of ./include/application.inc
  $0806072F TAPPLICATION__RUNLOOP, line 1269 of ./include/application.inc
  $080A8BF3 TWIDGETSET__APPRUN, line 49 of ./include/interfacebase.inc
  $080606EA TAPPLICATION__RUN, line 1257 of ./include/application.inc
  $080534E2 main, line 114 of lazarus.pp

Gtk-CRITICAL **: file gtkwidget.c: line 3722 (gtk_widget_get_parent_window): assertion `widget->parent != NULL' failed.
[TMainIDE.Destroy] A
[TMainIDE.Destroy] B -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END
[TGtkWidgetSet.Destroy] WARNING: There are 1 unreleased DCs, a detailed dump follows:
[TGtkWidgetSet.Destroy] DCs: 406C8030
[TGtkWidgetSet.Destroy] WARNING: There are 3 unreleased GDIObjects, a detailed dump follows:
[TGtkWidgetSet.Destroy] GDIOs: 410BD6E0 410BD680 410BD620
[TGtkWidgetSet.Destroy] gdiBrush: 1
[TGtkWidgetSet.Destroy] gdiFont: 1
[TGtkWidgetSet.Destroy] gdiPen: 1

Paul Ishenin

2009-09-08 08:59

manager   ~0030527

Please test and close if ok.

Burkhard Carstens

2009-09-08 13:11

reporter   ~0030538

Tested with fpc-fixes_2_4-r13649 and lazarus-0_9_29-r21612-gtk1.

Tried several times but could not reproduce the crash anymore, so this seems fixed.
Thanks.

Issue History

Date Modified Username Field Change
2009-09-05 15:41 Burkhard Carstens New Issue
2009-09-05 15:41 Burkhard Carstens Widgetset => GTK
2009-09-07 10:48 Burkhard Carstens Note Added: 0030507
2009-09-07 12:38 Vincent Snijders LazTarget => 0.9.28
2009-09-07 12:38 Vincent Snijders Status new => acknowledged
2009-09-07 12:38 Vincent Snijders Target Version => 0.9.28
2009-09-08 08:59 Paul Ishenin Fixed in Revision => 21608
2009-09-08 08:59 Paul Ishenin Status acknowledged => resolved
2009-09-08 08:59 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2009-09-08 08:59 Paul Ishenin Resolution open => fixed
2009-09-08 08:59 Paul Ishenin Assigned To => Paul Ishenin
2009-09-08 08:59 Paul Ishenin Note Added: 0030527
2009-09-08 13:11 Burkhard Carstens Status resolved => closed
2009-09-08 13:11 Burkhard Carstens Note Added: 0030538