View Issue Details

IDProjectCategoryView StatusLast Update
0014540LazarusIDEpublic2009-09-29 13:27
ReporterTsvetoslav Assigned ToPaul Ishenin  
PrioritynormalSeveritytweakReproducibilitysometimes
Status closedResolutionfixed 
Platformi386OSwindows 
Product Version0.9.29 (SVN) 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0014540: Error "[TCustomForm.SetFocus] : THintWindow Can not focus." when switching to Lazarus
DescriptionSometimes, when I work with Lazarus, then minimize it and work with another application (e.g. firefox, etc.) for 5-10 minutes and then switch back to Lazarus usually with Alt-Tab, I receive this error message

[TCustomForm.SetFocus] : THintWindow Can not focus.
Press OK to ignore and risk data corruption.
Pres Cancel to kill the program

( see the attached screenshot.)
Anyway, I don't know how exactly to reproduce this error, sometimes it occurs and sometimes it does not, seems to happen randomly.
TagsNo tags attached.
Fixed in Revision21859
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Activities

2009-09-08 14:56

 

Lazarus_Error1.png (39,239 bytes)   
Lazarus_Error1.png (39,239 bytes)   

Anton Kavalenka

2009-09-09 18:50

reporter   ~0030573

Also got:
[TCustomForm.SetFocus] : TSynBaseCompletionHint Can not focus."

Paul Ishenin

2009-09-25 12:03

manager   ~0030971

Please test and close if ok.

Tsvetoslav

2009-09-29 13:27

reporter   ~0031033

Since the issue was marked "resolved", I haven't seen the error anymore, so it seems the bug is fixed. Thanks!

Issue History

Date Modified Username Field Change
2009-09-08 14:56 Tsvetoslav New Issue
2009-09-08 14:56 Tsvetoslav File Added: Lazarus_Error1.png
2009-09-08 14:56 Tsvetoslav Widgetset => Win32/Win64
2009-09-09 08:10 Vincent Snijders LazTarget => 1.0
2009-09-09 08:10 Vincent Snijders Status new => acknowledged
2009-09-09 08:10 Vincent Snijders Target Version => 1.0.0
2009-09-09 18:50 Anton Kavalenka Note Added: 0030573
2009-09-25 12:03 Paul Ishenin Fixed in Revision => 21859
2009-09-25 12:03 Paul Ishenin Status acknowledged => resolved
2009-09-25 12:03 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2009-09-25 12:03 Paul Ishenin Resolution open => fixed
2009-09-25 12:03 Paul Ishenin Assigned To => Paul Ishenin
2009-09-25 12:03 Paul Ishenin Note Added: 0030971
2009-09-29 13:27 Tsvetoslav Status resolved => closed
2009-09-29 13:27 Tsvetoslav Note Added: 0031033