View Issue Details

IDProjectCategoryView StatusLast Update
0014554LazarusLCLpublic2009-09-14 16:08
ReporterLuca Olivetti Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
OSWindows XP 
Product Version0.9.29 (SVN) 
Target Version0.9.28Fixed in Version0.9.29 (SVN) 
Summary0014554: BorderStyle bsNone and WindowState wsMaximized don't work well together
DescriptionThe attached program sets BorderStyle:=bsNone and WindowState:=wsMaximized on form creation.
The form, instead of covering the whole screen, just covers the top left corner (i.e. it seems it isn't resized).
This is under windows XP, both with the classic theme and the windows xp (luna) one.
Bisecting I found that the problem was introduced in revision 20522 as a fix to bug 0013921.
TagsNo tags attached.
Fixed in Revision21648
LazTarget0.9.28
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0013921 closedPaul Ishenin Black fields and garbage when Windows 7 auto-resizing form 

Activities

2009-09-10 09:42

 

maximizebug.zip (2,341 bytes)

Paul Ishenin

2009-09-11 11:05

manager   ~0030620

Please test amd close if ok.

Luca Olivetti

2009-09-14 16:08

reporter   ~0030712

Tested ok. Thank you.

Issue History

Date Modified Username Field Change
2009-09-10 09:42 Luca Olivetti New Issue
2009-09-10 09:42 Luca Olivetti File Added: maximizebug.zip
2009-09-10 09:42 Luca Olivetti Widgetset => Win32/Win64
2009-09-10 12:07 Vincent Snijders LazTarget => 0.9.28
2009-09-10 12:07 Vincent Snijders Status new => acknowledged
2009-09-10 12:07 Vincent Snijders Target Version => 0.9.28
2009-09-10 12:08 Vincent Snijders Relationship added related to 0013921
2009-09-11 11:05 Paul Ishenin Fixed in Revision => 21648
2009-09-11 11:05 Paul Ishenin Status acknowledged => resolved
2009-09-11 11:05 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2009-09-11 11:05 Paul Ishenin Resolution open => fixed
2009-09-11 11:05 Paul Ishenin Assigned To => Paul Ishenin
2009-09-11 11:05 Paul Ishenin Note Added: 0030620
2009-09-14 16:08 Luca Olivetti Status resolved => closed
2009-09-14 16:08 Luca Olivetti Note Added: 0030712