View Issue Details

IDProjectCategoryView StatusLast Update
0014681FPCUtilitiespublic2010-11-23 20:04
ReporterMario Ray Mahardhika Assigned ToMarco van de Voort  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformi386OSwin32 
Product Version2.5.1 
Target Version2.4.2 
Summary0014681: Failed to build fcl.chm
Descriptiondoing make html HMTLFMT=chm in fpcbuild/fpcdocs gives:

Writing 1990 pages...
An unhandled exception occurred at $532E7265 :
EAccessViolation : Access violation
  $532E7265
  $00409EE2
  $00409EE2
  $00453B89 THTMLWRITER__WRITEDOC, line 3341 of dw_html.pp
  $00402D51 CREATEDOCUMENTATION, line 267 of fpdoc.pp
  $00402F57 main, line 290 of fpdoc.pp

make: *** [fcl.chk] Error 217
Additional Informationfrom readme.rev in fpcbuild:
URL: http://svn.freepascal.org/svn/fpcbuild/trunk
Revision: 686
Last Changed Rev: 683
URL: http://svn.freepascal.org/svn/fpc/trunk
Revision: 13718
Last Changed Rev: 13718
URL: http://svn.freepascal.org/svn/fpcdocs/trunk
Revision: 559
Last Changed Rev: 559
URL: http://svn.freepascal.org/svn/logs
Revision: 20163
Last Changed Rev: 20163
TagsNo tags attached.
Fixed in Revision16198
FPCOldBugId
FPCTarget
Attached Files

Activities

Marco van de Voort

2009-10-11 22:23

manager   ~0031263

Last edited: 2009-10-11 22:23

Under windows, I don't even manage to build the rtl one:

../fpc/rtl/unix/sockets.pp(20,15): Could not find include file 'osdefs.inc'
../fpc/rtl/unix/ipc.pp(26,15): Could not find include file 'osdefs.inc'
An unhandled exception occurred at $0046028A :
EFileNotFoundError : '../fpc/rtl/win32/classes.pp
  $0046028A TFILERESOLVER__FINDSOURCEFILE, line 393 of src/pscanner.pp
  $004606E7 TPASCALSCANNER__OPENFILE, line 467 of src/pscanner.pp
  $00402923 CREATEDOCUMENTATION, line 250 of fpdoc.pp
  $00402EF3 main, line 290 of fpdoc.pp

Note the forward slashes and the fact that it searches an unix path.

If I try to build the FCL using a .xct file from a build on unix (otherwise I don't even get as far as the FCL), it works fine though:

11-10-2009 22:22 779.581 fcl.chm


Did you make adaptations to the sources to be able to build it on windows, or can you give me any additional info?

Marco van de Voort

2009-10-27 07:16

manager   ~0031706

See earlier comment

Marco van de Voort

2010-08-10 12:19

manager   ~0040104

Can't really reproduce it with trunk. (I have to comment ezcgi for trunk to build, but that is about it)

If you have more info, please reopen.

Joost van der Sluis

2010-10-19 10:24

manager   ~0041912

I have this same problem with fpc 2.4.2rc1. The result is that the rpm's can't be build. Problem is that the error occurs 'randomly'. If I run the same command fpdoc-command over and over again, I think it fails in about 25% of the cases.

Trunk indeed doesn't have this problem.

Marco van de Voort

2010-10-19 11:18

manager   ~0041913

Last edited: 2010-10-19 13:57

Joost, do you have a more complete trace?

I happen to have been building chm docs with 2.5.1 all weekend, and had no problems.

So since RPM seems to exclude windows specific problems, it is either 2.4.x specific or html only.

I'll try to generate html docs with 2.4.x as soon as I have time.

Joost van der Sluis

2010-10-19 22:42

manager   ~0041920

I din't build chm, but latex. Re-build fpdoc with fcl-xml debuginfo gives this backtrace:

An unhandled exception occurred at $080993B0 :
EAccessViolation : Access violation
  $080993B0 TDOMNAMEDNODEMAP__FIND, line 1677 of src/dom.pp
  $0809945A TDOMNAMEDNODEMAP__GETNAMEDITEM, line 1699 of src/dom.pp
  $0809C74B TDOMELEMENT__GETATTRIBUTE, line 2832 of src/dom.pp
  $080B64B1 TLINEARWRITER__WRITETYPES, line 754 of dwlinear.pp
  $080B594E TLINEARWRITER__WRITEVARSCONSTSTYPES, line 547 of dwlinear.pp
  $080B5853 TLINEARWRITER__PROCESSSECTION, line 532 of dwlinear.pp
  $080B56F5 TLINEARWRITER__WRITEDOC, line 499 of dwlinear.pp
  $080498A6 CREATEDOCUMENTATION, line 268 of fpdoc.pp
  $08049AA4 main, line 291 of fpdoc.pp

There's an error message at the start too:

FPDoc - Free Pascal Documentation Tool
Version 2.4.2 [2010/10/17]
(c) 2000 - 2003 Areca Systems GmbH / Sebastian Guenther, sg@freepascal.org

TPascalScanner.Error /home/joost/git/fpc/master/fpcbuild-2.4.2rc1/fpcsrc/rtl/linux/
/home/joost/git/fpc/master/fpcbuild-2.4.2rc1/fpcsrc/rtl/unix/
/home/joost/git/fpc/master/fpcbuild-2.4.2rc1/fpcsrc/rtl/inc/
/home/joost/git/fpc/master/fpcbuild-2.4.2rc1/fpcsrc/rtl/i386/

../fpcsrc/rtl/bsd/sysosh.inc(26,40): Could not find include file 'pmutext.inc'
No documentation node found for identifier : #rtl.Classes.TFPListEnumerator.Create


This is the exact command I used, running in the fpcdocs directory of fpcbuild:

../fpcsrc/utils/fpdoc/fpdoc --output=rtl.inc --warn-no-node --package=rtl --descr=rtl.xml --content=rtl.xct --hide-protected --descr=strutils.xml --input="../fpcsrc/rtl/objpas/strutils.pp " --descr=sysutils.xml --input="../fpcsrc/rtl/unix/sysutils.pp -Fi../fpcsrc/rtl/objpas/sysutils -Fi../fpcsrc/rtl/inc " --descr=strings.xml --input="../fpcsrc/rtl/inc/strings.pp -Fi../fpcsrc/rtl/i386 -Fi../fpcsrc/rtl/inc " --descr=mouse.xml --input="../fpcsrc/rtl/unix/mouse.pp -Fi../fpcsrc/rtl/inc " --descr=keyboard.xml --input="../fpcsrc/rtl/unix/keyboard.pp -Fi../fpcsrc/rtl/inc " --descr=crt.xml --input="../fpcsrc/rtl/unix/crt.pp -Fi../fpcsrc/rtl/inc " --descr=video.xml --input="../fpcsrc/rtl/unix/video.pp -Fi../fpcsrc/rtl/inc " --descr=dos.xml --input="../fpcsrc/rtl/unix/dos.pp -Fi../fpcsrc/rtl/inc -dcpui386 " --descr=sockets.xml --input="-dver1_0 ../fpcsrc/rtl/unix/sockets.pp -Fi../fpcsrc/rtl/inc -Fi../fpcsrc/rtl/linux " --descr=objects.xml --input="../fpcsrc/rtl/inc/objects.pp -Fi../fpcsrc/rtl/i386 -Fi../fpcsrc/rtl/linux " --descr=heaptrc.xml --input="../fpcsrc/rtl/inc/heaptrc.pp -Fi../fpcsrc/rtl/i386 -Fi../fpcsrc/rtl/linux " --descr=mmx.xml --input="../fpcsrc/rtl/i386/mmx.pp -Fi../fpcsrc/rtl/linux " --descr=ipc.xml --input="../fpcsrc/rtl/unix/ipc.pp -Fi../fpcsrc/rtl/linux " --descr=printer.xml --input="../fpcsrc/rtl/unix/printer.pp -Fi../fpcsrc/rtl/linux -Fi../fpcsrc/rtl/inc " --descr=typinfo.xml --input="../fpcsrc/rtl/objpas/typinfo.pp -Fi../fpcsrc/rtl/linux " --descr=ports.xml --input="../fpcsrc/rtl/unix/ports.pp -Fi../fpcsrc/rtl/linux " --descr=getopts.xml --input="../fpcsrc/rtl/inc/getopts.pp -Fi../fpcsrc/rtl/linux " --descr=emu387.xml --input="../fpcsrc/rtl/go32v2/emu387.pp -Fi../fpcsrc/rtl/i386 " --descr=dxeload.xml --input="../fpcsrc/rtl/go32v2/dxeload.pp -Fi../fpcsrc/rtl/i386 " --descr=go32.xml --input="../fpcsrc/rtl/go32v2/go32.pp -Fi../fpcsrc/rtl/i386 " --descr=gpm.xml --input="-dVER1_0 ../fpcsrc/rtl/linux/gpm.pp -Fi../fpcsrc/rtl/i386 " --descr=graph.xml --input="../fpcsrc/packages/graph/src/unix/graph.pp -Fi../fpcsrc/packages/graph/src/inc " --descr=oldlinux.xml --input="../fpcsrc/rtl/linux/oldlinux.pp -Fi../fpcsrc/rtl/linux -Fi../fpcsrc/rtl/unix " --descr=unixtype.xml --input="../fpcsrc/rtl/unix/unixtype.pp -Fi../fpcsrc/rtl/unix -Fi../fpcsrc/rtl/linux -Fi../fpcsrc/rtl/linux/i386 " --descr=baseunix.xml --input="../fpcsrc/rtl/unix/baseunix.pp -Fi../fpcsrc/rtl/unix -Fi../fpcsrc/rtl/linux -Fi../fpcsrc/rtl/linux/i386 " --descr=unix.xml --input="../fpcsrc/rtl/unix/unix.pp -Fi../fpcsrc/rtl/unix -Fi../fpcsrc/rtl/linux -Fi../fpcsrc/rtl/linux/i386 " --descr=classes.xml --input='../fpcsrc/rtl/unix/classes.pp -Fi../fpcsrc/rtl/objpas/classes -dfpdocsystem' --descr=unixutil.xml --input="../fpcsrc/rtl/unix/unixutil.pp " --descr=x86.xml --input="../fpcsrc/rtl/unix/x86.pp " --descr=dynlibs.xml --input="../fpcsrc/rtl/inc/dynlibs.pas -Fi../fpcsrc/rtl/unix " --descr=linux.xml --input="../fpcsrc/rtl/linux/linux.pp -Fi../fpcsrc/rtl/linux -Fi../fpcsrc/rtl/unix " --descr=math.xml --input="../fpcsrc/rtl/objpas/math.pp -Fi../fpcsrc/rtl/i386 -dFPC_HAS_TYPE_EXTENDED " --descr=matrix.xml --input="../fpcsrc/rtl/inc/matrix.pp -Fi../fpcsrc/rtl/inc " --descr=system.xml --input="-dfpdocsystem -dHASGETHEAPSTATUS -dSUPPORT_DOUBLE ../fpcsrc/rtl/bsd/system.pp -Fi../fpcsrc/rtl/linux -Fi../fpcsrc/rtl/unix -Fi../fpcsrc/rtl/inc -Fi../fpcsrc/rtl/i386 -dCPU32 -dHASVARIANT -dFPC_HAS_TYPE_EXTENDED -dHASWIDECHAR " --descr=objpas.xml --input="-dHASINTF ../fpcsrc/rtl/objpas/objpas.pp " --descr=dateutils.xml --input="../fpcsrc/rtl/objpas/dateutils.pp -Fi../fpcsrc/rtl/objpas " --descr=wincrt.xml --input="../fpcsrc/packages/graph/src/win32/wincrt.pp" --descr=clocale.xml --input="../fpcsrc/rtl/unix/clocale.pp " --descr=cthreads.xml --input="../fpcsrc/rtl/unix/cthreads.pp " --descr=cmem.xml --input="../fpcsrc/rtl/inc/cmem.pp " --descr=cwstring.xml --input="../fpcsrc/rtl/unix/cwstring.pp " --descr=exeinfo.xml --input="../fpcsrc/rtl/inc/exeinfo.pp " --descr=lineinfo.xml --input="../fpcsrc/rtl/inc/lineinfo.pp " --descr=lnfodwrf.xml --input="../fpcsrc/rtl/inc/lnfodwrf.pp " --descr=ctypes.xml --input="../fpcsrc/rtl/inc/ctypes.pp -Fi../fpcsrc/rtl/unix " --format=latex

Marco van de Voort

2010-10-20 13:28

manager   ~0041936

Last edited: 2010-10-20 15:52

I still have a look if I have time, but don't know the linear backend that well.

If I look in the source it looks like either docnode or docnode.node are assigned but invalid.

Problem is that besides fpdoc/fcl-passrc improvements, trunk also contains many xml pkg changes.

Marco van de Voort

2010-10-21 22:46

manager   ~0041986

Very scary bug. Have been playing a while, and exceptions indeed pop up at random, and in totally different parts of the program (parsing, latex writing, and while memory freeing after everything is done (usually in DOM, but not always)

I compared most latex related parts, and tried to backport all extra assigned() checks in dwlineair,dwriter, but that didn't really fix it. Valgrind tomorrow.

Marco van de Voort

2010-10-22 22:57

manager   ~0042010

Fixed.

Issue History

Date Modified Username Field Change
2009-09-28 11:05 Mario Ray Mahardhika New Issue
2009-10-11 22:23 Marco van de Voort Note Added: 0031263
2009-10-11 22:23 Marco van de Voort Note Edited: 0031263
2009-10-27 07:16 Marco van de Voort Note Added: 0031706
2009-10-27 07:16 Marco van de Voort Status new => feedback
2010-08-10 12:19 Marco van de Voort Status feedback => resolved
2010-08-10 12:19 Marco van de Voort Resolution open => unable to reproduce
2010-08-10 12:19 Marco van de Voort Assigned To => Marco van de Voort
2010-08-10 12:19 Marco van de Voort Note Added: 0040104
2010-10-19 10:24 Joost van der Sluis Status resolved => feedback
2010-10-19 10:24 Joost van der Sluis Resolution unable to reproduce => reopened
2010-10-19 10:24 Joost van der Sluis Note Added: 0041912
2010-10-19 10:24 Joost van der Sluis Target Version => 2.4.2
2010-10-19 11:18 Marco van de Voort Note Added: 0041913
2010-10-19 13:57 Marco van de Voort Note Edited: 0041913
2010-10-19 22:42 Joost van der Sluis Note Added: 0041920
2010-10-20 13:28 Marco van de Voort Note Added: 0041936
2010-10-20 15:52 Marco van de Voort Note Edited: 0041936
2010-10-21 22:46 Marco van de Voort Note Added: 0041986
2010-10-22 22:57 Marco van de Voort Fixed in Revision => 16198
2010-10-22 22:57 Marco van de Voort Status feedback => resolved
2010-10-22 22:57 Marco van de Voort Resolution reopened => fixed
2010-10-22 22:57 Marco van de Voort Note Added: 0042010
2010-11-23 20:04 Mario Ray Mahardhika Status resolved => closed