View Issue Details

IDProjectCategoryView StatusLast Update
0014694LazarusDatabasepublic2014-06-22 08:19
ReporterChristian Assigned ToJesus Reyes  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0014694: DBGrid shows data in an clean Row.
DescriptionWhen and Datasource is totally clean, and an DBGrid that shows the Data from these Source is resised so that the Row is not fully visible (Vertical) then Data is shown in these clean row.
Maybe it happens only on Master/Detail Datasets.
Tagsdataset, dbgrids, master-detail
Fixed in Revision27278
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Activities

Vincent Snijders

2009-09-30 12:11

manager   ~0031047

Please, attach an example application.

Jesus Reyes

2009-11-04 20:38

developer   ~0031896

please attach a sample project and a screenshot

2009-11-07 04:05

 

row1.jpg (27,370 bytes)   
row1.jpg (27,370 bytes)   

2009-11-07 04:05

 

row1_resized.jpg (25,769 bytes)   
row1_resized.jpg (25,769 bytes)   

Christian

2009-11-07 04:06

reporter   ~0031965

The 2 screenshots shows the same dataset at the same state
first with an row not fully visible.
second with the row fully visible.

Christian

2009-11-07 04:07

reporter   ~0031966

It seems to happen when .Insert is called to the dataset in an Master/Detail relationship and the row is not fully visible.

samuel herzog

2010-03-28 14:46

developer   ~0036204

Because no example project was uploaded within the last 3 months this issue seems not so important and therefore I moved the lazTarget to 1.0

Christian

2010-03-28 15:06

reporter   ~0036205

Seems that the problem is not reproducable with current SVN.

Zeljan Rikalo

2010-03-28 18:14

developer   ~0036218

@Christian, can it be resolved then ?

Christian

2010-05-04 08:34

reporter   ~0037235

No, i have seen it in actual SVN.
It seems to be undefined what the grid shows in one row
what has not the full height,
maybe it happend only in insert state.

Jesus Reyes

2010-06-19 19:17

developer   ~0038653

Christian can you try with a recent revision (please state the tested revision for the record)

Christian

2010-07-02 07:25

reporter   ~0038936

Seems that it dont show data in an clean row for now, but it shows no data in an Row that contains data in the same case.

Steps to reproduce:
Use an clean datasource
Resize the grid so that only the half of the forst line is visible
type something in the first row (Insert)
No data is visible
resize the grid so that the row comes completely visible->the data appears

Felipe Monteiro de Carvalho

2010-07-21 11:07

developer   ~0039549

Please attach a test project

Christian

2010-09-07 10:01

reporter   ~0040879

An Testproject is useless, you can use any DB Example from lazarus.
You have to type something to reproduce it thats not very easy to do with an testproject.

Christian

2010-09-07 18:36

reporter   ~0040887

thx

Issue History

Date Modified Username Field Change
2009-09-30 12:00 Christian New Issue
2009-09-30 12:00 Christian Widgetset => Win32/Win64
2009-09-30 12:11 Vincent Snijders LazTarget => 1.0
2009-09-30 12:11 Vincent Snijders Note Added: 0031047
2009-09-30 12:11 Vincent Snijders Status new => feedback
2009-09-30 12:11 Vincent Snijders Target Version => 1.0.0
2009-09-30 17:22 Jesus Reyes Status feedback => assigned
2009-09-30 17:22 Jesus Reyes Assigned To => Jesus Reyes
2009-11-04 20:38 Jesus Reyes LazTarget 1.0 => 0.9.30
2009-11-04 20:38 Jesus Reyes Note Added: 0031896
2009-11-04 20:38 Jesus Reyes Status assigned => feedback
2009-11-04 20:38 Jesus Reyes Target Version 1.0.0 => 0.9.30
2009-11-07 04:05 Christian File Added: row1.jpg
2009-11-07 04:05 Christian File Added: row1_resized.jpg
2009-11-07 04:06 Christian Note Added: 0031965
2009-11-07 04:07 Christian Note Added: 0031966
2009-12-11 12:39 Vincent Snijders Status feedback => assigned
2010-03-15 01:47 Jesus Reyes Tag Attached: dbgrids
2010-03-28 14:46 samuel herzog LazTarget 0.9.30 => 1.0
2010-03-28 14:46 samuel herzog Note Added: 0036204
2010-03-28 15:06 Christian Note Added: 0036205
2010-03-28 18:14 Zeljan Rikalo Note Added: 0036218
2010-03-28 18:14 Zeljan Rikalo Status assigned => feedback
2010-05-02 05:58 Paul Ishenin Category LCL => Database
2010-05-04 08:34 Christian Note Added: 0037235
2010-06-19 19:17 Jesus Reyes Note Added: 0038653
2010-07-02 07:25 Christian Note Added: 0038936
2010-07-21 11:07 Felipe Monteiro de Carvalho Note Added: 0039549
2010-09-06 12:30 Vincent Snijders Target Version 0.9.30 => 1.0.0
2010-09-07 10:01 Christian Note Added: 0040879
2010-09-07 17:48 Jesus Reyes Fixed in Revision => 27278
2010-09-07 17:48 Jesus Reyes LazTarget 1.0 => 0.9.30
2010-09-07 17:48 Jesus Reyes Status feedback => resolved
2010-09-07 17:48 Jesus Reyes Fixed in Version => 0.9.29 (SVN)
2010-09-07 17:48 Jesus Reyes Resolution open => fixed
2010-09-07 17:49 Jesus Reyes Target Version 1.0.0 => 0.9.30
2010-09-07 18:36 Christian Status resolved => closed
2010-09-07 18:36 Christian Note Added: 0040887
2014-06-22 08:19 Reinier Olislagers Tag Attached: dataset
2014-06-22 08:19 Reinier Olislagers Tag Attached: master-detail