View Issue Details

IDProjectCategoryView StatusLast Update
0014712LazarusLCLpublic2009-10-03 20:06
ReporterChris Kirkpatrick Assigned ToPaul Ishenin  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Fixed in Version0.9.29 (SVN) 
Summary0014712: lazarus/lcl/lclmemmanager.pas(100,53) Error: Cannot access a private field of an object here
DescriptionCompilation of lclmemmanager fails with above message, on line 100 (class TExtMemoryStream).
Property Capacity refers to FCapacity and SetCapacity, both of which are declared Private in TMemoryStream
SVN r21988, fpc 2.5.1 r13795
TagsNo tags attached.
Fixed in Revision21998
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Burkhard Carstens

2009-10-03 11:30

reporter   ~0031090

This is probably caused by http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&sortby=date&revision=13794 fixing 0014650

Paul Ishenin

2009-10-03 17:58

manager   ~0031101

Please test and close if ok.

Issue History

Date Modified Username Field Change
2009-10-03 11:17 Chris Kirkpatrick New Issue
2009-10-03 11:17 Chris Kirkpatrick Widgetset => GTK 2
2009-10-03 11:30 Burkhard Carstens Note Added: 0031090
2009-10-03 17:58 Paul Ishenin Fixed in Revision => 21998
2009-10-03 17:58 Paul Ishenin LazTarget => -
2009-10-03 17:58 Paul Ishenin Status new => resolved
2009-10-03 17:58 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2009-10-03 17:58 Paul Ishenin Resolution open => fixed
2009-10-03 17:58 Paul Ishenin Assigned To => Paul Ishenin
2009-10-03 17:58 Paul Ishenin Note Added: 0031101
2009-10-03 20:06 Chris Kirkpatrick Status resolved => closed