View Issue Details

IDProjectCategoryView StatusLast Update
0014717LazarusDatabasepublic2011-01-14 12:29
ReporterClaudio Romero Assigned ToJesus Reyes  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Target Version1.0.0 
Summary0014717: DBEdit show only 2 digits in float field after SQLTransaction1.Commit;
DescriptionWhen I commit a transaction, and reopen SQLQuery with another transaction
DBEdit show 2 digits.
Ej:
606 -> 60
7825.36 -> 78

But show fine the number in DBGrid, and with SQLQuery1.FieldByName('precio').asstring;
In the first transaction DBEdit show fine the number, in the second not.
This happen in Firebird float field (numeric 7,2 or numeric 18,2).
Upload test.zip (with ddl table-need and firebird version)
Tested with
Lazarus 0.9.29 svn 21445. fpc 2.3.1 svn 13383
Lazarus 0.9.29 svn 22001. fpc 2.5.1 svn 13795
under Windows 2000 server SP4 and Windows XP sp3

Regards
Tagsdbcontrols
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Activities

2009-10-03 20:55

 

test.zip (5,263 bytes)

yang jixian

2011-01-04 02:29

developer   ~0044851

The test.zip works fine on Windows XP sp3, Lazarus latest svn and FPC2.5.1 svn 16327.
Firebird 2.5 the same version on server and client side.

Claudio Romero

2011-01-14 12:14

reporter   ~0045171

Maybe is Firebird 2.1.1 problem, after upgrade to Firebird 2.1.4, I can't reproduce the error. (even con Lazarus 0.9.27)

You can close this issue.

Thanks

Vincent Snijders

2011-01-14 12:19

manager   ~0045172

Thanks for testing.

Claudio Romero

2011-01-14 12:29

reporter   ~0045174

You're welcome

Issue History

Date Modified Username Field Change
2009-10-03 20:54 Claudio Romero New Issue
2009-10-03 20:54 Claudio Romero Widgetset => Win32/Win64
2009-10-03 20:55 Claudio Romero File Added: test.zip
2009-10-04 19:13 Vincent Snijders LazTarget => 1.0
2009-10-04 19:13 Vincent Snijders Assigned To => Jesus Reyes
2009-10-04 19:13 Vincent Snijders Status new => assigned
2009-10-04 19:13 Vincent Snijders Target Version => 1.0.0
2010-03-15 02:05 Jesus Reyes Tag Attached: dbcontrols
2010-05-02 05:57 Paul Ishenin Category LCL => Database
2011-01-04 02:29 yang jixian Note Added: 0044851
2011-01-14 12:14 Claudio Romero Note Added: 0045171
2011-01-14 12:19 Vincent Snijders Status assigned => resolved
2011-01-14 12:19 Vincent Snijders Resolution open => fixed
2011-01-14 12:19 Vincent Snijders Note Added: 0045172
2011-01-14 12:29 Claudio Romero Status resolved => closed
2011-01-14 12:29 Claudio Romero Note Added: 0045174