View Issue Details

IDProjectCategoryView StatusLast Update
0014723LazarusIDEpublic2011-12-01 11:24
ReporterDomingo Alvarez DuarteAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformanyOSanyOS Versionany
Product Version0.9.29 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0014723: When inheriting a form from another form that has an inserted TFame there is dupilcation of inherited TFrame
DescriptionWhen I try to create an inherited form form another form that has a TFrame inserted I got a duplicated TFrame error.
Steps To ReproduceThe attached project shows it.
In short:
Create an application, create a Frame, create a Form, insert the created Frame on taht form, cerate an inherited form fron the already created form with the Frame inserted, makes the inherited form the main form compile and run. I get an exception saying that ther is a duplicate Frame.
TagsNo tags attached.
Fixed in Revision
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Activities

2009-10-05 10:05

 

bug-form-inheritance-with-frames.zip (11,623 bytes)

Paul Ishenin

2010-07-09 08:57

manager   ~0039184

Probably fixed in the mean time. At least we made many fixes in the related area and I can't reproduce it. Please reopen if it is not fixed for you or close in other case.

Issue History

Date Modified Username Field Change
2009-10-05 10:05 Domingo Alvarez Duarte New Issue
2009-10-05 10:05 Domingo Alvarez Duarte File Added: bug-form-inheritance-with-frames.zip
2009-10-05 10:05 Domingo Alvarez Duarte Widgetset => Win32/Win64
2009-10-20 22:11 Vincent Snijders LazTarget => 1.0
2009-10-20 22:11 Vincent Snijders Assigned To => Mattias Gaertner
2009-10-20 22:11 Vincent Snijders Status new => assigned
2009-10-20 22:11 Vincent Snijders Target Version => 1.0.0
2010-07-02 20:23 Mattias Gaertner LazTarget 1.0 => 0.9.30
2010-07-09 08:57 Paul Ishenin Status assigned => resolved
2010-07-09 08:57 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-07-09 08:57 Paul Ishenin Resolution open => fixed
2010-07-09 08:57 Paul Ishenin Note Added: 0039184
2011-12-01 11:24 Marc Weustink Status resolved => closed