View Issue Details

IDProjectCategoryView StatusLast Update
0014753LazarusIDEpublic2011-10-23 15:39
ReporterGraeme GeldenhuysAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSUbuntu LinuxOS Version8.04.2
Product Version0.9.28Product Buildlatest revision 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0014753: Assembler window is not vertical scrollable
DescriptionWhen I am debugging inside the IDE and the Assembler Window is shown. I can scroll the content horizontally, but cannot scroll the content vertically using the "thumb button" of the vertical scrollbar. The thumb button is locked in the center of the vertical scrollbar.

I can however scroll the content vertically if I use the up/down buttons of the vertical scrollbar. How weird is that. :-/

I have only testing this under Lazarus IDE compiled with GTK2 (64bit compiler).
TagsNo tags attached.
Fixed in Revision32806
LazTarget0.99.0
Widgetset
Attached Files

Activities

2009-10-08 09:50

 

Screenshot-Assembler.png (45,337 bytes)
Screenshot-Assembler.png (45,337 bytes)

Zeljan Rikalo

2011-09-12 17:56

developer   ~0051747

Yes, same with qtlcl.

Martin Friebe

2011-10-14 11:40

manager   ~0052973

The scrolling was changed in r 32806.
My tests showed that the new way work on w32, fedora and mac.

Please test your platform and let me know if the issue can be resolved.

Please note:
The scrollbar works different from a "normal" scrollbar. This is by design.

The total scrolling range is not known, as new data is automatically loaded, when reaching the top/bottom.
Therefore the knob of the bar, will jump back to the center, if the mouse is released. While dragged away from the center (even if hold in a fixed position other than the center) the window will scroll. Speed depends on the distance to the center.

Martin Friebe

2011-10-23 15:39

manager   ~0053325

please test and close if ok.

Issue History

Date Modified Username Field Change
2009-10-08 09:50 Graeme Geldenhuys New Issue
2009-10-08 09:50 Graeme Geldenhuys File Added: Screenshot-Assembler.png
2009-10-20 22:05 Vincent Snijders LazTarget => 1.0
2009-10-20 22:05 Vincent Snijders Status new => acknowledged
2009-10-20 22:05 Vincent Snijders Target Version => 1.0.0
2011-09-11 23:29 Martin Friebe Status acknowledged => assigned
2011-09-11 23:29 Martin Friebe Assigned To => Martin Friebe
2011-09-12 17:56 Zeljan Rikalo Note Added: 0051747
2011-10-14 11:40 Martin Friebe Note Added: 0052973
2011-10-14 11:40 Martin Friebe Status assigned => feedback
2011-10-23 15:39 Martin Friebe Fixed in Revision => 32806
2011-10-23 15:39 Martin Friebe LazTarget 1.0 => 0.99.0
2011-10-23 15:39 Martin Friebe Status feedback => resolved
2011-10-23 15:39 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2011-10-23 15:39 Martin Friebe Resolution open => fixed
2011-10-23 15:39 Martin Friebe Note Added: 0053325
2011-10-23 15:39 Martin Friebe Target Version 1.0.0 => 0.99.0