View Issue Details

IDProjectCategoryView StatusLast Update
0014760LazarusWidgetsetpublic2010-05-10 10:14
ReporterDRIGUS GmbHAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0014760: TGroupBox in WinCE: Displacement of child controls / TLabel not visible
DescriptionTForm with a TGroupBox and a TLable inside: At runtime the TLabel is not visible. If you place f.e. a TEdit and a TButton in the TGroupBox they are visible at runtime but displaced regarding design time.

(There is no problem when using the Win32 WidgetSet.)
Additional InformationLazarus 0.9.29 r22068
FPC 2.2.4
i386-win32-win32/win64

Windows CE 6.0 ARM Device
(no SmartPhone / PocketPC)
Tagswince
Fixed in Revision25214, 25203, 25202, 25201, 25194, 25185
LazTarget-
WidgetsetWinCE
Attached Files

Relationships

related to 0015945 closedFelipe Monteiro de Carvalho Position of Tlabel wrong at runtime in wince. 
related to 0015654 closedFelipe Monteiro de Carvalho WinCE align not working for Timage 
has duplicate 0014913 closedFelipe Monteiro de Carvalho Labels aren't displayed when in a groupbox or a tabsheet 
has duplicate 0015424 closedFelipe Monteiro de Carvalho TLabel 
related to 0015896 closedFelipe Monteiro de Carvalho StaticText color doesn't work in WinCE GroupBox 
related to 0013457 assignedStephano WinCE - TPageControl not show TLabel TImage TSpeedButton and not show to top tabs 

Activities

2009-10-08 15:01

 

GroupBoxTest.zip (807,894 bytes)

Felipe Monteiro de Carvalho

2009-10-21 20:11

developer   ~0031557

I fixed the TButton positioning inside TGroupBox in rev22254. As far as I checked, this is the only control affected so the problem no longer exists for windowed controls. Contrary to your claim in my tests TEdit isn't affected.

About non-windowed controls, like TCaption, I need to check, but there is something wrong about the painting of TGroupBox.

Felipe Monteiro de Carvalho

2009-10-21 20:19

developer   ~0031558

In the mean time you can put a windowed substitute to TCaption, like TStaticText.

nicola gorlandi

2010-02-17 18:13

reporter   ~0034566

TStaticText doesn't have the trasparent property...

Felipe Monteiro de Carvalho

2010-02-26 03:17

developer   ~0034772

You can use the same color as the background

nicola gorlandi

2010-02-27 11:23

reporter   ~0034823

I got to put Tlabel over a gradientpanel.

Felipe Monteiro de Carvalho

2010-04-26 10:58

developer   ~0037017

I tested with the latest Lazarus and couldn't reproduce, so it's fixed, isn't it?

2010-04-27 13:50

 

2010_4_27__13_46_53.JPG (17,140 bytes)
2010_4_27__13_46_53.JPG (17,140 bytes)

DRIGUS GmbH

2010-04-27 13:53

reporter   ~0037046

Lazarus 0.9.29 r24987 FPC 2.4.1 i386-win32-win32/win64

I upload a new screenshot. As you can see, the TLabel is visible now. But the TEdit and the TButton are still displaced. The caption of the TGroupBox is missing, too.

Felipe Monteiro de Carvalho

2010-05-04 14:03

developer   ~0037250

Last edited: 2010-05-04 14:04

It's not the TEdit or TButton that are displaced, it's the TLabel that is displaced, please check that. The caption problem is a regression introduced in rev24177

http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&root=lazarus&revision=24177

2010-05-04 14:30

 

2010_04_05.jpg (60,253 bytes)
2010_04_05.jpg (60,253 bytes)

DRIGUS GmbH

2010-05-04 14:34

reporter   ~0037251

Take a look at the last screenshot, which shows the formular at design time. For me it looks like the TEdit and the TButton are displaced, because the TButton strikes against the bottom line of the TGroupBox at runtime.

Felipe Monteiro de Carvalho

2010-05-04 15:15

developer   ~0037252

It's true, in your screenshot the button and edit are on the wrong position, their Y position is higher then it should, while the Label is in the right position.

It seams that between 0.9.28 and now there was a series of regressions introduced. The good side is that the problems can be easily tracked by testing many revisions to search which one broke it. I am documenting the effort here:

http://wiki.lazarus.freepascal.org/Windows_CE_Development_Notes#Regressions

Felipe Monteiro de Carvalho

2010-05-05 15:41

developer   ~0037285

I think I fixed the mentioned problems, please test and see if they are fixed.

There may still be other different issues. If you find different issues then the ones originally mentioned, please open bug reports. thanks,

DRIGUS GmbH

2010-05-10 10:14

reporter   ~0037409

Lazarus 0.9.29 r25285 FPC 2.4.1 i386-win32-win32/win64

Fixed, thanks.

Issue History

Date Modified Username Field Change
2009-10-08 15:01 DRIGUS GmbH New Issue
2009-10-08 15:01 DRIGUS GmbH File Added: GroupBoxTest.zip
2009-10-08 15:01 DRIGUS GmbH Widgetset => WinCE
2009-10-13 18:12 Felipe Monteiro de Carvalho Status new => assigned
2009-10-13 18:12 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2009-10-20 17:06 Felipe Monteiro de Carvalho Tag Attached: wince
2009-10-21 20:11 Felipe Monteiro de Carvalho Note Added: 0031557
2009-10-21 20:19 Felipe Monteiro de Carvalho Note Added: 0031558
2009-10-27 15:32 Felipe Monteiro de Carvalho Relationship added related to 0014913
2010-01-03 02:25 Felipe Monteiro de Carvalho Relationship added related to 0015424
2010-02-17 18:13 nicola gorlandi Note Added: 0034566
2010-02-26 03:17 Felipe Monteiro de Carvalho Note Added: 0034772
2010-02-27 11:23 nicola gorlandi Note Added: 0034823
2010-03-06 04:06 Felipe Monteiro de Carvalho Relationship added related to 0015896
2010-03-09 22:35 Felipe Monteiro de Carvalho Relationship added related to 0013457
2010-04-26 10:58 Felipe Monteiro de Carvalho LazTarget => -
2010-04-26 10:58 Felipe Monteiro de Carvalho Note Added: 0037017
2010-04-26 10:58 Felipe Monteiro de Carvalho Status assigned => feedback
2010-04-26 10:59 Felipe Monteiro de Carvalho Relationship replaced has duplicate 0015424
2010-04-26 11:00 Felipe Monteiro de Carvalho Relationship replaced has duplicate 0014913
2010-04-26 11:37 Felipe Monteiro de Carvalho Relationship added related to 0015945
2010-04-27 13:50 DRIGUS GmbH File Added: 2010_4_27__13_46_53.JPG
2010-04-27 13:53 DRIGUS GmbH Note Added: 0037046
2010-05-04 14:03 Felipe Monteiro de Carvalho Note Added: 0037250
2010-05-04 14:04 Felipe Monteiro de Carvalho Note Edited: 0037250
2010-05-04 14:30 DRIGUS GmbH File Added: 2010_04_05.jpg
2010-05-04 14:34 DRIGUS GmbH Note Added: 0037251
2010-05-04 15:15 Felipe Monteiro de Carvalho Note Added: 0037252
2010-05-04 15:31 Felipe Monteiro de Carvalho Relationship added related to 0015654
2010-05-05 15:41 Felipe Monteiro de Carvalho Fixed in Revision => 25214, 25203, 25202, 25201, 25194, 25185
2010-05-05 15:41 Felipe Monteiro de Carvalho Status feedback => resolved
2010-05-05 15:41 Felipe Monteiro de Carvalho Fixed in Version => 0.9.29 (SVN)
2010-05-05 15:41 Felipe Monteiro de Carvalho Resolution open => fixed
2010-05-05 15:41 Felipe Monteiro de Carvalho Note Added: 0037285
2010-05-10 10:14 DRIGUS GmbH Status resolved => closed
2010-05-10 10:14 DRIGUS GmbH Note Added: 0037409