View Issue Details

IDProjectCategoryView StatusLast Update
0014789LazarusIDEpublic2012-02-21 01:34
ReportermspillerAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.31 (SVN) 
Summary0014789: Patch: Focus lost when execution stops
DescriptionThere is an issue with the focus, that is lost when debugging application after process is ended. Observed under Windows.

Usage should be the folowing:
- Edit code inside Source Editor
- F9 run app
- exit app
- return focus to Source Editor (currently none of lazarus windows are focused)
TagsNo tags attached.
Fixed in Revision35504
LazTarget1.2
WidgetsetWin32/Win64
Attached Files
  • 0014789.patch (455 bytes)
    Index: debugmanager.pas
    ===================================================================
    --- debugmanager.pas	(revision 24176)
    +++ debugmanager.pas	(working copy)
    @@ -1561,6 +1561,7 @@
     
             if FDialogs[ddtAssembler] <> nil
             then TAssemblerDlg(FDialogs[ddtAssembler]).SetLocation(nil, 0);
    +        if Assigned(SourceEditorManager.ActiveSourceWindow) then SourceEditorManager.ActiveSourceWindow.SetFocus;
           end;
         end;
       end;
    
    0014789.patch (455 bytes)

Relationships

duplicate of 0009883 closedVincent Snijders Lazarus Editor doesn't get focus after successfull run 
related to 0014294 closedMartin Friebe Lazarus Stop debug with ctrl-F2, moves focus away from Editor 
related to 0012020 closedMattias Gaertner Patches If "Show compile dialog" is active, the focus is put to the messages window when the compilation done 
related to 0019411 resolvedBart Broersma Lazarus Show Compile Dialog: previous focus is lost 
related to 0015494 closedPaul Ishenin Lazarus Trouble with focus 
related to 0015967 closedJuha Manninen Lazarus When debugging a GUI application and breakpoint is hit, focus doesn't move to editor 
related to 0009140 closedJuha Manninen Lazarus Focus not in source editor after "Search string '...' not found" dialog 

Activities

This was fixed for gtk2, please mark resolved:fixed if ok.
Sorry, confirmed it's still present on Windows.

samuel herzog

2010-03-16 06:28

developer   ~0035614

tested today with SVN 24016 on winxp sp3. Works fine.
This is so odd. I jumped the gun and asked everybody for confirmation whether the "focus on stop" bugs still exist, and now I'm the only still seeing :D
Do you have "show message on stop" enabled? Did you try both Ctrl+F2 and closing the debugged app normally?

samuel herzog

2010-03-18 22:47

developer   ~0035784

You are right. If the setting "show message on stop" is enabled, then the focus still get's lost. I reopened this issue again.

mspiller

2010-03-21 12:41

reporter   ~0035859

works for me (with show message on stop DISABLED)

2010-03-23 04:04

 

0014789.patch (455 bytes)
Index: debugmanager.pas
===================================================================
--- debugmanager.pas	(revision 24176)
+++ debugmanager.pas	(working copy)
@@ -1561,6 +1561,7 @@
 
         if FDialogs[ddtAssembler] <> nil
         then TAssemblerDlg(FDialogs[ddtAssembler]).SetLocation(nil, 0);
+        if Assigned(SourceEditorManager.ActiveSourceWindow) then SourceEditorManager.ActiveSourceWindow.SetFocus;
       end;
     end;
   end;
0014789.patch (455 bytes)

samuel herzog

2010-03-23 04:04

developer   ~0035955

Patch added.

samuel herzog

2010-04-06 06:48

developer   ~0036475

Changed assignement to Vincent because he reopened this issue.

Attila Borka

2010-04-06 08:39

reporter   ~0036481

All this and the related reports are revolve around
http://bugs.freepascal.org/view.php?id=12020

If "Show compile progress dialog" is checked, all focus problems arise.

When there was an error, when there wasn't an error, when program execution starts, when debugging session starts, when execution is stopped, when debugging is stopped by either program exiting or using CTRL+F2 from debugging.
Sometimes there are dialogs to close after execution (ex: debug finished, execution finished) but they are behind the non closed "compiler progress" dialog.

If the "compiler progress window" is there, nothing should happen at all until it is manually or automatically closed (no execution, no debugging, no focus move from that window, nothing). After it is closed manually, or automatically (maybe when execution happens or debugging session starts it can be automatically closed) then the focus should be moved to the proper window (messages if there was an error, source code if there wasn't, etc.)
Maybe the CompilerDialog isn't closed soon enough to return the focus to the editor before the debugged application gets focus (OTOH Z-index should be updated regardless of whether the app has focus).

Juha Manninen

2011-08-16 23:17

developer   ~0050886

Fixed in meantime.

Zeljan Rikalo

2011-11-19 20:24

developer   ~0054266

@mspiller, can you retest please ? That's probably fixed in current trunk

Zeljan Rikalo

2012-02-04 12:25

developer   ~0056351

@Martin please see what to do with this. Postpone to 1.2 if needed.

Zeljan Rikalo

2012-02-04 12:26

developer   ~0056352

No feedback, postponed to 1.2

Paul Ishenin

2012-02-21 01:34

manager   ~0056949

The issue is fixed now. Please test and close if ok.

To have it work properly you need to uncheck and option "Focus messages after compilation" in Environment->Desktop->Misc options

Paul Ishenin

2012-02-21 01:34

manager   ~0056950

The issue is fixed now. Please test and close if ok.

To have it work properly you need to uncheck and option "Focus messages after compilation" in Environment->Desktop->Misc options

Issue History

Date Modified Username Field Change
2009-10-12 23:30 mspiller New Issue
2009-10-12 23:30 mspiller Widgetset => Win32/Win64
2009-10-13 01:30 Martin Friebe Relationship added duplicate of 0009883
2009-10-13 01:30 Martin Friebe Relationship added related to 0014294
2009-10-20 21:38 Vincent Snijders LazTarget => post 1.2
2009-10-20 21:38 Vincent Snijders Status new => acknowledged
2010-01-23 10:51 Dmitry Boyarintsev Relationship added related to 0015494
2010-03-12 00:44 Juha Manninen Relationship added related to 0015967
2010-03-12 16:41 Flávio Etrusco (notifications not working) Note Added: 0035368
2010-03-12 16:41 Flávio Etrusco (notifications not working) Status acknowledged => feedback
2010-03-12 17:32 Flávio Etrusco (notifications not working) Note Added: 0035386
2010-03-12 17:32 Flávio Etrusco (notifications not working) Status feedback => acknowledged
2010-03-16 06:28 samuel herzog Note Added: 0035614
2010-03-17 07:29 samuel herzog Status acknowledged => resolved
2010-03-17 07:29 samuel herzog Resolution open => fixed
2010-03-17 07:29 samuel herzog Assigned To => samuel herzog
2010-03-17 07:40 Flávio Etrusco (notifications not working) Note Added: 0035685
2010-03-18 19:26 samuel herzog LazTarget post 1.2 => 1.0
2010-03-18 19:26 samuel herzog Status resolved => acknowledged
2010-03-18 19:26 samuel herzog Target Version => 1.0.0
2010-03-18 22:47 samuel herzog Note Added: 0035784
2010-03-21 12:41 mspiller Note Added: 0035859
2010-03-23 04:04 samuel herzog File Added: 0014789.patch
2010-03-23 04:04 samuel herzog Note Added: 0035955
2010-03-23 18:39 samuel herzog Status acknowledged => confirmed
2010-03-23 18:39 samuel herzog Summary Focus lost when execution stopss => Patch: Focus lost when execution stops
2010-03-29 10:56 Vincent Snijders Resolution fixed => open
2010-04-06 06:47 samuel herzog Status confirmed => assigned
2010-04-06 06:47 samuel herzog Assigned To samuel herzog => Vincent Snijders
2010-04-06 06:48 samuel herzog Note Added: 0036475
2010-04-06 08:39 Attila Borka Note Added: 0036481
2010-04-06 16:11 Vincent Snijders Assigned To Vincent Snijders =>
2010-04-06 16:11 Vincent Snijders Status assigned => acknowledged
2010-04-28 18:04 Flávio Etrusco (notifications not working) Note Added: 0037065
2011-08-11 14:04 Felipe Monteiro de Carvalho LazTarget 1.0 => 0.99.0
2011-08-16 23:17 Juha Manninen Status acknowledged => resolved
2011-08-16 23:17 Juha Manninen Resolution open => fixed
2011-08-16 23:17 Juha Manninen Assigned To => Juha Manninen
2011-08-16 23:17 Juha Manninen Note Added: 0050886
2011-09-08 20:19 Flávio Etrusco (notifications not working) Assigned To Juha Manninen =>
2011-09-08 20:19 Flávio Etrusco (notifications not working) Status resolved => assigned
2011-09-08 20:19 Flávio Etrusco (notifications not working) Resolution fixed => reopened
2011-09-09 16:04 Martin Friebe Relationship added related to 0009140
2011-09-16 00:45 Juha Manninen Status assigned => acknowledged
2011-11-14 22:04 Juha Manninen Relationship added related to 0012020
2011-11-19 20:24 Zeljan Rikalo Note Added: 0054266
2011-11-19 20:24 Zeljan Rikalo Status acknowledged => feedback
2012-02-04 12:25 Zeljan Rikalo Note Added: 0056351
2012-02-04 12:25 Zeljan Rikalo Assigned To => Martin Friebe
2012-02-04 12:25 Zeljan Rikalo Status feedback => assigned
2012-02-04 12:26 Zeljan Rikalo LazTarget 0.99.0 => 1.2
2012-02-04 12:26 Zeljan Rikalo Note Added: 0056352
2012-02-08 04:36 Martin Friebe Relationship added related to 0019411
2012-02-08 04:36 Martin Friebe Assigned To Martin Friebe => Paul Ishenin
2012-02-21 01:34 Paul Ishenin Fixed in Revision => 35504
2012-02-21 01:34 Paul Ishenin Status assigned => resolved
2012-02-21 01:34 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2012-02-21 01:34 Paul Ishenin Resolution reopened => fixed
2012-02-21 01:34 Paul Ishenin Note Added: 0056949
2012-02-21 01:34 Paul Ishenin Note Added: 0056950