View Issue Details

IDProjectCategoryView StatusLast Update
0014813LazarusIDEpublic2010-10-31 22:17
ReporterSven BarthAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.28Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0014813: Identifier Completion not usable during Synchron Edit
DescriptionIf I use Identifier Completion (Ctrl+Space) during Synchron Edit, the Synchron Edit mode is left and only the first block of the active ones is replaced.
Additional InformationExample:

var
  strings, slist: TStrings;
(...)
strings.Names[0] := 'foo';
strings.ValueFromIndex[0] := 'bar';

Select the two "strings" lines and enter Synchron Edit mode ("strings" should be selected). Enter first two letters of "slist" and execute Identifer Completion.

Result looks like this:

(...)
slist.Names[0] := 'foo';
.ValueFromIndex[0] := 'bar';
TagsNo tags attached.
Fixed in Revision25250
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0014773 closedMartin Friebe New $param templates: Template is "done" when using Identifier Completion + Enter 

Activities

Sven Barth

2009-10-15 17:54

manager   ~0031343

I know it, that they are related :P

Martin Friebe

2009-10-15 18:38

manager   ~0031344

Try with revision 22195.

Identifier completion inside the cell should now work.

I also allowed for other codetool edits *outside* the cell, such as creation of local variable (shift-ctrl-c on variable name).

However user input / typing outside a cell is still (supposed) to be forbidden, and will cancel the syncro/template mode.

The reason you can move the caret outside the cells is that you may whist to copy some code from outside, and paste it into a cell.

The current fix has one very minor fault:
If you mark text in front of a cell, so that the caret is at the border of the cell (technically that counts the caret as inside the cell), you can overwrite the block, which is editing outside the cell. But it will not be detected, the syncro mode continues to operate.

Hence I leave this report open (just this, as I have the remainder description on here).

Sven Barth

2009-10-15 21:55

manager   ~0031349

Ok... it works as expected. Also the possibility to use ctrl+shift+c is a good work around till 0014774 becomes reality ^^

I was also able to reproduce the fault you described. I believe very much that this will be fixed somewhen ;) Till then I'll take care marking text while using Synchron Edit mode...

Nevertheless: Thank you so far

Sven Barth

2010-10-31 22:17

manager   ~0042509

Works good so far. Thank you very much :D

Regards,
Sven

Issue History

Date Modified Username Field Change
2009-10-15 17:23 Sven Barth New Issue
2009-10-15 17:23 Sven Barth Widgetset => Win32/Win64
2009-10-15 17:35 Martin Friebe Relationship added related to 0014773
2009-10-15 17:36 Martin Friebe Status new => assigned
2009-10-15 17:36 Martin Friebe Assigned To => Martin Friebe
2009-10-15 17:54 Sven Barth Note Added: 0031343
2009-10-15 18:38 Martin Friebe Note Added: 0031344
2009-10-15 21:55 Sven Barth Note Added: 0031349
2010-05-08 16:36 Martin Friebe Fixed in Revision => 25250
2010-05-08 16:36 Martin Friebe LazTarget => 0.9.30
2010-05-08 16:36 Martin Friebe Status assigned => resolved
2010-05-08 16:36 Martin Friebe Fixed in Version => 0.9.29 (SVN)
2010-05-08 16:36 Martin Friebe Resolution open => fixed
2010-05-08 16:36 Martin Friebe Target Version => 0.9.30
2010-10-31 22:17 Sven Barth Status resolved => closed
2010-10-31 22:17 Sven Barth Note Added: 0042509