View Issue Details

IDProjectCategoryView StatusLast Update
0014829LazarusDatabasepublic2018-05-09 00:58
ReporterDomingo Alvarez DuarteAssigned ToJesus Reyes 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version1.8.4Fixed in Version1.9 (SVN) 
Summary0014829: When edit a created dbfield on object inspector garbage comes for fields type blob
DescriptionAttached is a simple project that show garbage on the dbfield notes that is of type TEXT on postgresql.
Also the menu option "add fields" and after it the "Create" button sometimes give access violation or insert/create fields not selected.
TagsDatabase
Fixed in Revision
LazTarget1.8.4
Widgetset
Attached Files

Activities

2009-10-17 11:32

 

bugsqldb.zip (6,852 bytes)

Jesus Reyes

2018-05-09 00:58

developer   ~0108208

From the description and the lfm file, it seems to have been a time where TEXT columns where mapped to ftBlob fields, now they are mapped to ftMemo fields.

Because the conditions have changed in the mean time and I could not reproduce the problem with the current versions of Lazarus and FPC and the given description, I'm resolving this problem as fixed. If this is not so, please update the description, the sample project and the steps to reproduce the problem or close this report is everything is working as it should.

Issue History

Date Modified Username Field Change
2009-10-17 11:32 Domingo Alvarez Duarte New Issue
2009-10-17 11:32 Domingo Alvarez Duarte File Added: bugsqldb.zip
2009-10-17 19:28 Jesus Reyes Status new => assigned
2009-10-17 19:28 Jesus Reyes Assigned To => Jesus Reyes
2010-03-15 03:04 Jesus Reyes Tag Attached: Database
2018-05-09 00:58 Jesus Reyes LazTarget => 1.8.4
2018-05-09 00:58 Jesus Reyes Note Added: 0108208
2018-05-09 00:58 Jesus Reyes Status assigned => resolved
2018-05-09 00:58 Jesus Reyes Fixed in Version => 1.9 (SVN)
2018-05-09 00:58 Jesus Reyes Resolution open => fixed
2018-05-09 00:58 Jesus Reyes Target Version => 1.8.4