View Issue Details

IDProjectCategoryView StatusLast Update
0014842FPCCompilerpublic2009-12-03 14:00
ReporterDenis Golovan Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformLinux 
Product Version2.5.1 
Summary0014842: Implements makes Support function return wrong result
DescriptionSupport does not work as expected when "implements" is used.
See attach for details.

Tested in fpc 2.5.1 svn 13618
Tagscom, implements
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

2009-10-18 13:50

 

Sergei Gorelkin

2009-12-03 02:19

developer   ~0032678

Not a bug, I presume.

Casting TObj2 to IIntf1 delegates the interface handling to TObj1, which 'knows' nothing about TObj2 and implements only IIntf1. So it's simply impossible to get back to TObj2 without writing additional code.

Delphi 7 behaves exactly as FPC on this example.

Denis Golovan

2009-12-03 07:50

reporter   ~0032684

Ok. Thanks. I see now. Somebody close this ticket

Issue History

Date Modified Username Field Change
2009-10-18 13:50 Denis Golovan New Issue
2009-10-18 13:50 Denis Golovan File Added: Interface-Supports.tar.gz
2009-10-18 14:01 Marco van de Voort Tag Attached: com
2009-10-18 14:01 Marco van de Voort Tag Attached: implements
2009-12-03 02:19 Sergei Gorelkin Note Added: 0032678
2009-12-03 07:50 Denis Golovan Note Added: 0032684
2009-12-03 14:00 Jonas Maebe Status new => closed
2009-12-03 14:00 Jonas Maebe Resolution open => no change required