View Issue Details

IDProjectCategoryView StatusLast Update
0014892LazarusWidgetsetpublic2009-12-14 17:40
Reporteryann.mAssigned ToDmitry Boyarintsev 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.28Product Build 
Target Version0.9.30Fixed in Version0.9.30 
Summary0014892: Carbon: TImage mousedown + mousemove problem
DescriptionNew bug with Lazarus 0.9.28 (MasOs X 10.5)

with the mouse left button down on a TImage:

the onmousemove event isn't recognized (?) if the cursor goes outside the timage.

With Laz 0.9.26.2 this was working well.
Additional Informationsome of my components are not working with that bug, i'm back under 0.9.26.2
TagsNo tags attached.
Fixed in Revision23088
LazTarget0.9.30
WidgetsetCarbon
Attached Files

Activities

Dmitry Boyarintsev

2009-10-25 20:27

developer   ~0031663

Please provide a reproducible test.

The following code works as expected.

procedure TForm1.Image1MouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);
begin
  Caption := Format('%d %d', [x,y]);
  if ssLeft in Shift then Caption := Caption + ' pressed';
end;

Dmitry Boyarintsev

2009-10-25 20:30

developer   ~0031664

Some standard OSX controls, doesn't inform about mousemove with left button pressed. It cannot be fixed, since it's limitation of the system composite engine.

But TImage is not standard OSX control, so you should be able to get OnMouseMove event.

yann.m

2009-10-26 00:53

reporter   ~0031668

I confirm the problem

Most of time (99%) the following code isn't working if the cursor goes outside the TImage (with left button down)

-----------------------

procedure TForm1.Image1MouseMove(Sender: TObject; Shift: TShiftState; X,
    Y: Integer);
begin
    Caption := Format('%d %d', [x,y]);
  if ssLeft in Shift then Caption := Caption + ' pressed';
end;

procedure TForm1.Image1MouseUp(Sender: TObject; Button: TMouseButton;
    Shift: TShiftState; X, Y: Integer);
begin
    if Button = mbLeft then caption := 'Left button up !';
end;

------------------------

after tests:
it seems that pressing the left button while the cursor is moving makes the above code working

but if i left clic then i move the cursor the code isn't working


(sorry for my english)

Dmitry Boyarintsev

2009-12-11 22:51

developer   ~0032980

please test and close if ok

yann.m

2009-12-13 15:13

reporter   ~0033034

It's ok

Thanks a lot

Vincent Snijders

2009-12-13 19:02

manager   ~0033044

If it is ok, then please close the issue.

yann.m

2009-12-14 17:40

reporter   ~0033077

closed

Issue History

Date Modified Username Field Change
2009-10-25 19:46 yann.m New Issue
2009-10-25 19:46 yann.m Widgetset => Carbon
2009-10-25 20:27 Dmitry Boyarintsev LazTarget => -
2009-10-25 20:27 Dmitry Boyarintsev Note Added: 0031663
2009-10-25 20:27 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2009-10-25 20:27 Dmitry Boyarintsev Status new => feedback
2009-10-25 20:30 Dmitry Boyarintsev Note Added: 0031664
2009-10-25 20:33 Vincent Snijders LazTarget - => 0.9.30
2009-10-25 20:33 Vincent Snijders Target Version => 0.9.30
2009-10-26 00:53 yann.m Note Added: 0031668
2009-12-11 13:32 Vincent Snijders Status feedback => assigned
2009-12-11 22:51 Dmitry Boyarintsev Fixed in Revision => 23088
2009-12-11 22:51 Dmitry Boyarintsev Status assigned => resolved
2009-12-11 22:51 Dmitry Boyarintsev Fixed in Version => 0.9.30
2009-12-11 22:51 Dmitry Boyarintsev Resolution open => fixed
2009-12-11 22:51 Dmitry Boyarintsev Note Added: 0032980
2009-12-13 15:13 yann.m Note Added: 0033034
2009-12-13 19:02 Vincent Snijders Note Added: 0033044
2009-12-14 17:40 yann.m Status resolved => closed
2009-12-14 17:40 yann.m Note Added: 0033077