View Issue Details

IDProjectCategoryView StatusLast Update
0014894LazarusWidgetsetpublic2009-11-16 23:53
ReporterŽilvinas Ledas Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0014894: Wrong MainMenu drawing on Windows7 when RightJustify := true
DescriptionWhen I set
MyMenuItem.RightJustify := true;
to some main menu item, there is "empty space" in the menu that is not drawn correctly.
See attached screenshot.
TagsNo tags attached.
Fixed in Revision22410,22595
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Activities

2009-10-25 22:57

 

main_menu_paint_bug.png (28,347 bytes)   
main_menu_paint_bug.png (28,347 bytes)   

Paul Ishenin

2009-10-27 11:01

manager   ~0031714

Your menu looks strange at all. Can you attach an example?

2009-10-31 16:49

 

Žilvinas Ledas

2009-10-31 16:50

reporter   ~0031816

I have added an example. but it is as simple as it can be :)
Maybe my screenshoot menu looks strange as it has that right-aligned item without caption only with image ;)

Paul Ishenin

2009-11-03 20:21

manager   ~0031867

Please test and close if ok.

Žilvinas Ledas

2009-11-10 17:32

reporter   ~0032044

It is ok in the compiled program, but in the Lazarus designer it is not fixed.

Žilvinas Ledas

2009-11-10 17:49

reporter   ~0032045

Sorry for the late reply but the issue is not solved...
Menu background (without items) is not repainted in the form designer AND after minimize->restore in any compiled app.
Now it isreproducable and without MyMenuItem.RightJustify := true; case.

Paul Ishenin

2009-11-15 14:49

manager   ~0032153

I made another trial to fix that problem.
Please test and close if ok.

Žilvinas Ledas

2009-11-16 23:53

reporter   ~0032197

Thank You! I didn't notice any problems now.

Issue History

Date Modified Username Field Change
2009-10-25 22:57 Žilvinas Ledas New Issue
2009-10-25 22:57 Žilvinas Ledas File Added: main_menu_paint_bug.png
2009-10-25 22:57 Žilvinas Ledas Widgetset => Win32/Win64
2009-10-26 11:03 Vincent Snijders LazTarget => 0.9.30
2009-10-26 11:03 Vincent Snijders Assigned To => Paul Ishenin
2009-10-26 11:03 Vincent Snijders Status new => assigned
2009-10-26 11:03 Vincent Snijders Target Version => 0.9.30
2009-10-27 11:01 Paul Ishenin Note Added: 0031714
2009-10-27 11:01 Paul Ishenin Status assigned => feedback
2009-10-31 16:49 Žilvinas Ledas File Added: Menu_right_align_test.zip
2009-10-31 16:50 Žilvinas Ledas Note Added: 0031816
2009-11-03 17:25 Paul Ishenin Status feedback => assigned
2009-11-03 20:21 Paul Ishenin Fixed in Revision => 22410
2009-11-03 20:21 Paul Ishenin Status assigned => resolved
2009-11-03 20:21 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2009-11-03 20:21 Paul Ishenin Resolution open => fixed
2009-11-03 20:21 Paul Ishenin Note Added: 0031867
2009-11-10 17:32 Žilvinas Ledas Status resolved => closed
2009-11-10 17:32 Žilvinas Ledas Note Added: 0032044
2009-11-10 17:49 Žilvinas Ledas Status closed => assigned
2009-11-10 17:49 Žilvinas Ledas Resolution fixed => reopened
2009-11-10 17:49 Žilvinas Ledas Note Added: 0032045
2009-11-15 14:49 Paul Ishenin Fixed in Revision 22410 => 22410,22595
2009-11-15 14:49 Paul Ishenin Status assigned => resolved
2009-11-15 14:49 Paul Ishenin Resolution reopened => fixed
2009-11-15 14:49 Paul Ishenin Note Added: 0032153
2009-11-16 23:53 Žilvinas Ledas Note Added: 0032197
2009-11-16 23:53 Žilvinas Ledas Status resolved => closed