View Issue Details

IDProjectCategoryView StatusLast Update
0014942LazarusIDEpublic2009-11-29 13:36
ReporterJan Magne Landsvik Assigned ToPaul Ishenin  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.26.3 (SVN) 
Target Version1.0.0Fixed in Version0.9.28 
Summary0014942: Changing the EditrOptions:FGcolornumber > 128 crashes the IDE.
DescriptionEnvironment>
Editor Options:Color

Changing the ForeGroundColornumber > 128, crashes the IDE.
(Same goes for BackGroundColor)

Correct Version number is: 0.9.26-4 beta (fpc: 2.2.2-8)

Linux Mint (Linux lanjan-desktop 2.6.28-16-generic 0000055-Ubuntu SMP Tue Oct 20 19:48:24 UTC 2009 i686 GNU/Linux)
Additional InformationI stumbled over it, when failing to selecting all numbers.
Then when writing 40, it became 400. Instant Crash.

Trying more, crashing everytime.

More testing gave me 128 as the maximum size number.

Not all fields are affected, glow or whatever topmost selector is, takes as many number 9 as the field can fit.
Field below crashes with > 128.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK
Attached Files

Activities

Vincent Snijders

2009-11-18 15:15

manager   ~0032253

Can you retest with Lazarus 0.9.28 or higher, which defaults to the gtk2 widgetset?

Jan Magne Landsvik

2009-11-22 20:19

reporter   ~0032347

RE-testing with
Lazarus: 0.9.28.2-0 beta
Widgetset: gtk2

Now, this is how it's supposed to be.
Whatever you put into the numberfields now, (and I really mean whatever) it resets to the max or min value for that field.

Paul Ishenin

2009-11-23 05:37

manager   ~0032362

Ok. So we can close the issue since it is fixed in 0.9.28. Please close if ok.

Jan Magne Landsvik

2009-11-29 13:36

reporter   ~0032573

As suggested by Paul Ishenin.

Issue History

Date Modified Username Field Change
2009-10-29 23:54 Jan Magne Landsvik New Issue
2009-10-29 23:54 Jan Magne Landsvik Widgetset => GTK
2009-11-18 15:15 Vincent Snijders LazTarget => 1.0
2009-11-18 15:15 Vincent Snijders Note Added: 0032253
2009-11-18 15:15 Vincent Snijders Status new => feedback
2009-11-18 15:15 Vincent Snijders Target Version => 1.0.0
2009-11-22 20:19 Jan Magne Landsvik Note Added: 0032347
2009-11-23 05:37 Paul Ishenin Status feedback => resolved
2009-11-23 05:37 Paul Ishenin Fixed in Version => 0.9.28
2009-11-23 05:37 Paul Ishenin Resolution open => fixed
2009-11-23 05:37 Paul Ishenin Assigned To => Paul Ishenin
2009-11-23 05:37 Paul Ishenin Note Added: 0032362
2009-11-29 13:36 Jan Magne Landsvik Status resolved => closed
2009-11-29 13:36 Jan Magne Landsvik Note Added: 0032573