View Issue Details

IDProjectCategoryView StatusLast Update
0015006LazarusIDEpublic2011-01-03 10:32
ReporterDavid EmersonAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSdebian linuxOS Version5.0.3
Product Version0.9.28.2Product Buildi386-linux-gtk 2 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0015006: white flash when opening new unit while debugging
DescriptionI use an inverted color scheme, which helps me with a minor visual
disability.

I often ctrl+click on an identifier to jump to its declaration. In a special case, when a unit is opened, it is initially rendered with a white background before my color scheme is applied. This results in a visually disturbing white flash.
Steps To Reproduce1. Set up an inverted color scheme for the source editor (e.g. black background, white text)
2. Quit lazarus
3. Start lazarus
4. Insert a breakpoint
5. Run program
6. encounter the breakpoint
7. open a unit which has not been opened during the current lazarus session (the reason for steps 2/3 quit/restart)
Step 7 can be done with file/open or by using ctrl+click on a unit name or identifier
TagsNo tags attached.
Fixed in Revision22549
LazTarget0.9.30
WidgetsetGTK 2, Win32/Win64
Attached Files

Activities

Martin Friebe

2009-11-12 22:02

manager   ~0032092

Please test and close if ok

David Emerson

2011-01-03 10:31

reporter   ~0044821

works great, thanks! Sorry to take so long. Wish I could figure out how to get emails from this system.

Issue History

Date Modified Username Field Change
2009-11-05 21:19 David Emerson New Issue
2009-11-05 21:19 David Emerson Widgetset => GTK 2
2009-11-06 00:20 Martin Friebe Status new => assigned
2009-11-06 00:20 Martin Friebe Assigned To => Martin Friebe
2009-11-12 22:02 Martin Friebe Fixed in Revision => 22549
2009-11-12 22:02 Martin Friebe LazTarget => 0.9.30
2009-11-12 22:02 Martin Friebe Widgetset GTK 2 => GTK 2, Win32/Win64
2009-11-12 22:02 Martin Friebe Status assigned => resolved
2009-11-12 22:02 Martin Friebe Fixed in Version => 0.9.29 (SVN)
2009-11-12 22:02 Martin Friebe Resolution open => fixed
2009-11-12 22:02 Martin Friebe Note Added: 0032092
2009-11-12 22:03 Martin Friebe Target Version => 0.9.30
2011-01-03 10:31 David Emerson Note Added: 0044821
2011-01-03 10:32 David Emerson Status resolved => closed