View Issue Details

IDProjectCategoryView StatusLast Update
0015036LazarusLCLpublic2010-01-20 20:23
ReporterClaudio Romero Assigned ToJesus Reyes  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN) 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0015036: Try to edit TDBEdit with DataSource disabled raise Access Violation, even with ReadOnly=True.
DescriptionTested under Lazarus 0.9.29 svn 22490 fpc 2.5.1 svn 13795. Windows XP SP3.

Thanks.
TagsNo tags attached.
Fixed in Revision23497
LazTarget0.9.30
WidgetsetWin32/Win64
Attached Files

Activities

Jesus Reyes

2009-11-09 04:55

developer   ~0032017

I tried to reproduce this way:

1. new application
2. drop tdbf, setup properties, set active=true: success
3. drop datasource, setup properties, set disable=true
4. drop tdbedit, setup datasource and datafield: data is shown
5. run application, edit data, it works.

please give steps to reproduce or attach a sample project. tried with rev 22491

Claudio Romero

2009-11-09 18:13

reporter   ~0032033

Last edited: 2009-11-09 18:16

Upload an example with rev 22505, under Windows XP.

With Dbf1.close and SQLQuery1.close (IBConnection with Firebird 2.1.2) raise AV too.
With Dataset enabled work, the problem is with Dataset closed. Sorry in title I post Datasource :)..

2009-11-09 18:14

 

Dbedit_read_only.zip (3,512 bytes)

Claudio Romero

2010-01-20 20:23

reporter   ~0033756

thank you very much.

Issue History

Date Modified Username Field Change
2009-11-08 21:04 Claudio Romero New Issue
2009-11-08 21:04 Claudio Romero Widgetset => Win32/Win64
2009-11-09 04:49 Jesus Reyes Status new => assigned
2009-11-09 04:49 Jesus Reyes Assigned To => Jesus Reyes
2009-11-09 04:55 Jesus Reyes LazTarget => -
2009-11-09 04:55 Jesus Reyes Note Added: 0032017
2009-11-09 04:55 Jesus Reyes Status assigned => feedback
2009-11-09 18:13 Claudio Romero Note Added: 0032033
2009-11-09 18:14 Claudio Romero File Added: Dbedit_read_only.zip
2009-11-09 18:16 Claudio Romero Note Edited: 0032033
2009-12-11 13:40 Vincent Snijders Status feedback => assigned
2010-01-20 09:25 Jesus Reyes Fixed in Revision => 23497
2010-01-20 09:25 Jesus Reyes LazTarget - => 0.9.30
2010-01-20 09:25 Jesus Reyes Status assigned => resolved
2010-01-20 09:25 Jesus Reyes Fixed in Version => 0.9.29 (SVN)
2010-01-20 09:25 Jesus Reyes Resolution open => fixed
2010-01-20 09:25 Jesus Reyes Target Version => 0.9.30
2010-01-20 20:23 Claudio Romero Status resolved => closed
2010-01-20 20:23 Claudio Romero Note Added: 0033756