View Issue Details

IDProjectCategoryView StatusLast Update
0015068LazarusWidgetsetpublic2014-09-20 00:13
ReporterPaul van HeldenAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.28Product Build 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0015068: Incorrect drawing of buttons when not using themes
DescriptionThe function FillWithDottedBrush (line 1985 of Themes.pas) actually fills with black. This causes the background of a TSpeedButton to be black when it is in a down (toggled) state.

Normally the Windows theme functions are used to draw the background but when disabled or on WinCE, this makes for very ugly toggle speedbuttons.

I can't see why a solid black block is being produced so I've just commented the function out for now.
TagsNo tags attached.
Fixed in Revision22689
LazTarget1.0
WidgetsetWinCE
Attached Files

Relationships

related to 0026748 closedFelipe Monteiro de Carvalho Patches [Patch] Improved CreateBrushIndirect workaround 

Activities

Paul Ishenin

2009-11-20 09:10

manager   ~0032309

This is not reproduced under win32. Probably windows ce can't create a dotted brush.

Paul Ishenin

2009-11-20 09:15

manager   ~0032310

I really have not checked what wince shows now but the problem was that CreatePatternBrush was not implemented for wince widgetset. I fixed that now. Hope it draws right.

Please test and close if ok.

Issue History

Date Modified Username Field Change
2009-11-12 12:41 Paul van Helden New Issue
2009-11-12 12:41 Paul van Helden Widgetset => Win32/Win64, WinCE
2009-11-18 23:15 Vincent Snijders LazTarget => 1.0
2009-11-18 23:15 Vincent Snijders Status new => acknowledged
2009-11-18 23:15 Vincent Snijders Target Version => 1.0.0
2009-11-20 09:10 Paul Ishenin Widgetset Win32/Win64, WinCE => WinCE
2009-11-20 09:10 Paul Ishenin Note Added: 0032309
2009-11-20 09:15 Paul Ishenin Fixed in Revision => 22689
2009-11-20 09:15 Paul Ishenin Status acknowledged => resolved
2009-11-20 09:15 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2009-11-20 09:15 Paul Ishenin Resolution open => fixed
2009-11-20 09:15 Paul Ishenin Assigned To => Paul Ishenin
2009-11-20 09:15 Paul Ishenin Note Added: 0032310
2011-12-01 11:22 Marc Weustink Status resolved => closed
2014-09-20 00:13 Juha Manninen Relationship added related to 0026748