View Issue Details

IDProjectCategoryView StatusLast Update
0000151Lazaruspublic2003-12-23 09:51
ReporterBug Import Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0000151: TNotebook generates pagechanged event before most objects created
DescriptionI just learned that a TNotebook will generate a pagechanged event at the form's creation, referencing the current page as the one it was left at during design time.

Meaning, if you reference objects in a datamodule during the pagechanged event, you get an access violation, because the datamodule hasn't even been created yet. I was able to put a simple check to see if the datamod existed prior to doing anything, but it seems to me that it shouldn't generate a pagechanged event at creation time.
Additional InformationImported information
--------------------
Name: Tony Maro
Mail: tony (at) maro.net
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2003-12-23 09:51

reporter   ~0000131

MG

Issue History

Date Modified Username Field Change
2003-11-13 00:00 Bug Import New Issue
2003-11-13 00:00 Bug Import Widgetset => GTK, Win32
2003-12-23 09:51 Bug Import Note Added: 0000131
2003-12-23 09:51 Bug Import Status new => closed
2003-12-23 09:51 Bug Import Resolution open => fixed