View Issue Details

IDProjectCategoryView StatusLast Update
0015226LazarusIDEpublic2011-12-01 11:22
ReporterGraeme Geldenhuys Assigned ToVincent Snijders  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSUbuntu Linux 
Product Version0.9.28.3 (SVN) 
Fixed in Version0.9.28.3 (SVN) 
Summary0015226: Compiler Options dialog is broken
DescriptionIn 0.9.28.2 the Compiler Options dialog used tabs. The 0.9.28.3 (svn) now use the same as Trunk, a listbox.

Anyway, the last two options: Inherited and Compilation is broken.

Selecting "Inherited", shows the "Compilation" information. Selecting "Compilation" doesn't do or change anything.

See attached screenshots.
 * Screenshot 1 shows the wrong information
 * Screenshot 2 shows whatever the previous information was, in this case Path.
TagsNo tags attached.
Fixed in Revision22906
LazTarget-
Widgetset
Attached Files

Relationships

related to 0015227 closedVincent Snijders Compiler Options labels disappear 

Activities

2009-12-01 08:39

 

Screenshot1.png (59,393 bytes)   
Screenshot1.png (59,393 bytes)   

2009-12-01 08:40

 

Screenshot2.png (58,887 bytes)   
Screenshot2.png (58,887 bytes)   

Graeme Geldenhuys

2009-12-01 08:52

reporter   ~0032619

I'm using the following version:
  Lazarus 0.9.28.3 r22882 FPC 2.3.1 x86_64-linux-gtk 2 (beta)

Vincent Snijders

2009-12-01 08:56

manager   ~0032621

Work in progress.

Graeme Geldenhuys

2009-12-01 09:03

reporter   ~0032623

Thanks. Just thought I would let you know (to be complete with testing), that I tested with Trunk, and there the dialog works correctly.

  Lazarus 0.9.29 rUnknown FPC 2.3.1 x86_64-linux-gtk 2 (beta)

Vincent Snijders

2009-12-01 09:27

manager   ~0032625

Thanks for testing. I probably need to merge more, but got interrupted last night.

Vincent Snijders

2009-12-22 21:18

manager   ~0033266

I cannot reproduce this with r22326. I did not merge anything since rr22906.

Can you test with the latest version?

Graeme Geldenhuys

2009-12-23 07:28

reporter   ~0033274

I can confirm that the problem is not in r22906 any more. This bug report can be closed, thanks.

Issue History

Date Modified Username Field Change
2009-12-01 08:39 Graeme Geldenhuys New Issue
2009-12-01 08:39 Graeme Geldenhuys File Added: Screenshot1.png
2009-12-01 08:40 Graeme Geldenhuys File Added: Screenshot2.png
2009-12-01 08:52 Graeme Geldenhuys Note Added: 0032619
2009-12-01 08:56 Vincent Snijders Status new => assigned
2009-12-01 08:56 Vincent Snijders Assigned To => Vincent Snijders
2009-12-01 08:56 Vincent Snijders Note Added: 0032621
2009-12-01 09:00 Vincent Snijders Relationship added related to 0015227
2009-12-01 09:03 Graeme Geldenhuys Note Added: 0032623
2009-12-01 09:27 Vincent Snijders Note Added: 0032625
2009-12-22 21:18 Vincent Snijders Note Added: 0033266
2009-12-22 21:18 Vincent Snijders LazTarget => -
2009-12-22 21:18 Vincent Snijders Status assigned => feedback
2009-12-23 07:28 Graeme Geldenhuys Note Added: 0033274
2009-12-23 09:36 Vincent Snijders Fixed in Revision => 22906
2009-12-23 09:36 Vincent Snijders Status feedback => resolved
2009-12-23 09:36 Vincent Snijders Fixed in Version => 0.9.28.3 (SVN)
2009-12-23 09:36 Vincent Snijders Resolution open => fixed
2011-12-01 11:22 Marc Weustink Status resolved => closed