View Issue Details

IDProjectCategoryView StatusLast Update
0015267LazarusIDEpublic2011-12-01 11:23
ReporteralterAssigned ToVincent Snijders 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSopenSUSEOS Version11.2
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0015267: Crash on open dialog
DescriptionWhenever open dialog, save dialog (list of folders) or select directory dialog is opened Lazarus crashes.
Steps To ReproduceFor example try to open any project or file with Lazarus.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0015114 closedJuha Manninen IDE dies when trying to select FPC source directory 
has duplicate 0015747 closedVincent Snijders Complete crash when browsing folders 

Activities

alter

2009-12-06 16:04

reporter   ~0032751

I forgot to add that I use KDE 4.3. I have now recompiled Lazarus so IDE uses Qt instead of Gtk and now it works. Lazarus was installed on 2 different machines with the same result.

Zeljan Rikalo

2009-12-06 19:34

developer   ~0032755

Think that's because of qtcurve (or similar) theme which crashes gtk2 (some ppl already mentioned it here)

Bart Broersma

2009-12-06 23:00

developer   ~0032757

Can you look at issue 0015188 and 0015114 and tell us if this is the same problem (with GTK2 qtcurve theme)?

Issue History

Date Modified Username Field Change
2009-12-06 15:55 alter New Issue
2009-12-06 16:04 alter Note Added: 0032751
2009-12-06 19:34 Zeljan Rikalo Note Added: 0032755
2009-12-06 23:00 Bart Broersma LazTarget => -
2009-12-06 23:00 Bart Broersma Note Added: 0032757
2009-12-06 23:00 Bart Broersma Status new => feedback
2010-03-12 10:54 Vincent Snijders Relationship added has duplicate 0015747
2010-03-12 10:55 Vincent Snijders Relationship added duplicate of 0015114
2010-03-12 10:55 Vincent Snijders Status feedback => resolved
2010-03-12 10:55 Vincent Snijders Fixed in Version => 0.9.29 (SVN)
2010-03-12 10:55 Vincent Snijders Resolution open => fixed
2010-03-12 10:55 Vincent Snijders Assigned To => Vincent Snijders
2011-12-01 11:23 Marc Weustink Status resolved => closed