View Issue Details

IDProjectCategoryView StatusLast Update
0015272FPCPackagespublic2019-09-20 17:51
ReporterMarelisAssigned ToMarco van de Voort 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
Platformi386OSUbuntuOS Version9.10
Product Version2.5.1Product Build 
Target VersionFixed in Version 
Summary0015272: FPC does not link against Ubuntu's libgdb.a 7.0
DescriptionDuring compilation FPC SVN 14347 error occurred, which probably is related to linking the library "/usr/lib/libgdb.a". See attached files (part of the log and symbols of the libgdb.a)

I'm not expert, but perhaps it will be something useful. I'm here this problem stated (ID: 0015236) but someone threw it in the trash without bothering to at least skim through the eyes.
Additional Informationliska@mar-liska:~$ gdb -v
GNU gdb (GDB) 7.0-ubuntu
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId0
FPCTarget-
Attached Files

Relationships

has duplicate 0017333 closedJonas Maebe libgdb.a error 

Activities

2009-12-07 08:34

 

20091207_make_part.log.tar.gz (5,632 bytes)

2009-12-07 08:35

 

20091207_libgdb_symbols.log.tar.gz (160,558 bytes)

Marco van de Voort

2009-12-07 09:46

manager   ~0032763

Did you recompile the GDBINT interfaces (fpc/packages/gdbint) with -dGDB_V700 ?

Marelis

2009-12-07 10:20

reporter   ~0032764

I exported fpcbuild SVN directory and perform the bash command "make deb". How do I switch "-dGDB_V700" used to "make deb" ? Thanks.

Jonas Maebe

2009-12-07 12:58

manager   ~0032768

Add the following at the end of the make command: OPT="-dGDB_V700"

Marelis

2009-12-07 13:22

reporter   ~0032772

I entered this bash command:

make deb OPT="-dGDB_V700" 2>&1 | tee 20091207_make_deb.log

But it seems to be the same.I uploaded a log file with this compilation. Anything else I should try? Thanks.

2009-12-07 13:22

 

20091207_make_deb.log.tar.gz (91,120 bytes)

Marco van de Voort

2009-12-08 22:21

manager   ~0032825

If I quickly look at this report, I see that the missing symbols seem to fall in three categories:

1 python related symbols
2 decimal related symbols
3 inflate* symbols

GDB probably has multiple configuration options. Compile 7.0 without Python support and try again. Otherwise you'll have to fix gdbint for python support.

The textmode IDE afaik does not need support for python debugging, so it is best to disable it. The other two catergories might be dependancies of python, or other additional optional parts of GDB.

Marelis

2009-12-09 09:52

reporter   ~0032832

Interesting description of the Debian package libgdb-dev in Ubuntu 9.10 (part):

"This package contains libgdb.a, the bulk of GDB as a linkable library. It is provided for an IDE which links to libgdb.a. Please do not use libgdb.a for new projects."

Will continue to use this library? Are not you afraid that one day disappear from the face of the globe, as indicated by the end of the description of the package? :)

Okay, I will try to overcome the problem by cutting Python. If I was silent a long time, it's that looking sharp knife or drove me to the hospital: o)

If someone could solve this problem without circumvention, so for me to be a great guy. Thanks!

Jonas Maebe

2009-12-09 09:59

manager   ~0032833

That package comment explicitly refers to the FPC text mode IDE. They added it specifically for that IDE, so I guess they will leave it in as long as the IDE uses it.

Marelis

2009-12-09 10:20

reporter   ~0032836

The point is the sentence: "Please do not use libgdb.a for new projects."

Sometimes it is strictly logical thinking counter-productive.

Jonas Maebe

2009-12-09 10:31

manager   ~0032837

> The point is the sentence: "Please do not use libgdb.a for new projects."

The text mode IDE is the extremely old project (dating back to 1996 or so) which caused this package to be added to Debian/Ubuntu (see ). They are saying that you should not use that library for newly developed programs or IDEs.

> Sometimes it is strictly logical thinking counter-productive

Please stop with your snide remarks.

Marelis

2009-12-09 11:23

reporter   ~0032840

Last edited: 2009-12-09 11:24

When do I use SVN export fpcbuild + "make deb ..." thus detects the presence of the library libgdb.a. So the library is taken into account when creating a Debian package by running "make deb ...".

If the package manager with "libgdb.a" asks that this was not used instead, it is probably obvious question: "Will this continue to use the library?" (of course I mean fpcbuild SVN export + "make deb ...").

And an explanation that "it will be used until it will be used" simply do not accept, that forgiveness is a tautology. When I run "make deb ... " and not the result of linking error, but the packages, and express my deepest admiration and appreciation. Nothing bad, just opinion. Thanks.

P.S. - I noticed that there is machine and non-emotional language without humor and hyperbole, so what I write about irritating mechanical eye: o) do not apologize for, I am a man and not a machine. Thanks.

Pierre Muller

2009-12-09 11:54

developer   ~0032841

I tried to improve gdbint.pp for GDB 7.0 support
in svn revision 14375.
  Could you please check if that works for you?

  I am not sure it will be sufficient as
it needs a libpython.so or a libpython.a that is
a symbolic link to the python version used for gdb compilation
that generated the libgdb.a.

  One easier solution is to recompile GDB 7.0 from sources
and use svn packages/gdbint/gen-gdblib-inc.sh script.

  For that simply copy and run that script in the
build/gdb folder, after run
./copy-libs.sh /directory/to/fpcsrc/libgdb/linux/i386
replacing directory/to by the appropriate directory of course.

  Rerunning make in packages/gdbint should then
find the libraries in fpcsrc/libgdb/linux/i386
and use the generated gdblib.inc that should contain all
needed $LINKLIB.

Marco van de Voort

2009-12-09 12:38

manager   ~0032842

What's the point of having python support in the textmode IDE? It only introduces a dependancy that can go wrong? Or am I missing something?

Jonas Maebe

2009-12-09 12:49

manager   ~0032843

Ubuntu ships a /usr/lib/libgdb.a 7.0 that is presumably compiled using the default options, which means that it depends on Python (because gdb 7.0 added Python scripting support that is enabled by default).

Marelis

2009-12-09 12:51

reporter   ~0032844

@ Pierre Muller

I exported fpcbuild with fpcsrc SVN 14375 and made bash command:

make deb OPT="-dGDB_V700"

Part of the log file:

LibGDB found in /usr/lib/libgdb.a
make[5]: Leaving directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
/usr/bin/make fpc_all
make[5]: Entering directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/compiler/ppc386 -di386 -Fl/usr/lib -Ur -Xs -O2 -n -Sg -Fu/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux -Fu/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/packages/fv/units/i386-linux -Fu/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/packages/gdbint/units/i386-linux -Fu/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/packages/regexpr/units/i386-linux -Fu/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/packages/fcl-base/units/i386-linux -Fu/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/packages/iconvenc/units/i386-linux -Fu/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/packages/fcl-xml/units/i386-linux -Fu/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/packages/chm/units/i386-linux -FE. -FUunits/i386-linux -Fl/usr/lib/gcc/i486-linux-gnu/4.4.1 -Flinclude -Fl/etc/ld.so.conf.d/*.conf -dGDB_V700 -dRELEASE fp.pas
/usr/bin/ld: warning: ./link.res contains output sections; did you forget -T?
/usr/bin/ld: cannot find -ldecnumber
fp.pas(575,1) Error: Error while linking
fp.pas(575,1) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
make[5]: *** [fp] Error 1
make[5]: Leaving directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
make[4]: *** [buildfp] Error 2
make[4]: Leaving directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
make[3]: *** [gdb] Error 2
make[3]: Leaving directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
make[2]: *** [ide_all] Error 2
make[2]: Leaving directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc'
make[1]: *** [build-arch-stamp] Error 2
make[1]: Leaving directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1'
dpkg-buildpackage: error: debian/rules build gave error exit status 2
make: *** [debbuild] Error 2

-eof-

I see that it's on track to solve! I'm going to look for "-ldecnumber": o) Some quick tip what to do?

Thank you for your cooperation. I am fully available, if it were something to be tested.

Pierre Muller

2009-12-09 13:42

developer   ~0032848

Try adding "FPCOPT-s" to make call
and manually remove the line containing
-ldecnumber
from 'link.res' file to
see if the the linker works
by launching
 ./ppas.sh
afterward.

Marelis

2009-12-09 14:50

reporter   ~0032850

I added to make "FPCOPT-s" and after running make file "link.res" I see, but where is ppas.sh? Either I am blind or is an error between chair and keyboard: o)

Pierre Muller

2009-12-09 14:56

developer   ~0032851

It should be 'FPCOPT=-s' sorry,
this adds '-s' option to ppc386 command line.
'-s' option is for do not link, but create a script
that can be run later.

Marelis

2009-12-09 20:23

reporter   ~0032857

Last edited: 2009-12-09 20:23

Error is more on my side when I missed. When added in make 'FPCOPT=-s' so it ends as follows (now with fpcsrc SVN 14378):

--- Building
dh_testdir
/usr/bin/make -C fpcsrc compiler_cycle
make[2]: Entering directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc'
/usr/bin/make -C compiler cycle
make[3]: Entering directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/compiler'
/usr/bin/make tempclean ppc3
make[4]: Entering directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/compiler'
/bin/rm -f ppcross386 ppc ppc1 ppc2 ppc3 ./msg2inc pp1.wpo pp2.wpo
/usr/bin/make 'OLDFPC=' next
make[5]: Entering directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/compiler'
/usr/bin/make rtlclean rtl
make[6]: Entering directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/compiler'
/usr/bin/make -C /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl clean
make[7]: Entering directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl'
/bin/rm -f fpcmade.i386-linux Package.fpc ppas.sh script.res link.res
/bin/rm -f *.s *_ppas.sh
/usr/bin/make -C linux clean
make[8]: Entering directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/linux'
/bin/rm -f /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/system.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/si_prc.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/si_c21g.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/si_c21.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/si_c.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/si_dll.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/si_uc.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/unixtype.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/ctypes.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/baseunix.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/strings.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/objpas.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/macpas.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/syscall.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/unixutil.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/fpintres.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/heaptrc.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/lineinfo.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/lnfodwrf.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/termio.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/unix.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/linux.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/initc.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/cmem.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/x86.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/ports.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/cpu.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/mmx.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/crt.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/printer.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/linuxvcs.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/sysutils.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/typinfo.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/math.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/matrix.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/varutils.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/charset.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/ucomplex.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/getopts.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/errors.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/sockets.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/gpm.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/ipc.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/serial.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/terminfo.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/dl.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/dynlibs.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/video.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/mouse.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/keyboard.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/variants.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/types.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/dateutils.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/sysconst.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/fmtbcd.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/cthreads.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/classes.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/fgl.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/convutils.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/stdconvs.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/strutils.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/rtlconsts.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/dos.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/objects.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/cwstring.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/fpcylix.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/clocale.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/exeinfo.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/syslinux.ppu /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/linux.ppu
/bin/rm -f /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/math.rst /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/varutils.rst /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/typinfo.rst /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/variants.rst /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/sysconst.rst /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/rtlconsts.rst /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux/stdconvs.rst
/bin/rm -f fpcmade.i386-linux Package.fpc ppas.sh script.res link.res
/bin/rm -f *.s *_ppas.sh
make[8]: Leaving directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/linux'
make[7]: Leaving directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl'
/usr/bin/make -C /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl 'OPT=-dGDB_V700' all
make[7]: Entering directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl'
/usr/bin/make -C linux all
make[8]: Entering directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/linux'
/bin/mkdir -p /home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux
/usr/bin/ppc386 -s -Ur -Ur -Xs -O2 -n -Fi../inc -Fi../i386 -Fi../unix -Fii386 -FE. -FU/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux -dGDB_V700 -di386 -dRELEASE -Us -Sg system.pp
thread.inc(332,10) Warning: Function result does not seem to be set
thread.inc(344,11) Warning: Function result does not seem to be set
thread.inc(354,11) Warning: Function result does not seem to be set
thread.inc(359,11) Warning: Function result does not seem to be set
thread.inc(364,11) Warning: Function result does not seem to be set
thread.inc(393,10) Warning: Function result does not seem to be set
thread.inc(412,11) Warning: Function result does not seem to be set
thread.inc(436,11) Warning: Function result does not seem to be set
thread.inc(442,11) Warning: Function result does not seem to be set
thread.inc(483,10) Warning: Function result does not seem to be set
/usr/bin/ppc386 -s -Ur -Ur -Xs -O2 -n -Fi../inc -Fi../i386 -Fi../unix -Fii386 -FE. -FU/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/units/i386-linux -dGDB_V700 -di386 -dRELEASE si_prc.pp
make[8]: ppas.sh: Command not found
make[8]: *** [si_prc.ppu] Error 127
make[8]: Leaving directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl/linux'
make[7]: *** [linux_all] Error 2
make[7]: Leaving directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/rtl'
make[6]: *** [rtl] Error 2
make[6]: Leaving directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/compiler'
make[5]: *** [next] Error 2
make[5]: Leaving directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/compiler'
make[4]: *** [ppc1] Error 2
make[4]: Leaving directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/compiler'
make[3]: *** [cycle] Error 2
make[3]: Leaving directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/compiler'
make[2]: *** [compiler_cycle] Error 2
make[2]: Leaving directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc'
make[1]: *** [build-arch-stamp] Error 2
make[1]: Leaving directory `/home/marek/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1'
dpkg-buildpackage: error: debian/rules build gave error exit status 2
make: *** [debbuild] Error 2

-eof-

I'm doing something wrong? Thanks.

Pierre Muller

2009-12-10 01:02

developer   ~0032875

You shouldn't try to redo everything with that option,
you need to first go to fpcsrc/ide directory.
Only there, you add the FPCOPT=-s command line arg to make,
edit link.res to see if it works if you remove the -ldecnumber line.
You run './ppas.sh' to start the linker and check if compilation
works, but I suspect that libdecnumber.a is really required
for the IDE to be linked successfully...

Could you tell me if the debian package had other files in it?

Marelis

2009-12-10 11:13

reporter   ~0032897

Last edited: 2009-12-10 11:22

So from the beginning:

1) export fpcbuild (fpcsrc SVN 14381) to the directory "../fpcbuild"

2) enter to directory "../fpcbuild"

3) execute the command:

make deb OPT="-dGDB_V700"

... so it now was in a state with error "/usr/bin/ld: cannot find -ldecnumber"

4) enter to directory "../fpcbuild/build/fpc-2.5.1/fpcsrc/ide"

5) execute the command:

make 'FPCOPT=-s'

Command result:

make buildfp
make[1]: Entering directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
make compilerunits
make[2]: Entering directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
make[2]: Nothing to be done for `compilerunits'.
make[2]: Leaving directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
make testgdb
make[2]: Entering directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
LibGDB found in /usr/lib/libgdb.a
make[2]: Leaving directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
make fpc_all
make[2]: Entering directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
/usr/bin/ppc386 -s -di386 -Fl../libgdb/linux -Sg -Fu../rtl/units/i386-linux -Fu../packages/fv/units/i386-linux -Fu../packages/gdbint/units/i386-linux -Fu../packages/regexpr/units/i386-linux -Fu../packages/fcl-base/units/i386-linux -Fu../packages/iconvenc/units/i386-linux -Fu../packages/fcl-xml/units/i386-linux -Fu../packages/chm/units/i386-linux -FE. -FUunits/i386-linux -Fl/usr/lib/gcc/i486-linux-gnu/4.4.1 -Flinclude -Fl/etc/ld.so.conf.d/*.conf fp.pas
Free Pascal Compiler version 2.4.0rc1-0 [2009/11/07] for i386
Copyright (c) 1993-2009 by Florian Klaempfl
Target OS: Linux for i386
Compiling fp.pas
Compiling fpcatch.pas
Compiling fpcompil.pas
PPU Loading units/i386-linux/finput.ppu
PPU Invalid Version 106
Fatal: Can't find unit FInput used by FPCompil
Fatal: Compilation aborted
make[2]: Leaving directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'
make[1]: Leaving directory `/home/liska/Marelis/Skripty/Bash/.svn_export/fpcbuild/build/fpc-2.5.1/fpcsrc/ide'

The correct procedures and orders, or I'm wrong again?

> Could you tell me if the debian package had other files in it?

What Debian package exactly?

I apologize for the delay, to solve problems here, a lot of work.

Thank you for your time spent on solving this problem, I highly appreciate it.

Marco van de Voort

2010-02-15 16:08

manager   ~0034498

Jonas: I suspect gdb's configure auto enables stuff when found and not explicitely forbidden.

This because it compiles fine on systems without python without explicit disabling it.

Marco van de Voort

2010-02-19 23:01

manager   ~0034612

Marelis: the restart of building is performed with the installed (starting) compiler (2.4.0rc1 as visible clearly in the log), not with the newly created compiler.

You should restart the build with exactly the same parameters as were given in the failing one (in this case FPC=../compiler/ppc386 probably, but there may be others)

Marelis

2010-02-20 05:37

reporter   ~0034615

Last edited: 2010-02-20 05:51

The same error (cannot find-ldecnumber) when installed fpc 2.4.0 (official release) and fpcsrc (fpcbuild) svn revision 14929 IF installed package libgdb-dev with libgdb.a

(maybe I BFU, but the debian packages fpc 2.4.0rc1 I downloaded from your ftp server and then installs them)

And what about the error "cannot find-ldecnumber? It has a solution?

I tried to repeat the recommendation (line No. 5), namely, the command:

make 'FPCOPT=-s' in directory "../fpcbuild/build/fpc-2.5.1/fpcsrc/ide"

so it turned out as follows:

make buildfp
make[1]: Entering directory `/media/Marelis/Build/fpc/20100220_050722.fpc.sh/build/fpc-2.5.1/fpcsrc/ide'
make compilerunits
make[2]: Entering directory `/media/Marelis/Build/fpc/20100220_050722.fpc.sh/build/fpc-2.5.1/fpcsrc/ide'
make[2]: Nothing to be done for `compilerunits'.
make[2]: Leaving directory `/media/Marelis/Build/fpc/20100220_050722.fpc.sh/build/fpc-2.5.1/fpcsrc/ide'
make testgdb
make[2]: Entering directory `/media/Marelis/Build/fpc/20100220_050722.fpc.sh/build/fpc-2.5.1/fpcsrc/ide'
LibGDB found in /usr/lib/libgdb.a
make[2]: Leaving directory `/media/Marelis/Build/fpc/20100220_050722.fpc.sh/build/fpc-2.5.1/fpcsrc/ide'
make fpc_all
make[2]: Entering directory `/media/Marelis/Build/fpc/20100220_050722.fpc.sh/build/fpc-2.5.1/fpcsrc/ide'
/usr/bin/ppc386 -s -di386 -Fl../libgdb/linux -Sg -Fu../rtl/units/i386-linux -Fu../packages/fv/units/i386-linux -Fu../packages/gdbint/units/i386-linux -Fu../packages/regexpr/units/i386-linux -Fu../packages/fcl-base/units/i386-linux -Fu../packages/iconvenc/units/i386-linux -Fu../packages/fcl-xml/units/i386-linux -Fu../packages/chm/units/i386-linux -FE. -FUunits/i386-linux -Fl/usr/lib/gcc/i486-linux-gnu/4.4.1 -Flinclude -Fl/etc/ld.so.conf.d/*.conf fp.pas
Free Pascal Compiler version 2.4.0-0 [2009/12/21] for i386
Copyright (c) 1993-2009 by Florian Klaempfl
Target OS: Linux for i386
Compiling fp.pas
Compiling fpcatch.pas
Compiling fpcompil.pas
PPU Loading units/i386-linux/finput.ppu
PPU Invalid Version 115
Fatal: Can't find unit FInput used by FPCompil
Fatal: Compilation aborted
make[2]: Leaving directory `/media/Marelis/Build/fpc/20100220_050722.fpc.sh/build/fpc-2.5.1/fpcsrc/ide'
make[1]: Leaving directory `/media/Marelis/Build/fpc/20100220_050722.fpc.sh/build/fpc-2.5.1/fpcsrc/ide'

Thanks.

Marco van de Voort

2010-02-20 12:13

manager   ~0034617

Please read the message carefully again. It should be built with the JUST BUILT compiler (2.5.1), not the starting compiler (2.4.0 release)

Marelis

2010-02-21 07:15

reporter   ~0034624

I apologize for my ineptitude.

I made several interventions in installed Ubuntu.

Commands in terminal (>):

> sudo apt-get install hercules

// this adds the library libdecnumber

> sudo ln -s /usr/lib/libdecNumber.la /usr/lib/libdecnumber.la
> sudo ln -s /usr/lib/libdecNumber.so /usr/lib/libdecnumber.so

// author of the package probably did not realize
// that a large letter in the name may cause complications :o)

> sudo apt-get install libpython2.6

// I mention to be sure, most of this package is already installed

> sudo ln -s /usr/lib/libpython2.6.so.1 /usr/lib/libpython.so

// at this point I have, maybe a lot of naive question:

// should linker know that they are of different versions
// of python libraries - by name - and should therefore be given
// as a basis for linking (in file link.res) the specific version
// of the library? (for example: -lpython2.6)

// Maybe it's bullshit, If so, throw it in the trash.

> cd ../build/fpc-2.5.1/fpcsrc/ide

// I do not give the full path, just from the point of "build"
// This is the place where the stops "make deb" when linking.

> make 'FPCOPT=-s' FPC=../compiler/ppc386

// Here I thank Marco for gentle kick up the backside :o)

> ./ppas.sh

// I left the file link.res line with "-ldecnumber"
// The linking errors remained only that:

Linking ./fp
/usr/bin/ld: warning: ./link.res contains output sections; did you forget -T?
/usr/lib/libgdb.a(dfp.o): In function `decimal_from_integral':
(.text+0x85e): undefined reference to `decNumberFromUInt32'
/usr/lib/libgdb.a(dfp.o): In function `decimal_from_integral':
(.text+0x8d6): undefined reference to `decNumberFromInt32'
An error occurred while linking ./fp

Now I ask you, as experienced programmers, which is wrong? In libgdb? In libdecnumber? Between chair and keyboard?

Thank you for your patience.

Marco van de Voort

2010-05-30 14:20

manager   ~0038137

I'd say the libdecnumber doesn't match the one used to build libgdb.

Marelis

2010-06-27 16:21

reporter   ~0038831

I am no longer using Lazarus IDE. Today I am cleaning here and gone.

I pointed out the problem, make in that order, I wish good luck ;-)

Thanks.

alexey

2010-09-02 15:35

reporter   ~0040740

execute this command
make build OPT="-dGDB_V700"

and got this error

make[4]: Вход в каталог `/home/vay/freepascal/fpc/ide'
Makefile:289: Using system default libgdb file located in /usr/lib/libgdb.a
LibGDB found in /usr/lib/libgdb.a
make[4]: Выход из каталога `/home/vay/freepascal/fpc/ide'
make fpc_all
make[4]: Вход в каталог `/home/vay/freepascal/fpc/ide'
Makefile:289: Using system default libgdb file located in /usr/lib/libgdb.a
/home/vay/freepascal/fpc/compiler/ppc386 -di386 -Fl/home/vay/freepascal/fpc/libgdb/linux -Ur -Xs -O2 -n -Sg -Fu/home/vay/freepascal/fpc/rtl/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/fv/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/gdbint/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/regexpr/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/fcl-base/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/iconvenc/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/fcl-xml/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/chm/units/i386-linux -FE. -FUunits/i386-linux -Fl/usr/lib/gcc/i486-linux-gnu/4.4.3 -Flinclude -Fl/etc/ld.so.conf.d/*.conf -dGDB_V700 -dRELEASE fp.pas
/usr/bin/ld: warning: ./link.res contains output sections; did you forget -T?
/usr/bin/ld: cannot find -ldecnumber
fp.pas(552,1) Error: Error while linking
fp.pas(552,1) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
make[4]: *** [fp] Ошибка 1
make[4]: Выход из каталога `/home/vay/freepascal/fpc/ide'
make[3]: *** [buildfp] Ошибка 2
make[3]: Выход из каталога `/home/vay/freepascal/fpc/ide'
make[2]: *** [gdb] Ошибка 2
make[2]: Выход из каталога `/home/vay/freepascal/fpc/ide'
make[1]: *** [ide_all] Ошибка 2
make[1]: Выход из каталога `/home/vay/freepascal/fpc'
make: *** [build-stamp.i386-linux] Ошибка 2

help please?

alexey

2010-09-05 08:30

reporter   ~0040825

after added library and make again got this error

make[4]: Вход в каталог `/home/vay/freepascal/fpc/ide'
Makefile:289: Using system default libgdb file located in /usr/lib/libgdb.a
/home/vay/freepascal/fpc/compiler/ppc386 -di386 -Fl/home/vay/freepascal/fpc/libgdb/linux -Ur -Xs -O2 -n -Sg -Fu/home/vay/freepascal/fpc/rtl/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/fv/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/gdbint/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/regexpr/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/fcl-base/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/iconvenc/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/fcl-xml/units/i386-linux -Fu/home/vay/freepascal/fpc/packages/chm/units/i386-linux -FE. -FUunits/i386-linux -Fl/usr/lib/gcc/i686-linux-gnu/4.4.5 -Flinclude -Fl/etc/ld.so.conf.d/*.conf -dGDB_V700 -dRELEASE fp.pas
/usr/bin/ld: warning: ./link.res contains output sections; did you forget -T?
//usr/lib/libgdb.a(dfp.o): In function `decimal_from_integral':
(.text+0x85e): undefined reference to `decNumberFromUInt32'
//usr/lib/libgdb.a(dfp.o): In function `decimal_from_integral':
(.text+0x8d6): undefined reference to `decNumberFromInt32'
fp.pas(552,1) Error: Error while linking
fp.pas(552,1) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
make[4]: *** [fp] Ошибка 1
make[4]: Выход из каталога `/home/vay/freepascal/fpc/ide'
make[3]: *** [buildfp] Ошибка 2
make[3]: Выход из каталога `/home/vay/freepascal/fpc/ide'
make[2]: *** [gdb] Ошибка 2
make[2]: Выход из каталога `/home/vay/freepascal/fpc/ide'
make[1]: *** [ide_all] Ошибка 2
make[1]: Выход из каталога `/home/vay/freepascal/fpc'
make: *** [build-stamp.i386-linux] Ошибка 2

help?

AlexL

2013-01-03 16:52

reporter   ~0064589

Last edited: 2013-01-03 17:17

make[4]: Вход в каталог `/root/rpmbuild/BUILD/fpc-2.6.0/ide'
Makefile:320: Using system default libgdb file located in /usr/lib/libgdb.a
/root/rpmbuild/BUILD/fpc-2.6.0/compiler/ppc386 -di386 -Fl/root/rpmbuild/BUILD/fpc-2.6.0/libgdb/linux -Ur -Xs -O2 -n -Sg -Fu/root/rpmbuild/BUILD/fpc-2.6.0/rtl/units/i386-linux -Fu/root/rpmbuild/BUILD/fpc-2.6.0/packages/fv/units/i386-linux -Fu/root/rpmbuild/BUILD/fpc-2.6.0/packages/gdbint/units/i386-linux -Fu/root/rpmbuild/BUILD/fpc-2.6.0/packages/regexpr/units/i386-linux -Fu/root/rpmbuild/BUILD/fpc-2.6.0/packages/fcl-base/units/i386-linux -Fu/root/rpmbuild/BUILD/fpc-2.6.0/packages/iconvenc/units/i386-linux -Fu/root/rpmbuild/BUILD/fpc-2.6.0/packages/fcl-xml/units/i386-linux -Fu/root/rpmbuild/BUILD/fpc-2.6.0/packages/chm/units/i386-linux -FE. -FUunits/i386-linux -Fl/usr/lib/gcc/i586-mageia-linux-gnu/4.6.3 -Flinclude -Fl/etc/ld.so.conf.d/*.conf -dGDB_V700 -dRELEASE fp.pas
/usr/bin/ld: warning: ./link.res contains output sections; did you forget -T?
/usr/lib/libgdb.a(dfp.o): In function `decimal_from_integral':
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/gdb/../../gdb/dfp.c:229: undefined reference to `decNumberFromInt32'
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/gdb/../../gdb/dfp.c:227: undefined reference to `decNumberFromUInt32'
/usr/lib/libgdb.a(dwarf2read.o): In function `zlib_decompress_section':
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/gdb/../../gdb/dwarf2read.c:1565: undefined reference to `inflateInit_'
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/gdb/../../gdb/dwarf2read.c:1573: undefined reference to `inflate'
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/gdb/../../gdb/dwarf2read.c:1577: undefined reference to `inflateReset'
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/gdb/../../gdb/dwarf2read.c:1579: undefined reference to `inflateEnd'
/usr/lib/libbfd.a(compress.o): In function `bfd_compress_section_contents':
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/bfd/../../bfd/compress.c:100: undefined reference to `compressBound'
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/bfd/../../bfd/compress.c:106: undefined reference to `compress'
/usr/lib/libbfd.a(compress.o): In function `decompress_contents':
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/bfd/../../bfd/compress.c:61: undefined reference to `inflateEnd'
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/bfd/../../bfd/compress.c:49: undefined reference to `inflateInit_'
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/bfd/../../bfd/compress.c:59: undefined reference to `inflateReset'
/root/rpmbuild/BUILD/gdb-7.3.50.20110722/build-i586-mageia-linux-gnu/bfd/../../bfd/compress.c:56: undefined reference to `inflate'
fp.pas(552,1) Error: Error while linking

Equal result with -dGDB_V703

Marco van de Voort

2013-01-03 18:27

manager   ~0064594

Last edited: 2013-01-03 18:29

Your parameters show -dGDB_V700 while your errormessages show gdb-7.3.50. That doesn't match.

Moreover, I see mageia, while this is a debian/ubuntu bugreport.

Anyway, it seems your libgdb doesn't contain libdec, and needs an extra inclusion of zlib (compression). Adjust your gdbint appropriately

Marco van de Voort

2018-02-25 17:32

manager   ~0106627

Last edited: 2018-02-25 17:32

View 2 revisions

Very old ubuntu versions, no updates in years -> close.

Issue History

Date Modified Username Field Change
2009-12-07 08:34 Marelis New Issue
2009-12-07 08:34 Marelis File Added: 20091207_make_part.log.tar.gz
2009-12-07 08:35 Marelis File Added: 20091207_libgdb_symbols.log.tar.gz
2009-12-07 09:46 Marco van de Voort Note Added: 0032763
2009-12-07 10:20 Marelis Note Added: 0032764
2009-12-07 12:58 Jonas Maebe Note Added: 0032768
2009-12-07 13:22 Marelis Note Added: 0032772
2009-12-07 13:22 Marelis File Added: 20091207_make_deb.log.tar.gz
2009-12-08 20:58 Jonas Maebe FPCOldBugId => 0
2009-12-08 20:58 Jonas Maebe Summary FPC does not link against the new GDB 7 debugger => FPC does not link against Ubuntu's libgdb.a 7.0
2009-12-08 22:21 Marco van de Voort Note Added: 0032825
2009-12-09 09:52 Marelis Note Added: 0032832
2009-12-09 09:59 Jonas Maebe Note Added: 0032833
2009-12-09 10:20 Marelis Note Added: 0032836
2009-12-09 10:31 Jonas Maebe Note Added: 0032837
2009-12-09 11:23 Marelis Note Added: 0032840
2009-12-09 11:24 Marelis Note Edited: 0032840
2009-12-09 11:24 Marelis Note Edited: 0032840
2009-12-09 11:54 Pierre Muller Note Added: 0032841
2009-12-09 12:38 Marco van de Voort Note Added: 0032842
2009-12-09 12:49 Jonas Maebe Note Added: 0032843
2009-12-09 12:51 Marelis Note Added: 0032844
2009-12-09 13:42 Pierre Muller Note Added: 0032848
2009-12-09 14:50 Marelis Note Added: 0032850
2009-12-09 14:56 Pierre Muller Note Added: 0032851
2009-12-09 20:23 Marelis Note Added: 0032857
2009-12-09 20:23 Marelis Note Edited: 0032857
2009-12-10 01:02 Pierre Muller Note Added: 0032875
2009-12-10 11:13 Marelis Note Added: 0032897
2009-12-10 11:22 Marelis Note Edited: 0032897
2010-02-15 16:08 Marco van de Voort Note Added: 0034498
2010-02-19 23:01 Marco van de Voort Note Added: 0034612
2010-02-20 05:37 Marelis Note Added: 0034615
2010-02-20 05:51 Marelis Note Edited: 0034615
2010-02-20 12:13 Marco van de Voort Note Added: 0034617
2010-02-21 07:15 Marelis Note Added: 0034624
2010-05-30 14:20 Marco van de Voort Note Added: 0038137
2010-06-27 16:21 Marelis Note Added: 0038831
2010-09-02 15:12 Jonas Maebe Relationship added has duplicate 0017333
2010-09-02 15:35 alexey Note Added: 0040740
2010-09-05 08:30 alexey Note Added: 0040825
2010-09-09 15:11 Jonas Maebe Category Compiler => Packages
2013-01-03 16:52 AlexL Note Added: 0064589
2013-01-03 17:17 AlexL Note Edited: 0064589
2013-01-03 18:27 Marco van de Voort Note Added: 0064594
2013-01-03 18:29 Marco van de Voort Note Edited: 0064594
2018-02-25 17:32 Marco van de Voort Note Added: 0106627
2018-02-25 17:32 Marco van de Voort Status new => resolved
2018-02-25 17:32 Marco van de Voort Resolution open => no change required
2018-02-25 17:32 Marco van de Voort Assigned To => Marco van de Voort
2018-02-25 17:32 Marco van de Voort Note Edited: 0106627 View Revisions
2019-09-20 17:51 Marco van de Voort Status resolved => closed
2019-09-20 17:51 Marco van de Voort FPCTarget => -