View Issue Details

IDProjectCategoryView StatusLast Update
0015372LazarusIDEpublic2010-03-08 05:14
ReporterSeth Grover Assigned ToVincent Snijders  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.28.3 (SVN) 
Fixed in Version0.9.28.3 (SVN) 
Summary0015372: form designer component dragging fails
Description
I'm running Lazarus 0.9.28.3 beta (from fixes_0_9_28 branch in svn)
with FPC 2.4.0 (from release_2_4_0 tag in svn) under Ubuntu 9.10 with
the gtk2 widget set.

I run lazarus, and the default project comes up with a blank Form1, etc.

I drop a component, like a TButton or a TEdit onto the form. I click
on the component to select it. It selects correctly. I click and start
to drag the component to move it somewhere else on the form, and
rather than moving the component it just makes the dotted selection
box as if I've clicked on the form behind the component and i'm
dragging to select multiple items.

The end result is I'm only able to move components around my form by
clicking the component and doing ctrl+arrow keys or by manually
setting Top, Left, etc.

I've recorded a video of the phenomenon:

http://stashbox.org/729914/lazcomponentdrag.ogv

I reverted to the previous several revisions in that branch
(fixes_0_9_28) and found the following regarding this bug:

22886 - works fine, no dragging bug
22890 - lazarus fails to compile
22897+ - compiles, dragging bug is present

So this bug was either introduced in 22890 or 22897.
TagsNo tags attached.
Fixed in Revision23868
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

has duplicate 0015605 closedVincent Snijders Objects are not moveable on the design forms 
has duplicate 0015801 closedVincent Snijders I can't move the form's controls 

Activities

Seth Grover

2009-12-17 21:22

reporter   ~0033162

Note that the bug doesn't repro in the trunk, it's a problem with something merged back into the 0.9.28 fixes branch, which is where it needs to be fixed.

Graeme Geldenhuys

2009-12-22 08:01

reporter   ~0033249

I can confirm this bug. I'm using Ubuntu 8.04.3 and Lazarus with GTK2 widgetset.

Seth Grover

2010-02-12 00:13

reporter   ~0034398

Will this be fixed in the fixes_0_9_28 branch any time soon? I can't use trunk, but there are other fixes in this branch I do need. This bug makes 0.9.28.3 completely unusable.

Maxim Ganetsky

2010-03-07 23:54

developer   ~0035024

Works for me on Windows. Thanks, Vincent.

Seth Grover

2010-03-08 05:14

reporter   ~0035028

works in gtk2 now as well, thanks

Issue History

Date Modified Username Field Change
2009-12-17 21:20 Seth Grover New Issue
2009-12-17 21:20 Seth Grover Widgetset => GTK 2
2009-12-17 21:22 Seth Grover Note Added: 0033162
2009-12-17 22:41 Vincent Snijders Status new => assigned
2009-12-17 22:41 Vincent Snijders Assigned To => Vincent Snijders
2009-12-22 08:01 Graeme Geldenhuys Note Added: 0033249
2009-12-23 12:43 Vincent Snijders LazTarget => -
2009-12-23 12:43 Vincent Snijders Status assigned => confirmed
2010-01-28 14:40 Vincent Snijders Relationship added has duplicate 0015605
2010-02-12 00:13 Seth Grover Note Added: 0034398
2010-02-17 19:02 Vincent Snijders Relationship added has duplicate 0015801
2010-03-07 21:21 Vincent Snijders Fixed in Revision => 23868
2010-03-07 21:21 Vincent Snijders Status confirmed => resolved
2010-03-07 21:21 Vincent Snijders Fixed in Version => 0.9.28.3 (SVN)
2010-03-07 21:21 Vincent Snijders Resolution open => fixed
2010-03-07 23:54 Maxim Ganetsky Note Added: 0035024
2010-03-08 05:14 Seth Grover Status resolved => closed
2010-03-08 05:14 Seth Grover Note Added: 0035028