View Issue Details

IDProjectCategoryView StatusLast Update
0015374LazarusLCLpublic2011-08-11 10:59
ReporterLeslie KayeAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0015374: Missing Items property in TShellTreeView
DescriptionThe Items property is inaccessible in TShellListView because there is no override of the protected Items property in TCustomTreeView
Additional InformationI am using a TShellTreeView for file navigation in my application.
When running the application I want to open the directory which was selected when the application was previously closed.
In the mainform FormClose event I store the path of the selected treenode in an ini file.
In the mainform FormShow I want to parse the nodes to find the one which matches the path however this is not possible because there is no access to the protected Items property.
In TTreeView Items is a published property. This would not make sense in TShellTreeView instead Items should be exposed as a public property.
TagsNo tags attached.
Fixed in Revision25096
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Leslie Kaye

2011-08-11 10:59

reporter   ~0050707

Confirmed Fixed thanks.

Issue History

Date Modified Username Field Change
2009-12-17 23:43 Leslie Kaye New Issue
2009-12-17 23:43 Leslie Kaye Widgetset => Win32/Win64
2009-12-18 09:03 Vincent Snijders LazTarget => -
2009-12-18 09:03 Vincent Snijders Severity minor => feature
2009-12-18 09:03 Vincent Snijders Assigned To => Felipe Monteiro de Carvalho
2009-12-18 09:03 Vincent Snijders Status new => assigned
2010-05-01 14:37 Felipe Monteiro de Carvalho Fixed in Revision => 25096
2010-05-01 14:37 Felipe Monteiro de Carvalho Status assigned => resolved
2010-05-01 14:37 Felipe Monteiro de Carvalho Fixed in Version => 0.9.29 (SVN)
2010-05-01 14:37 Felipe Monteiro de Carvalho Resolution open => fixed
2011-08-11 10:59 Leslie Kaye Status resolved => closed
2011-08-11 10:59 Leslie Kaye Note Added: 0050707