View Issue Details

IDProjectCategoryView StatusLast Update
0015424LazarusLCLpublic2010-05-10 13:12
Reporternicola gorlandiAssigned ToFelipe Monteiro de Carvalho 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.29 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0015424: TLabel
DescriptionThe Tlabel top position inside a TTabSheet is use always as it is set to 0. All the labels inside the page are display in the first line. It seems a regression, I downloaded the daily snapshot of lazarus 0.9.29 FPC 2.2.4 on 10 th December and the label showed right.
TagsNo tags attached.
Fixed in Revision
LazTarget0.9.30
WidgetsetWinCE
Attached Files

Relationships

duplicate of 0014760 closedFelipe Monteiro de Carvalho TGroupBox in WinCE: Displacement of child controls / TLabel not visible 
duplicate of 0013457 assignedStephano WinCE - TPageControl not show TLabel TImage TSpeedButton and not show to top tabs 
related to 0015945 closedFelipe Monteiro de Carvalho Position of Tlabel wrong at runtime in wince. 

Activities

Felipe Monteiro de Carvalho

2010-03-09 23:40

developer   ~0035120

I don't know how it is possible that it worked on 10 Dez for you, I just tested a revision from 10 Dez: 23068 and it didn't work and I have a report from April 2009 saying it didn't work at that time: http://bugs.freepascal.org/view.php?id=13457

nicola gorlandi

2010-03-12 13:10

reporter   ~0035326

I'm sorry but I can't repeat the test now as when I wrote this issue.

It's sure that on 0.9.28 the TLabel position was right on WinCe. I start to porting my application on Lazarus 0.9.29 and it seems to me that everything worked fine until December 2009.

Paul van Helden

2010-03-12 16:34

reporter   ~0035364

This is the same as http://bugs.freepascal.org/view.php?id=15945

It seems all TGraphicControl decendants inside a panel or other container are getting Left,Top set to 0,0 at runtime

nicola gorlandi

2010-04-25 10:03

reporter   ~0036992

I made some tests but the problem doesn't appear anymore. Could it be solved ?

Felipe Monteiro de Carvalho

2010-04-26 10:53

developer   ~0037015

Sounds like it was! Here I also can't reproduce it

Felipe Monteiro de Carvalho

2010-04-26 10:57

developer   ~0037016

I don't think this is the same as 15945, this one seams fixed here but 15945 isn't

Felipe Monteiro de Carvalho

2010-04-26 11:30

developer   ~0037020

Somehow fixed in the mean time. Works with rev24958

Issue History

Date Modified Username Field Change
2009-12-25 10:29 nicola gorlandi New Issue
2009-12-25 10:29 nicola gorlandi Widgetset => WinCE
2009-12-25 11:07 Vincent Snijders LazTarget => 0.9.30
2009-12-25 11:07 Vincent Snijders Assigned To => Felipe Monteiro de Carvalho
2009-12-25 11:07 Vincent Snijders Status new => assigned
2009-12-25 11:07 Vincent Snijders Target Version => 0.9.30
2010-01-03 02:25 Felipe Monteiro de Carvalho Relationship added related to 0014760
2010-03-09 23:40 Felipe Monteiro de Carvalho Note Added: 0035120
2010-03-09 23:40 Felipe Monteiro de Carvalho Relationship added related to 0013457
2010-03-12 13:10 nicola gorlandi Note Added: 0035326
2010-03-12 16:34 Paul van Helden Note Added: 0035364
2010-04-25 10:03 nicola gorlandi Note Added: 0036992
2010-04-26 10:53 Felipe Monteiro de Carvalho Note Added: 0037015
2010-04-26 10:53 Felipe Monteiro de Carvalho Relationship added related to 0015945
2010-04-26 10:57 Felipe Monteiro de Carvalho Note Added: 0037016
2010-04-26 10:59 Felipe Monteiro de Carvalho Relationship replaced duplicate of 0014760
2010-04-26 11:04 Felipe Monteiro de Carvalho Relationship replaced duplicate of 0013457
2010-04-26 11:30 Felipe Monteiro de Carvalho Status assigned => resolved
2010-04-26 11:30 Felipe Monteiro de Carvalho Fixed in Version => 0.9.29 (SVN)
2010-04-26 11:30 Felipe Monteiro de Carvalho Resolution open => fixed
2010-04-26 11:30 Felipe Monteiro de Carvalho Note Added: 0037020
2010-05-10 13:12 nicola gorlandi Status resolved => closed