View Issue Details

IDProjectCategoryView StatusLast Update
0015450LazarusIDEpublic2015-11-26 19:11
ReporterSven BarthAssigned ToOndrej Pokorny 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version0.9.28Product Build 
Target VersionFixed in Version1.5 (SVN) 
Summary0015450: Lazarus should save window positions and sizes per resolution
DescriptionWhen I use Lazarus on my UMPC and I change the resolution by accident (wrong button) or on purpose (external monitor), the positions of Lazarus' windows are lost, when I reset the original resolution.

It would be nice if Lazarus saves the positions and sizes of its windows per resolution and reloads these settings on a resolution change.
Additional InformationI don't know about X or Carbon/Cocoa, but Windows notifies all processes with WM_DISPLAYCHANGE about a change in resolution and depth.

The attached screenshots show a sequence 1024x600 -> 800x480 -> 1024x600. The source editor window is moved to the left after the first resolution change and stays there after the second one.

Problem is similar, when a window is resized in the smaller resolution (to fit the screen), but not resized to "fill" the larger one.

Another case is a maximized window (Lazarus' main bar): the window is resized to fit the lower resolution and not restored to full size (but still in maxmized state!) once the resolution is increased again. Maybe the last problem is worth an extra issue ^^
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

2009-12-31 12:33

 

resolution-1024x600-1.png (80,633 bytes)
resolution-1024x600-1.png (80,633 bytes)

2009-12-31 12:34

 

resolution-800x480-1.png (49,701 bytes)
resolution-800x480-1.png (49,701 bytes)

2009-12-31 12:35

 

resolution-1024x600-2.png (81,231 bytes)
resolution-1024x600-2.png (81,231 bytes)

Jonas Schäfer

2010-01-03 13:56

reporter   ~0033441

Sounds nice… When this gets implemented, the following would be appreaciable:
when resolution changes:
  look for profile for this resolution
    if one is found, apply that profile (even save the visibility state of windows in these profiles?)
    if none is found, use the current and scale window positions and sizes according to the factors you get when you divide the old resolution by the new one. Exclude the main bar window from this, since it does not make any sense to scale this vertically (but horizontally would be nice, of course).

just a few cents ;)

Ondrej Pokorny

2015-11-26 19:11

reporter   ~0087617

Resolved with the Desktops feature.

Issue History

Date Modified Username Field Change
2009-12-31 12:33 Sven Barth New Issue
2009-12-31 12:33 Sven Barth File Added: resolution-1024x600-1.png
2009-12-31 12:34 Sven Barth File Added: resolution-800x480-1.png
2009-12-31 12:35 Sven Barth File Added: resolution-1024x600-2.png
2009-12-31 13:41 Vincent Snijders LazTarget => post 1.2
2009-12-31 13:41 Vincent Snijders Status new => acknowledged
2010-01-03 13:56 Jonas Schäfer Note Added: 0033441
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4
2014-09-16 22:40 Juha Manninen LazTarget 1.4 => -
2015-11-26 19:11 Ondrej Pokorny Note Added: 0087617
2015-11-26 19:11 Ondrej Pokorny Status acknowledged => resolved
2015-11-26 19:11 Ondrej Pokorny Fixed in Version => 1.5 (SVN)
2015-11-26 19:11 Ondrej Pokorny Resolution open => fixed
2015-11-26 19:11 Ondrej Pokorny Assigned To => Ondrej Pokorny