View Issue Details

IDProjectCategoryView StatusLast Update
0015451LazarusDatabasepublic2012-03-06 01:37
ReporterHandoko Assigned ToLuiz Americo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSwin32 
Product Version0.9.28.2 
Target Version1.0.0 
Summary0015451: TDBLookupComboBox cause an "EVariant Error" on ListSource that has index fields.
DescriptionI think it's a bug in TDBLookupComboBox.

- It won't happen on ListSource without index field.
- It won't happen on ListSource with one index field.
- It do happen on ListSource with 2 index fields.

Please try the source I've attached. The last DBLookupComboBox (which link to a indexed dbf as ListSource) causes an "EVariant Error" when you change the value.

=== Task.dbf ===
- TASKID string[15]
- USERID string[15]
- DESC string[40]
no indexes

=== User.dbf ===
- USERID string[15]
- USERNAME string[40]
no indexes

=== User_IDX.dbf === (the DBLookupComboBox will error if link to this file)
- USERID string[15]
- USERNAME string[40]
2 indexes (USERID, USERNAME)
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Activities

2010-01-01 08:52

 

Test01.zip (95,203 bytes)

Luiz Americo

2012-02-04 15:25

developer   ~0056461

1) TDBLookup* controls received a lot of changes in 2011. Can you test with a recent svn version of Lazarus to see if still occurs?

2) The attached demo is missing the lpr file and the data files. If the issue is still present attach a new example with the missing files

Luiz Americo

2012-02-04 15:26

developer   ~0056462

Reminder sent to: Handoko

Please retest this bug

Luiz Americo

2012-03-06 01:37

developer   ~0057303

Seems to be fixed in the mean time.
Marked as resolved since user does not replied

Issue History

Date Modified Username Field Change
2010-01-01 08:52 Handoko New Issue
2010-01-01 08:52 Handoko File Added: Test01.zip
2010-01-01 08:52 Handoko Widgetset => Win32/Win64
2010-03-12 13:01 Vincent Snijders LazTarget => 1.0
2010-03-12 13:01 Vincent Snijders Status new => acknowledged
2010-03-12 13:01 Vincent Snijders Target Version => 1.0.0
2012-02-04 12:26 Zeljan Rikalo Assigned To => Luiz Americo
2012-02-04 12:26 Zeljan Rikalo Status acknowledged => assigned
2012-02-04 15:25 Luiz Americo Note Added: 0056461
2012-02-04 15:25 Luiz Americo Status assigned => feedback
2012-02-04 15:26 Luiz Americo Note Added: 0056462
2012-03-06 01:37 Luiz Americo Status feedback => resolved
2012-03-06 01:37 Luiz Americo Resolution open => fixed
2012-03-06 01:37 Luiz Americo Note Added: 0057303