View Issue Details

IDProjectCategoryView StatusLast Update
0015462LazarusLCLpublic2010-01-05 15:12
Reporterbefelemepeseveze Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86-64OSUbuntu 
Product Version0.9.29 (SVN) 
Fixed in Version0.9.29 (SVN) 
Summary0015462: Lazarus doesn't compile with FPC 2.5.1. r14536 (SVN curent)
Descriptionlclmemmanager.pas(278,27) Error: function header doesn't match any method of this class "TExtMemoryStream.Realloc(var LongInt):^untyped;"
lclmemmanager.pas(283,40) Error: Call by var for arg no. 1 has to match exactly: Got "LongInt" expected "Int64"
lclmemmanager.pas(288) Fatal: There were 2 errors compiling module, stopping
Steps To Reproducecd ~/svn/lazarus/trunk
make clean
make all install INSTALL_PREFIX=~
Additional InformationPlease review a hotfix working for me:

15:40 myname@tux64:~/svn/lazarus/trunk/lcl$ svn diff lclmemmanager.pas
Index: lclmemmanager.pas
===================================================================
--- lclmemmanager.pas (revision 23367)
+++ lclmemmanager.pas (working copy)
@@ -95,7 +95,7 @@
   
   TExtMemoryStream = class(TMemoryStream)
   protected
- function Realloc(var NewCapacity: Longint): Pointer; override;
+ function Realloc(var NewCapacity: PtrInt): Pointer; override;
   public
     property Capacity;
   end;
@@ -275,7 +275,7 @@
 
 { TExtMemoryStream }
 
-function TExtMemoryStream.Realloc(var NewCapacity: LongInt): Pointer;
+function TExtMemoryStream.Realloc(var NewCapacity: PtrInt): Pointer;
 begin
   // if we are growing, grow at least a quarter
   if (NewCapacity>Capacity) then
15:40 myname@tux64:~/svn/lazarus/trunk/lcl$
TagsNo tags attached.
Fixed in Revision23385
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Vincent Snijders

2010-01-04 16:21

manager   ~0033451

64 bits only issue, win32 compiles without error.

Paul Ishenin

2010-01-05 14:36

manager   ~0033458

You can't unconditionally change to PtrInt because then fpc 2.4.0 will not work with lazarus :) I've fixed it using condition. Please test and close if ok.

befelemepeseveze

2010-01-05 15:11

reporter   ~0033461

You're right. Tested here with FPC 2.5.1 and works ok. Thanks for fixing :)

Issue History

Date Modified Username Field Change
2010-01-04 15:44 befelemepeseveze New Issue
2010-01-04 15:44 befelemepeseveze Widgetset => GTK 2
2010-01-04 16:21 Vincent Snijders Note Added: 0033451
2010-01-05 14:36 Paul Ishenin Fixed in Revision => 23385
2010-01-05 14:36 Paul Ishenin LazTarget => -
2010-01-05 14:36 Paul Ishenin Status new => resolved
2010-01-05 14:36 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-01-05 14:36 Paul Ishenin Resolution open => fixed
2010-01-05 14:36 Paul Ishenin Assigned To => Paul Ishenin
2010-01-05 14:36 Paul Ishenin Note Added: 0033458
2010-01-05 15:11 befelemepeseveze Note Added: 0033461
2010-01-05 15:12 befelemepeseveze Status resolved => closed