View Issue Details

IDProjectCategoryView StatusLast Update
0015464LazarusIDEpublic2011-12-01 11:23
Reporterequinox Assigned ToZeljan Rikalo  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformWindows OS7 
Product Version0.9.29 (SVN) 
Summary0015464: cannot change the name of an object in property editor
DescriptionHi,
I was able to change the name of an object in past, I cannot do so now.

In my case, I could not change the name of a checkbox.
If I tried to change the name of the checkbox, the cursor jumps to the first column and nothing happens. As if somekind of timer worked in the background which resets the field to its original value...

TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0017487 closedVincent Snijders TAB in Object Inspector causes problem 

Activities

equinox

2010-01-04 21:11

reporter   ~0033452

Ok, to be exact, I can change the name of object generally.
I cannot change the name of a checkbox if it is inside a groupbox.

So test it, make a groupbox and a checkbox in a groupbox.

samuel herzog

2010-01-05 23:26

developer   ~0033476

Can not reproduce this report with SVN 23386 on win32. Works fine here.

equinox

2010-01-18 17:19

reporter   ~0033731

Ok, my example was not complete enough.

I have the problem if I make one groupbox, then two checkboxes in the groupbox.
If there is one checkbox only, there is no problem.

Paul Ishenin

2010-01-19 04:28

manager   ~0033740

Create a test project and attach it here. We will try to change the name proeprty then :)

2010-02-19 09:44

 

namecannotbechanged.zip (160,850 bytes)

equinox

2010-02-19 09:45

reporter   ~0034592

Last edited: 2010-02-19 09:46

I added a test project which exhibits the bad behaviour.

Mattias Gaertner

2010-02-23 20:53

manager   ~0034711

I tried the example. I can change the names of the checkboxes under linux/gtk2.

equinox

2010-03-22 17:29

reporter   ~0035923

I am on WIndows 7!!!!!!!!!!!!

Alexander S. Klenin

2010-03-22 18:19

developer   ~0035924

Works for me on WinXP, Lazarus r24148

Tomasz Wieckowski

2010-03-22 20:05

reporter   ~0035931

I can't reproduce on my Win7. Your example works fine. (r24159)

equinox

2010-03-28 10:08

reporter   ~0036182

I cannot see the problem any longer ih current version.
r24216

equinox

2010-03-28 10:09

reporter   ~0036183

You can close this.

Zeljan Rikalo

2010-03-28 10:17

developer   ~0036184

Fixed in the meantime, reporter confirmed that bug does not exist anymore

Issue History

Date Modified Username Field Change
2010-01-04 19:40 equinox New Issue
2010-01-04 19:40 equinox Widgetset => Win32/Win64
2010-01-04 21:11 equinox Note Added: 0033452
2010-01-05 23:26 samuel herzog Note Added: 0033476
2010-01-18 17:19 equinox Note Added: 0033731
2010-01-19 04:28 Paul Ishenin LazTarget => -
2010-01-19 04:28 Paul Ishenin Note Added: 0033740
2010-01-19 04:28 Paul Ishenin Status new => feedback
2010-02-19 09:44 equinox File Added: namecannotbechanged.zip
2010-02-19 09:45 equinox Note Added: 0034592
2010-02-19 09:46 equinox Note Edited: 0034592
2010-02-23 20:53 Mattias Gaertner Note Added: 0034711
2010-03-22 17:29 equinox Note Added: 0035923
2010-03-22 18:19 Alexander S. Klenin Note Added: 0035924
2010-03-22 20:05 Tomasz Wieckowski Note Added: 0035931
2010-03-28 10:08 equinox Note Added: 0036182
2010-03-28 10:09 equinox Note Added: 0036183
2010-03-28 10:17 Zeljan Rikalo Status feedback => resolved
2010-03-28 10:17 Zeljan Rikalo Resolution open => fixed
2010-03-28 10:17 Zeljan Rikalo Assigned To => Zeljan Rikalo
2010-03-28 10:17 Zeljan Rikalo Note Added: 0036184
2010-09-25 10:51 Juha Manninen Relationship added related to 0017487
2011-12-01 11:23 Marc Weustink Status resolved => closed