View Issue Details

IDProjectCategoryView StatusLast Update
0015487LazarusLCLpublic2011-02-23 23:40
Reporterstocki Assigned ToPaul Ishenin  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version0.9.29 (SVN) 
Fixed in Version0.9.31 (SVN) 
Summary0015487: Application.MainFormOnTaskbar does not exist
DescriptionProperty Application.MainFormOnTaskbar does not exist.
A description can be found here:
http://docwiki.embarcadero.com/VCL/en/Forms.TApplication.MainFormOnTaskBar
  
  
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0017311 closedPaul Ishenin Patches There is no MainFormOnTaskBar property in Lazarus 

Activities

Flávio Etrusco

2010-03-12 23:21

developer   ~0035410

This seems a bit tricky to implement...
Also, this is basically a fix to allow Delphi applications to display the preview hint in taskbar, on Windows Vista and 7 (Home Premium and up). Do LCL apps show the preview?

Flávio Etrusco

2010-03-23 01:51

developer   ~0035950

Let's rephrase it: IMHO this is a "WONTFIX". Specific issues should be reported on separate issues, and the fix won't necessarily implement Application.MainFormOnTaskbar.

Paul Ishenin

2011-02-22 07:51

manager   ~0046187

Please test and close if ok

Issue History

Date Modified Username Field Change
2010-01-09 17:51 stocki New Issue
2010-01-09 17:51 stocki Widgetset => Win32/Win64
2010-01-09 18:33 Vincent Snijders LazTarget => -
2010-01-09 18:33 Vincent Snijders Severity minor => feature
2010-01-09 18:33 Vincent Snijders Status new => acknowledged
2010-03-12 23:21 Flávio Etrusco Note Added: 0035410
2010-03-23 01:51 Flávio Etrusco Note Added: 0035950
2011-02-22 07:51 Paul Ishenin Relationship added duplicate of 0017311
2011-02-22 07:51 Paul Ishenin Duplicate ID 0 => 17311
2011-02-22 07:51 Paul Ishenin Status acknowledged => resolved
2011-02-22 07:51 Paul Ishenin Fixed in Version => 0.9.31 (SVN)
2011-02-22 07:51 Paul Ishenin Resolution open => duplicate
2011-02-22 07:51 Paul Ishenin Assigned To => Paul Ishenin
2011-02-22 07:51 Paul Ishenin Note Added: 0046187
2011-02-23 23:40 stocki Status resolved => closed