View Issue Details

IDProjectCategoryView StatusLast Update
0015516LazarusIDEpublic2011-12-01 11:23
ReporterBPsoftwareAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platform32 bitOSWindowsOS VersionXP-SP2
Product VersionProduct Build 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0015516: TPageControl Large icons do not update directly into IDE
DescriptionForum topic: http://lazarus.freepascal.org/index.php/topic,8384.msg40521.html#new

Hi,
I am using a page control with the tabs on the left side. The icons are of a large dimension 48x48.
When I apply the icons, I can see that they appear, but the tab remains of the small 16 pixels size.
When compiled the tabs become larger and the problem is solved
I have to save the project, close and reopen the project to have large icons also in the editor.
Is this a bug?
Steps To ReproduceOpen Lazarus
Create an empty project
Put a Page Control on the Form
Put a Icon List on the form
Put some icons on the IconList
Assign the IconList to the PageControl
Put some tabs on the page control
NOW the icons should appear based on the ID
Go to the IconList and change the height and width of the icons to 48 pixels
The TPageControl shows the large icons, but the tabs now remain small
Compile
The tabs are now larger
Save the project, close and reopen the IDE, now the tabs are large also in design time
TagsNo tags attached.
Fixed in Revision23602
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Paul Ishenin

2010-01-30 17:16

manager   ~0034081

Please test and close if ok.

Issue History

Date Modified Username Field Change
2010-01-14 18:35 BPsoftware New Issue
2010-01-14 20:19 Marco van de Voort Project FPC => Lazarus
2010-01-30 17:16 Paul Ishenin Fixed in Revision => 23602
2010-01-30 17:16 Paul Ishenin LazTarget => -
2010-01-30 17:16 Paul Ishenin Widgetset => Win32/Win64
2010-01-30 17:16 Paul Ishenin Status new => resolved
2010-01-30 17:16 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-01-30 17:16 Paul Ishenin Resolution open => fixed
2010-01-30 17:16 Paul Ishenin Assigned To => Paul Ishenin
2010-01-30 17:16 Paul Ishenin Note Added: 0034081
2011-12-01 11:23 Marc Weustink Status resolved => closed