View Issue Details

IDProjectCategoryView StatusLast Update
0015554FPCTextmode IDEpublic2010-11-13 20:57
ReporterMait Lang Assigned ToPierre Muller  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformceleronOSXP 
Target Version2.4.2Fixed in Version2.4.2 
Summary0015554: Can't compile in IDE after first error
DescriptionIn IDE 1.0.12 from FPC 2.4.0 release for Win32, Win64 and WinCE compilation of a program after first error is not possible. Every next compilation trial stops and in "Compiler messages" window is displayed "Fatal: Compilation aborted". In verbose mode the last message before is Macro_defined: FPC_HAS_FEATURE_SOFTFPU. Compiling of other open programs also not possible. Restarting IDE helps until next error.
Steps To Reproduce{Simple program}
Program CMPInIDE;
begin
        WriteLn('Compiled within IDE.');
end.
// compiling in IDE works

// *-- make an error
Program CMPInIDE;
begin
        WriteLn('Compiled within IDE.' , );
end.

// compilation in IDE ends with correct error message "Error: Illegal expression ..." followed by "Fatal: syntax error ..."


// *-- fix error but compilation in IDE is not possible and ends with
   Macro_defined: FPC_HAS_FEATURE_SOFTFPU.
  "Fatal: Compilation aborted"
Additional InformationNo problems with IDE 1.0.10 and FPC 2.2.4
TagsNo tags attached.
Fixed in Revision14762
FPCOldBugId0
FPCTarget
Attached Files

Relationships

has duplicate 0015778 closedJonas Maebe No error messages displayed 
has duplicate 0016740 closedJonas Maebe Compiler via IDE sometimes fails to work - "Fatal: Compilation aborted" 
has duplicate 0017029 closedJonas Maebe (Usually) The first time a program is compiled, the IDE becomes UNUSABLE 

Activities

Marco van de Voort

2010-01-20 22:38

manager   ~0033757

I've seen this error too, but it is not always. IOW sometimes if I try to reproduce it, I'm not succeeding.
It might depend on the window or the number of files open.

If you find a rock solid reproduction way, please let me know.

Pierre Muller

2010-01-21 10:10

developer   ~0033760

 Text mode IDE was not correctly adapted to a new feature
of the compiler (whome program optimization)
http://wiki.freepascal.org/Whole_Program_Optimization
  A fix is currently under discussion by the core team.

Mait Lang

2010-01-21 10:32

reporter   ~0033761

Hi,

I filled the "Steps To Reproduce" field in the original posting (but this info has lost somehow?). The error is always reproducible in my computer.


// *Steps To Reproduce *
// start IDE
// write simple code and compile and it is ok
Program CMPInIDE;
begin
        WriteLn('Compiled within IDE.');
end.
 
// make a syntax error, compile and all error messages appare as jusual
Program CMPInIDE;
begin
        WriteLn('Compiled within IDE.' , );
end.

// However nevertheless the error is corrected or not the next compilations are not possible and end always in all windows (if one or more windows opened) with "Fatal: Compilation aborted" in "Compiler messages" window just after "Macro_defined: FPC_HAS_FEATURE_SOFTFPU" in verbose mode.

At present I can't use the IDE from the latest 2.4.0 release in my computer :(.

Pierre Muller

2010-01-21 11:59

developer   ~0033763

I hope that we solved the problem:
The fix is in rev 14760 in trunk
and rev 14761-14762 in fixes_2_4 branch.

I made a special i386-win32 snapshot with DEBUG=1 set
available for download at:
ftp://ftp.freepascal.org/pub/fpc/snapshot/v24/i386-win32/fpc-2.4.1debug.i386-win32.zip

Could you try it out?

Mait Lang

2010-01-21 12:27

reporter   ~0033764

The problem is gone.

Thank you!

Issue History

Date Modified Username Field Change
2010-01-20 14:11 Mait Lang New Issue
2010-01-20 22:38 Marco van de Voort Note Added: 0033757
2010-01-21 10:10 Pierre Muller Note Added: 0033760
2010-01-21 10:10 Pierre Muller Assigned To => Pierre Muller
2010-01-21 10:10 Pierre Muller Status new => acknowledged
2010-01-21 10:10 Pierre Muller Target Version => 2.4.2
2010-01-21 10:32 Mait Lang Note Added: 0033761
2010-01-21 11:59 Pierre Muller Note Added: 0033763
2010-01-21 12:27 Mait Lang Note Added: 0033764
2010-01-22 09:01 Pierre Muller Fixed in Revision => Fixes in trunk and fixes_2_4 branch
2010-01-22 09:01 Pierre Muller Status acknowledged => resolved
2010-01-22 09:01 Pierre Muller Fixed in Version => 2.4.1
2010-01-22 09:01 Pierre Muller Resolution open => fixed
2010-02-15 19:14 Jonas Maebe Relationship added has duplicate 0015778
2010-06-16 23:37 Jonas Maebe Relationship added has duplicate 0016740
2010-07-25 14:02 Jonas Maebe Relationship added has duplicate 0017029
2010-11-13 20:57 Jonas Maebe FPCOldBugId => 0
2010-11-13 20:57 Jonas Maebe Fixed in Revision Fixes in trunk and fixes_2_4 branch => 14762
2010-11-13 20:57 Jonas Maebe Description Updated
2010-11-13 20:57 Jonas Maebe Status resolved => closed