View Issue Details

IDProjectCategoryView StatusLast Update
0015630LazarusCompilerpublic2011-12-01 11:23
ReporterCarlos ValenteAssigned ToPaul Ishenin 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformi386OSLinuxOS VersionUbuntu 9.10
Product VersionProduct Build20100130 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0015630: Rebuild Lazarus fails for some reason
DescriptionConfigure "Build Lazarus" -> Build IDE with Packages: Target gtk 2 (beta) and IDE gtk 2 (beta)

Free Pascal Compiler version 2.4.0 [2010/01/29] for i386
Copyright (c) 1993-2009 by Florian Klaempfl
Target OS: Linux for i386
Compiling codetools.pas
Compiling basiccodetools.pas
Compiling sourcelog.pas
Compiling fileprocs.pas
Compiling codetoolsstrconsts.pas
Writing Resource String Table file: codetoolsstrconsts.rst
/usr/lib/lazarus/components/codetools/codetoolsstrconsts.pas(280) Error: Writing Resource String Table file: /usr/lib/lazarus/components/codetools/units/i386-linux/codetoolsstrconsts.rst
/usr/lib/lazarus/components/codetools/codetoolsstrconsts.pas(280) Fatal: There were 1 errors compiling module, stopping

I can not save changes in Lazarus Environment - IDE Options

The following message appears:

Error writing setting file: /usr/lib/lazarus/JCFSettings.cfg is read only
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Zeljan Rikalo

2010-01-30 09:40

developer   ~0034060

1.You have no permissions to write that file.
2.Maybe you run into ulimit fpcres bug

Paul Ishenin

2010-01-30 11:39

manager   ~0034064

I think both problems relates to permitions

Carlos Valente

2010-01-30 11:41

reporter   ~0034065

> 2.Maybe you run into ulimit fpcres bug

How do it?

Carlos Valente

2010-01-30 13:30

reporter   ~0034071

> I think both problems relates to permitions

Ok, but how do it ?

Paul Ishenin

2010-01-30 16:56

manager   ~0034079

I changed JCF code to store configuration file near the environment options settings and other lazarus configs. So since now it will be placed to the writable location. Please test this.

Paul Ishenin

2010-01-30 17:01

manager   ~0034080

I set status to resolved since JCF problem is fixed in the trunk and to rebuild lazarus either install it to the home directory (you can download from svn there or copy from your /usr/lib) or start lazarus using admin rights (not preferrable).

Carlos Valente

2010-01-30 19:17

reporter   ~0034087

Last edited: 2010-01-30 19:18

I changed the lazarus directory /usr/lib/lazarus to ~/lazarus, worked perfectly for me. Case closed.

Issue History

Date Modified Username Field Change
2010-01-29 21:43 Carlos Valente New Issue
2010-01-29 21:55 Jonas Maebe Project FPC => Lazarus
2010-01-30 09:40 Zeljan Rikalo Note Added: 0034060
2010-01-30 11:39 Paul Ishenin Note Added: 0034064
2010-01-30 11:41 Carlos Valente Note Added: 0034065
2010-01-30 13:30 Carlos Valente Note Added: 0034071
2010-01-30 16:56 Paul Ishenin Note Added: 0034079
2010-01-30 17:01 Paul Ishenin LazTarget => -
2010-01-30 17:01 Paul Ishenin Status new => resolved
2010-01-30 17:01 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-01-30 17:01 Paul Ishenin Resolution open => fixed
2010-01-30 17:01 Paul Ishenin Assigned To => Paul Ishenin
2010-01-30 17:01 Paul Ishenin Note Added: 0034080
2010-01-30 19:16 Carlos Valente Status resolved => assigned
2010-01-30 19:16 Carlos Valente Resolution fixed => reopened
2010-01-30 19:17 Carlos Valente Note Added: 0034087
2010-01-30 19:18 Carlos Valente Note Edited: 0034087
2010-01-30 19:58 Vincent Snijders Status assigned => resolved
2010-01-30 19:58 Vincent Snijders Resolution reopened => fixed
2011-12-01 11:23 Marc Weustink Status resolved => closed