View Issue Details

IDProjectCategoryView StatusLast Update
0015631LazarusLCLpublic2011-12-01 11:23
Reporteruser268Assigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build23595 
Target VersionFixed in Version0.9.29 (SVN) 
Summary0015631: TImage fail to display BMP picture on LoadFromFile method
DescriptionLinux, i386, GTK2

Next code simply do nothing:
Image1.Picture.LoadFromFile('./Test.bmp');

Picture Test.bmp is small 32bpp image (readable in gimp, browser, etc). When use TBitmap to load picture, copy to TLazIntfImage and then assign by Image1.Picture.Assign(bmp) it show it with no problem.
Steps To Reproduce1. Create new project from wizard
2. Insert a TImage
3. In Create form even insert code:
   Image1.Picture.LoadFromFile('./Test.bmp');

TagsNo tags attached.
Fixed in Revision23615
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0015644 closedPaul Ishenin unsupported BMP file in bitmap 

Activities

user268

2010-01-30 11:20

  ~0034063

Last edited: 2010-01-30 11:21

This seems to be related with 0015128.

user268

2010-01-30 12:31

  ~0034069

TBitmap class seems to not finished yet:

procedure TCustomBitmap.SetPixelFormat(AValue: TPixelFormat);
begin
  if AValue = FPixelFormat then Exit;
  {$IFDEF VerboseLCLTodos}{$note todo copy image into new format }{$ENDIF}
  FreeImage;
  FPixelFormat := AValue;
end;

Etc...

SEN

2010-02-02 08:03

reporter   ~0034149

Last edited: 2010-02-02 09:11

when will be fix (finish) that?

Paul Ishenin

2010-02-03 04:44

manager   ~0034175

Everything must work. Please attach your Test.bmp and maybe the whole test project.

user268

2010-02-03 06:11

  ~0034178

Last edited: 2010-02-03 06:16

Not supported 32bpp bitmaps on non-Windows platform (concrete Linux GTK2). Try to convert and execute attached code from 0015617 (included source, Windows executable and test bitmap).

Note: remove pixel conversion from sample to avoid picture deletion.

More test images from 0015644.

Paul Ishenin

2010-02-03 11:09

manager   ~0034188

If the bug is the same as 0015644 then please test and close if ok.

Issue History

Date Modified Username Field Change
2010-01-29 23:55 user268 New Issue
2010-01-29 23:55 user268 Widgetset => GTK 2
2010-01-30 11:20 user268 Note Added: 0034063
2010-01-30 11:21 user268 Note Edited: 0034063
2010-01-30 12:31 user268 Note Added: 0034069
2010-02-02 08:03 SEN Note Added: 0034149
2010-02-02 09:11 SEN Note Edited: 0034149
2010-02-03 04:44 Paul Ishenin LazTarget => -
2010-02-03 04:44 Paul Ishenin Note Added: 0034175
2010-02-03 04:44 Paul Ishenin Status new => feedback
2010-02-03 06:11 user268 Note Added: 0034178
2010-02-03 06:14 user268 Note Edited: 0034178
2010-02-03 06:16 user268 Note Edited: 0034178
2010-02-03 11:07 Paul Ishenin Relationship added related to 0015644
2010-02-03 11:09 Paul Ishenin Fixed in Revision => 23615
2010-02-03 11:09 Paul Ishenin Status feedback => resolved
2010-02-03 11:09 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-02-03 11:09 Paul Ishenin Resolution open => fixed
2010-02-03 11:09 Paul Ishenin Assigned To => Paul Ishenin
2010-02-03 11:09 Paul Ishenin Note Added: 0034188
2011-12-01 11:23 Marc Weustink Status resolved => closed